Unable to get centralised database working

Discussion in 'General Support' started by 1gkar, August 30, 2009.

  1. 1gkar
    • Premium Supporter

    1gkar MP Donator

    Joined:
    July 1, 2007
    Messages:
    236
    Likes Received:
    23
    Ratings:
    +37 / 0
    Home Country:
    New Zealand New Zealand
    Show System Specs
    Have finished setting up the music area: what a job. Now, I wish to reap the rewards of my main HTPC's plugins for bedtime viewing. Specifically, TV Series & Moving Pictures.



    I am restricted to an earlier version of MP: 1.0.0RC4 because of the rendering changes of 1080i with v1.0.1+.

    Hence, I am using an earlier version of Streamed MP as my skin: v0.4.298. Have posted to see if I can utilise later skin editions with my MP version in Skins forum. MP-TVSeries is v2.0.3296. Moving Pictures is: v0.7.2.545

    I understand Moving Pictures plugin did not incorporate centralised database options with this version, so not worrying about it at this time. Will investigate after I get other areas sorted.

    I have setup a share as outlined in the Centralised Database WIKI page.

    When I open the client machine & go to the TVSeries plugin, I get the basic page opening but with no thumbs/images & the media files will not open. I can playback media files on client machine fine after setting up folders in 'MP Config\Movies\Movie Folders'

    I am getting a number of SQLiteClient error codes. I have included the log from the most recent attempt. Any insights would be greatly appreciated.
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. rekenaar
    • Premium Supporter

    rekenaar Retired Team Member

    Joined:
    December 17, 2006
    Messages:
    4,421
    Likes Received:
    782
    Ratings:
    +785 / 0
    Home Country:
    South Africa South Africa
    Hi 1gkar :)

    I am a very happy user of the centralised DB. Not sure what your problem is, but let me ask a few questions as checkpoints for you.
    • Your log fie is full of READONLY messages. Are your shares set up with full rights?
    • Did you specify UNC patch in mediaportaldirs.xml for database and thumbs directory? (On my setup also for skin)
    • Same mediaportaldirs.xml in use on both clients?
    • Did you specify UNC location for your TVSeries locations inside the TVSeries Config program?
    • If you open TVSeries Config, does it show your database is located in the UNC path as specified by mediaportaldirs.xml? On both clients?
    • Are you accessing only from one client at a time?
     
  4. 1gkar
    • Premium Supporter

    1gkar MP Donator

    Joined:
    July 1, 2007
    Messages:
    236
    Likes Received:
    23
    Ratings:
    +37 / 0
    Home Country:
    New Zealand New Zealand
    Show System Specs
     
  5. rekenaar
    • Premium Supporter

    rekenaar Retired Team Member

    Joined:
    December 17, 2006
    Messages:
    4,421
    Likes Received:
    782
    Ratings:
    +785 / 0
    Home Country:
    South Africa South Africa
    Not sure if it is a requirement. Worth testing if other points below does not work.

    I only mean it must be set up as \\server\share and not by using a mapped network drive.

    Yip. Means both clients use exactly same skin layout (example my customized basic home). Only maintained on one place.

    Yes, the import paths. If I recall correctly, it is stored in database. My guess is that this is your problem.

    I use the modified one, with UNC location, on both. Have not tried it otherwise so not sure. Also a point to experiment if you struggle.

    Yip

    Really hope some of this points will help you.
     
  6. rekenaar
    • Premium Supporter

    rekenaar Retired Team Member

    Joined:
    December 17, 2006
    Messages:
    4,421
    Likes Received:
    782
    Ratings:
    +785 / 0
    Home Country:
    South Africa South Africa
    Not sure if it is a requirement. Worth testing if other points below does not work.

    I only mean it must be set up as \\server\share and not by using a mapped network drive.

    Yip. Means both clients use exactly same skin layout (example my customized basic home). Only maintained on one place.

    Yes, the import paths. If I recall correctly, it is stored in database.

    I use the modified one, with UNC location, on both. Have not tried it otherwise so not sure. Also a point to experiment if you struggle.

    Yip

    Really hope some of this points will help you.
     
    • Like Like x 1
  7. 1gkar
    • Premium Supporter

    1gkar MP Donator

    Joined:
    July 1, 2007
    Messages:
    236
    Likes Received:
    23
    Ratings:
    +37 / 0
    Home Country:
    New Zealand New Zealand
    Show System Specs
    OK. I went back through & checked everything. I adjusted the folders to allow them to be changed inside the network & sharing area. I then reinstalled the MSSQL & then reopened the TVSeries (TVS) config, & all the errors were gone & I could reset the import paths.

    I used 'Start Import' in the TVS config as there were still issues with thumbs & media playback. It imported all the banners & thumbs. I can now playback media with the thumbs present inside MP.

    Questions: it saved the banners/thumbs to the local, default directory. I can see the paths in 'TVS\config\about' & can link to them, using the 'show' link, but cannot alter them to my shared thumbs folder. Maybe this is a limitation with this version? Might try a later version when I get more time: in a weekend.

    Also, why is it necessary to setup a shared database/thumbs directories & copy the information across from the original folders in the Mediaportal directory on the singleseat HTPC? Does that not mean an extra set of files to manually update when the originals are updated. Would it not be better to simply copy the original mediaportaldirs.xml file to the shared\config folder & modify the paths to direct to the default database/thumbs folders, in the remote client machine. I ssume this is not possible as it is stipulated they should be the same on both machines. But I can't see how the modified one on the singleseat is automatically updated when the originals are. Am I missing something basic here:confused:

    Thanks for your assistance, again, rekenaar.

    PS Did you say you are also using Moving Pictures this way? If so, which version?
     
  8. rekenaar
    • Premium Supporter

    rekenaar Retired Team Member

    Joined:
    December 17, 2006
    Messages:
    4,421
    Likes Received:
    782
    Ratings:
    +785 / 0
    Home Country:
    South Africa South Africa
    Sorry, I do not follow. Can you elaborate a bit more?


    So you are referring to the instructions in the manual?
    All it states is that the mediaportaldirs.xml must be copied to both PC's. MediaPortal cannot read that from a central place. It must be in the MediaPortal folder. As for the rest, only on one PC. The instructions mention you should copy the database and thumbs to the new shared location. If the existing folders on one PC is used as the new shared location, then there is no need for that. Then you just share the existing location. Both PC's should just point to the same UNC path (\\server\folder) in mediaportaldirs.xml.


    Yes.
    Think it is 0.75 but I even used in in 0.72. Back then it was just not possible to create the movie-folder as UNC path, but I think I edited it manually. Must be like this:
    movpic02.JPG
     
  9. 1gkar
    • Premium Supporter

    1gkar MP Donator

    Joined:
    July 1, 2007
    Messages:
    236
    Likes Received:
    23
    Ratings:
    +37 / 0
    Home Country:
    New Zealand New Zealand
    Show System Specs
    Hope this image clarifies what I am meaning. I can see the default paths but cannot adjust them.


    What I am trying to ask, & not very clearly, is why is it not possible to utilise the existing, default thumbs & database paths, in the Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal folder by making them accessible to network share. Then use the mediaportaldirs.xml in a manually setup config folder in the same path, which points to the default folders' paths. Or have you totally deleted the original thumbs/database paths & just have the network share ones?

    ie.
    thumbs folder = Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal\thumbs
    database folder = Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal\database
    config folder = Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal\config
    and:
    mediaportaldirs.xml paths are adjusted to point to the above & the modified file is copied into the mediaportal root folder in each client machine. Otherwise, I do not see how the remote network share folder, comprising thumbs\database & config, are automatically updated when you add media files.

    Where on your HTPC do you have your client share? Inside the Mediaportal folder? On the same hard-drive or partition? Or totally separate? Reason I ask, I originally had it in my backup area which is on another partition, but after setting up the client share & adjusting the mediaportaldirs.xml file, my scheduled programmes would not record until I rebooted. Have reset back to original file until I can work it out.


    Yes.
    Got that working just after posting. Should have been a little more persistant before letting my fingers do the walking :oops: :Dagain.
     
  10. rekenaar
    • Premium Supporter

    rekenaar Retired Team Member

    Joined:
    December 17, 2006
    Messages:
    4,421
    Likes Received:
    782
    Ratings:
    +785 / 0
    Home Country:
    South Africa South Africa
    Silly me. the TVS part got me thinking about TVServer. No idea why I did not think about TVSeries - that is after all what we are talking about :D

    I think that is basically just displayed from your mediaportaldirs.xml. Can you post same screenshot but taken from your 2nd client?

    If you can share the folder, it should work no matter where it is. The 2nd client just need to be able to get there over network share.

    In my case, Yes, deleted original ones. I do not want my databases and thumbs on drive C. I created a new location on drive D and moved content from C to D (everything on my drive D is included in my backup schedule).

    I have never changed my config folder. Only Database, Thumbs, Skins. But that is just me ;)


    mediaportaldirs.xml paths must point to the UNC path after you SHARED the mentioned directories. Example:
    thumbs folder = \\server\shared\thumbs
    database folder = \\server\shared\database

    oops, already included in answer above :)
     
  11. 1gkar
    • Premium Supporter

    1gkar MP Donator

    Joined:
    July 1, 2007
    Messages:
    236
    Likes Received:
    23
    Ratings:
    +37 / 0
    Home Country:
    New Zealand New Zealand
    Show System Specs
    Rekenaar,

    Regarding the 2nd client TVSeries about tab: all the file paths are the installed defaults, except the database which points to the server share. So, fanart=c:\Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal\fanart: Logs=Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal\logs: Banners=Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal\MPTVSeriesBanners. I guess I must have done something wrong. You've given me more info to work with. I will play around with this over the course of the week/next weekend. Hopefully, the records' issue was just a problem with my first setup attempt.

    One other thing: Everytime I change the Series Listing Format, on the Mediaportal Display Control tab, to eg. filmstrip, it resets back to ListPosters. Weird. This is v2.0.3296. I think this is the latest I can use due to being restricted to pre-1.0.1 Not a biggie; just a nuisance:mad:
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!