Unable to get centralised database working (1 Viewer)

1gkar

MP Donator
  • Premium Supporter
  • July 1, 2007
    254
    57
    New Zealand New Zealand
    Country flag
    Have finished setting up the music area: what a job. Now, I wish to reap the rewards of my main HTPC's plugins for bedtime viewing. Specifically, TV Series & Moving Pictures.

    I am restricted to an earlier version of MP: 1.0.0RC4 because of the rendering changes of 1080i with v1.0.1+.

    Hence, I am using an earlier version of Streamed MP as my skin: v0.4.298. Have posted to see if I can utilise later skin editions with my MP version in Skins forum. MP-TVSeries is v2.0.3296. Moving Pictures is: v0.7.2.545

    I understand Moving Pictures plugin did not incorporate centralised database options with this version, so not worrying about it at this time. Will investigate after I get other areas sorted.

    I have setup a share as outlined in the Centralised Database WIKI page.

    When I open the client machine & go to the TVSeries plugin, I get the basic page opening but with no thumbs/images & the media files will not open. I can playback media files on client machine fine after setting up folders in 'MP Config\Movies\Movie Folders'

    I am getting a number of SQLiteClient error codes. I have included the log from the most recent attempt. Any insights would be greatly appreciated.
     

    rekenaar

    Retired Team Member
  • Premium Supporter
  • December 17, 2006
    4,421
    805
    South Africa South Africa
    Hi 1gkar :)

    I am a very happy user of the centralised DB. Not sure what your problem is, but let me ask a few questions as checkpoints for you.
    • Your log fie is full of READONLY messages. Are your shares set up with full rights?
    • Did you specify UNC patch in mediaportaldirs.xml for database and thumbs directory? (On my setup also for skin)
    • Same mediaportaldirs.xml in use on both clients?
    • Did you specify UNC location for your TVSeries locations inside the TVSeries Config program?
    • If you open TVSeries Config, does it show your database is located in the UNC path as specified by mediaportaldirs.xml? On both clients?
    • Are you accessing only from one client at a time?
     

    1gkar

    MP Donator
  • Premium Supporter
  • July 1, 2007
    254
    57
    New Zealand New Zealand
    Country flag
    Hi 1gkar :)

    I am a very happy user of the centralised DB. Not sure what your problem is, but let me ask a few questions as checkpoints for you.

    • [*]Your log fie is full of READONLY messages. Are your shares set up with full rights?
      Yes they are. I can view the media files within their directories & playback across my network. I have not set the ability to change the shared files. Is this a requirement?

      [*]Did you specify UNC patch in mediaportaldirs.xml for database and thumbs directory? (On my setup also for skin)
      I set the database & thumbs dierctories up as specified in the WIKI. Not sure what you mean by UNC patch? Also, how did you set up your skins directory? Just copy the contents across from your main Mediaportal folder & update mediaportaldirs.xml? Or??
      [*]Same mediaportaldirs.xml in use on both clients?
      I am using the modified mediaportaldirs.xml file on my client machine inside the root of the Mediaportal directory & inside the setup share/config folder. But am using the default one inside the root of Mediaportal on my main HTPC.

      [*]Did you specify UNC location for your TVSeries locations inside the TVSeries Config program?
      Do you mean the import paths in the Import Settings tab? If so, I was not aware this would need to be done. Otherwise, I'm not sure where you are referring to. I assume it is different to your list point about the database directly beneath this one?

      [*]If you open TVSeries Config, does it show your database is located in the UNC path as specified by mediaportaldirs.xml? On both clients?
      Have modified it to point to the shared/database folder. I have not touched the main HTPC's TVSeries config panel.

      [*]Are you accessing only from one client at a time?
      Yes.

    Thanks for the reply. Would love to get this operating. You do a great job. :D again.
     

    rekenaar

    Retired Team Member
  • Premium Supporter
  • December 17, 2006
    4,421
    805
    South Africa South Africa
    I have not set the ability to change the shared files. Is this a requirement?
    Not sure if it is a requirement. Worth testing if other points below does not work.

    Not sure what you mean by UNC patch?
    I only mean it must be set up as \\server\share and not by using a mapped network drive.

    Just copy the contents across from your main Mediaportal folder & update mediaportaldirs.xml?
    Yip. Means both clients use exactly same skin layout (example my customized basic home). Only maintained on one place.

    Do you mean the import paths in the Import Settings tab?
    Yes, the import paths. If I recall correctly, it is stored in database. My guess is that this is your problem.

    I am using the modified mediaportaldirs.xml file on my client machine inside the root of the Mediaportal directory & inside the setup share/config folder. But am using the default one inside the root of Mediaportal on my main HTPC.
    I use the modified one, with UNC location, on both. Have not tried it otherwise so not sure. Also a point to experiment if you struggle.

    I assume it is different to your list point about the database directly beneath this one?
    Yip

    Really hope some of this points will help you.
     

    rekenaar

    Retired Team Member
  • Premium Supporter
  • December 17, 2006
    4,421
    805
    South Africa South Africa
    I have not set the ability to change the shared files. Is this a requirement?
    Not sure if it is a requirement. Worth testing if other points below does not work.

    Not sure what you mean by UNC patch?
    I only mean it must be set up as \\server\share and not by using a mapped network drive.

    Just copy the contents across from your main Mediaportal folder & update mediaportaldirs.xml?
    Yip. Means both clients use exactly same skin layout (example my customized basic home). Only maintained on one place.

    Do you mean the import paths in the Import Settings tab?
    Yes, the import paths. If I recall correctly, it is stored in database.

    I am using the modified mediaportaldirs.xml file on my client machine inside the root of the Mediaportal directory & inside the setup share/config folder. But am using the default one inside the root of Mediaportal on my main HTPC.
    I use the modified one, with UNC location, on both. Have not tried it otherwise so not sure. Also a point to experiment if you struggle.

    I assume it is different to your list point about the database directly beneath this one?
    Yip

    Really hope some of this points will help you.
     

    1gkar

    MP Donator
  • Premium Supporter
  • July 1, 2007
    254
    57
    New Zealand New Zealand
    Country flag
    OK. I went back through & checked everything. I adjusted the folders to allow them to be changed inside the network & sharing area. I then reinstalled the MSSQL & then reopened the TVSeries (TVS) config, & all the errors were gone & I could reset the import paths.

    I used 'Start Import' in the TVS config as there were still issues with thumbs & media playback. It imported all the banners & thumbs. I can now playback media with the thumbs present inside MP.

    Questions: it saved the banners/thumbs to the local, default directory. I can see the paths in 'TVS\config\about' & can link to them, using the 'show' link, but cannot alter them to my shared thumbs folder. Maybe this is a limitation with this version? Might try a later version when I get more time: in a weekend.

    Also, why is it necessary to setup a shared database/thumbs directories & copy the information across from the original folders in the Mediaportal directory on the singleseat HTPC? Does that not mean an extra set of files to manually update when the originals are updated. Would it not be better to simply copy the original mediaportaldirs.xml file to the shared\config folder & modify the paths to direct to the default database/thumbs folders, in the remote client machine. I ssume this is not possible as it is stipulated they should be the same on both machines. But I can't see how the modified one on the singleseat is automatically updated when the originals are. Am I missing something basic here:confused:

    Thanks for your assistance, again, rekenaar.

    PS Did you say you are also using Moving Pictures this way? If so, which version?
     

    rekenaar

    Retired Team Member
  • Premium Supporter
  • December 17, 2006
    4,421
    805
    South Africa South Africa
    I can see the paths in 'TVS\config\about' & can link to them, using the 'show' link, but cannot alter them to my shared thumbs folder. Maybe this is a limitation with this version? Might try a later version when I get more time: in a weekend.
    Sorry, I do not follow. Can you elaborate a bit more?


    Also, why is it necessary to setup a shared database/thumbs directories & copy the information across from the original folders in the Mediaportal directory on the singleseat HTPC? Does that not mean an extra set of files to manually update when the originals are updated. Would it not be better to simply copy the original mediaportaldirs.xml file to the shared\config folder & modify the paths to direct to the default database/thumbs folders, in the remote client machine. I ssume this is not possible as it is stipulated they should be the same on both machines. But I can't see how the modified one on the singleseat is automatically updated when the originals are. Am I missing something basic here:confused:
    So you are referring to the instructions in the manual?
    All it states is that the mediaportaldirs.xml must be copied to both PC's. MediaPortal cannot read that from a central place. It must be in the MediaPortal folder. As for the rest, only on one PC. The instructions mention you should copy the database and thumbs to the new shared location. If the existing folders on one PC is used as the new shared location, then there is no need for that. Then you just share the existing location. Both PC's should just point to the same UNC path (\\server\folder) in mediaportaldirs.xml.


    PS Did you say you are also using Moving Pictures this way? If so, which version?
    Yes.
    Think it is 0.75 but I even used in in 0.72. Back then it was just not possible to create the movie-folder as UNC path, but I think I edited it manually. Must be like this:
    movpic02.JPG
     

    1gkar

    MP Donator
  • Premium Supporter
  • July 1, 2007
    254
    57
    New Zealand New Zealand
    Country flag
    I can see the paths in 'TVS\config\about' & can link to them, using the 'show' link, but cannot alter them to my shared thumbs folder. Maybe this is a limitation with this version? Might try a later version when I get more time: in a weekend.
    Sorry, I do not follow. Can you elaborate a bit more?
    Hope this image clarifies what I am meaning. I can see the default paths but cannot adjust them.


    Also, why is it necessary to setup a shared database/thumbs directories & copy the information across from the original folders in the Mediaportal directory on the singleseat HTPC? Does that not mean an extra set of files to manually update when the originals are updated. Would it not be better to simply copy the original mediaportaldirs.xml file to the shared\config folder & modify the paths to direct to the default database/thumbs folders, in the remote client machine. I ssume this is not possible as it is stipulated they should be the same on both machines. But I can't see how the modified one on the singleseat is automatically updated when the originals are. Am I missing something basic here:confused:
    So you are referring to the instructions in the manual?
    All it states is that the mediaportaldirs.xml must be copied to both PC's. MediaPortal cannot read that from a central place. It must be in the MediaPortal folder. As for the rest, only on one PC. The instructions mention you should copy the database and thumbs to the new shared location. If the existing folders on one PC is used as the new shared location, then there is no need for that. Then you just share the existing location. Both PC's should just point to the same UNC path (\\server\folder) in mediaportaldirs.xml.
    What I am trying to ask, & not very clearly, is why is it not possible to utilise the existing, default thumbs & database paths, in the Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal folder by making them accessible to network share. Then use the mediaportaldirs.xml in a manually setup config folder in the same path, which points to the default folders' paths. Or have you totally deleted the original thumbs/database paths & just have the network share ones?

    ie.
    thumbs folder = Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal\thumbs
    database folder = Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal\database
    config folder = Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal\config
    and:
    mediaportaldirs.xml paths are adjusted to point to the above & the modified file is copied into the mediaportal root folder in each client machine. Otherwise, I do not see how the remote network share folder, comprising thumbs\database & config, are automatically updated when you add media files.

    Where on your HTPC do you have your client share? Inside the Mediaportal folder? On the same hard-drive or partition? Or totally separate? Reason I ask, I originally had it in my backup area which is on another partition, but after setting up the client share & adjusting the mediaportaldirs.xml file, my scheduled programmes would not record until I rebooted. Have reset back to original file until I can work it out.


    PS Did you say you are also using Moving Pictures this way? If so, which version?
    Yes.
    Think it is 0.75 but I even used in in 0.72. Back then it was just not possible to create the movie-folder as UNC path, but I think I edited it manually. Must be like this:
    View attachment 46222
    Got that working just after posting. Should have been a little more persistant before letting my fingers do the walking :oops: :Dagain.
     

    rekenaar

    Retired Team Member
  • Premium Supporter
  • December 17, 2006
    4,421
    805
    South Africa South Africa
    TVS\config\about
    Hope this image clarifies what I am meaning
    Silly me. the TVS part got me thinking about TVServer. No idea why I did not think about TVSeries - that is after all what we are talking about :D

    I can see the default paths but cannot adjust them
    I think that is basically just displayed from your mediaportaldirs.xml. Can you post same screenshot but taken from your 2nd client?

    why is it not possible to utilise the existing, default thumbs & database paths, in the Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal folder by making them accessible to network share
    If you can share the folder, it should work no matter where it is. The 2nd client just need to be able to get there over network share.

    Or have you totally deleted the original thumbs/database paths & just have the network share ones?
    In my case, Yes, deleted original ones. I do not want my databases and thumbs on drive C. I created a new location on drive D and moved content from C to D (everything on my drive D is included in my backup schedule).

    config folder = Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal\config
    I have never changed my config folder. Only Database, Thumbs, Skins. But that is just me ;)


    thumbs folder = Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal\thumbs
    database folder = Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal\database

    mediaportaldirs.xml paths are adjusted to point to the above
    mediaportaldirs.xml paths must point to the UNC path after you SHARED the mentioned directories. Example:
    thumbs folder = \\server\shared\thumbs
    database folder = \\server\shared\database

    Where on your HTPC do you have your client share? Inside the Mediaportal folder? On the same hard-drive or partition? Or totally separate?
    oops, already included in answer above :)
     

    1gkar

    MP Donator
  • Premium Supporter
  • July 1, 2007
    254
    57
    New Zealand New Zealand
    Country flag
    Rekenaar,

    Regarding the 2nd client TVSeries about tab: all the file paths are the installed defaults, except the database which points to the server share. So, fanart=c:\Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal\fanart: Logs=Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal\logs: Banners=Documents & settings\All Users\Application Data\Team Mediaportal\Mediaportal\MPTVSeriesBanners. I guess I must have done something wrong. You've given me more info to work with. I will play around with this over the course of the week/next weekend. Hopefully, the records' issue was just a problem with my first setup attempt.

    One other thing: Everytime I change the Series Listing Format, on the Mediaportal Display Control tab, to eg. filmstrip, it resets back to ListPosters. Weird. This is v2.0.3296. I think this is the latest I can use due to being restricted to pre-1.0.1 Not a biggie; just a nuisance:mad:
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    R [solved] Unable to delete single recording General 2
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    D Unable to install 1.22 on Win 10 Newcomers Forum 9
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    V Unable to stream : 10 General Support 0
    B Suddenly MP is unable to play anything Watch / Listen Media 6
    M Unable to map virtual sent keys in the input device management General 6
    T [solved] "Unable To Play" (Videos) rears it's head again. Logs not possible... WatchDog error attached!! :( General Support 1
    porky996t Still Unable to play Live or Recorded TV General Support 4
    B Unable to play: Live3-0.ts issue General Support 7
    A Unable to play :stream 3 Television (MyTV frontend and TV-Server) 1
    badboyxx Unable to play BD-Iso watch/edit Videos 7
    Steve.Rayner61 TV "Unable to play" on Client - Working until Win 10 Server upgraded to Version 1803 Television (MyTV frontend and TV-Server) 5
    megahorst Unable to delete unseen recording while TV runs in the background 1.19 11
    gibman MP2 - V2.1 unable to playback new movie? Older releases 3
    M Unable To Record Series General 0
    F How to reset tv recordings database General 5
    A Synchronizing client databases MediaPortal 1 Talk 10
    R Problems accessing MySQL database remotely MediaPortal 1 Talk 0
    globaldonkey Music Database Error Listen Music 1
    R [solved] Files moved to new location - Easy way to update database? My TVSeries 7
    R Files moved to different location - Easy way to update database? Moving Pictures 2
    H [solved] Video database genres, sort titles and collection thumbnails Newcomers Forum 12
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    Similar threads

























    Top Bottom