Update to 1.0.1 THEN FTR 1.3.3 - BIG mistake (1 Viewer)

dir

MP Donator
  • Premium Supporter
  • August 30, 2006
    408
    36
    Home Country
    Afghanistan Afghanistan
    I just did a simple install from 1.0.0 to 1.0.1 of MP. I don't use SVN versions.

    Since I was running FTR 1.3.2 I thought I'd update it at the same time. I ran the update to FTR 1.3.3.

    Now when I try to enter MP's Configuration utility, it tells me that I'm running mismatched versions -

    TvPlugin and MediaPortal don't have the same version.
    Please update the older component to the same version as the newer one.
    MpConfig Version: 1.0.1.22344
    TvPlugin Version 1.0.0.0

    I then tried running just the TVServer 1.0.1 update from within the MP 1.0.1 installation temp directory, which worked fine and I can once again enter the config utility.

    However, if I try to run the TVServer Configure utility and go to plugins and click on the ForTheRecord plugin, I get


    Failed to locate assembly 'Gentle_Framework, Version =1.2.9.1286,
    Culture=neutral, etc. etc.

    I'm burying myself deeper and deeper and now afraid to try anything.

    I really REALLY don't want to lose my MP configuration - it takes about 8 hours to re-create. PLEASE don't suggest that I "simply" reinstall MP or do a "clean install". That's not an option!
     

    rekenaar

    Retired Team Member
  • Premium Supporter
  • December 17, 2006
    4,421
    805
    Home Country
    South Africa South Africa
    There were some changes after the 1.0.0 MP release that require new FTR dll's as well. They are listed on the FTR forum.

    Same with the TvPlugin version error. There were new "dummy" plugins posted on the FTR forum for each SVN version shortly after each release. I was not yet there to see if the 1.0.1 dummy plugin is there or not.
     

    dir

    MP Donator
  • Premium Supporter
  • August 30, 2006
    408
    36
    Home Country
    Afghanistan Afghanistan
    Will check the FTR forums.

    In the meantime here's a running log of my work. Will clean it up and post the answer here once I've got it to make it useful for others.


    Tried the following:
    Uninstalled FTR 1.3.3
    Uninstalled MP 1.0.1 TVServer only.
    Installed MP 1.0.1 TVServer only.
    Ran the TVServer config util and noted that it still shows FTR 1.3.3 plugin installed. Unticked it and exited.
    Noted that FTR 1.3.3 has not completely uninstalled - there are dozens of files still in c:\program files\For The Record.
    Deleted all those.
    Checked c:\program files\Team MediaPortal\MediaPortal TV Server\Plugins and found 5 or 6 ForTheRecord files in there, all dated April 1. All other files in this directory were dated April 11th. Shut down TVService and deleted these files.

    Re-entered the TVServer config util; now there's no FTR listed in available plugins.

    Ran FTR 1.3.3 installation program again.

    Re-entered TVServer config util; the FTR 1.3.3. plugin is listed. Enabled it. Clicked on it and get same error again.

    No progress.
     

    rekenaar

    Retired Team Member
  • Premium Supporter
  • December 17, 2006
    4,421
    805
    Home Country
    South Africa South Africa
    This is the steps that should be done imo:
    Install MP & TVServer 1.0.1
    Install FTR 1.3.3

    Get the updated FTR assemblies for the TVServer.
    At this stage you should be able to configure the plugin in TVServer without crash.

    Get the dummy TVPlugin dll for MP Client.
    Client TV should now also work.
     

    trevor

    Portal Pro
    October 17, 2006
    1,600
    950
    Chelmsford
    Home Country
    United Kingdom United Kingdom
    Will really need to wait for a true 4tr version for 1.0.1 but in the mean time I have attached an archive with the 4tr files that will work with 1.0.1. This is basiclly the set released for SVN 22162 with a version of the dummy TvPlugin.dll versioned to 1.0.1.

    There is a txt file included but to install.

    Stop TvService and the 4TR services
    Copy over the DLL files into Mediaportal/plugins/windows and Mediaportal Tv Server/plugins
    Restart all services

    Cheers

    Trevor
     

    Attachments

    • For The Record SVN22162.rar
      30.7 KB

    dir

    MP Donator
  • Premium Supporter
  • August 30, 2006
    408
    36
    Home Country
    Afghanistan Afghanistan
    Here's a giggle. I've been running MP stably for months and months and only tonight was bored and thought I'd see if there's a new version of MP out. I found and installed MP1.1Beta and then remembered that I should get the latest StreamedMP, ForTheRecord, and other staples. I installed FTR 1.4.0.1, and BANG ran into the same problem - I can't run MP Configuration app any more or run MP at all. I'll have to wait for the FTR guys to create updated dll files. Oh well, my bad!
     

    Users who are viewing this thread

    Similar threads

    I just copied over a backup and now it's working. It must have been some sort of corruption of important files. Thanks! Emph
    I just copied over a backup and now it's working. It must have been some sort of corruption of important files. Thanks! Emph
    I was using MediaPortal just last night with no issues at all, but since today, it doesn't autostart, if I try to run it or...
    Replies
    2
    Views
    293
    OK, @CyberSimian jogged my memory :) I remembered that something similar has happened to me before, back in 2017. So I searched back through previous posts and found the solution. I just knocked up a very rough document that describes the problem, symptoms & solution for anyone else that is interested in the future. It's attached to...
    OK, @CyberSimian jogged my memory :) I remembered that something similar has happened to me before, back in 2017. So I searched...
    Hi folks, Was running MePo 1.25 without issue. Installed latest Windows 10 updates, now MePo won't start, at all, it does not even...
    Replies
    5
    Views
    1K
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system hdd and decided it was time for a clean install anyway. Other hardware (C2D, 8 Gb ram, no tv cards - IP only) unchanged. Was running an earlier Win10 version with MP 1.24 which had been updated for years...
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system...
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system...
    Replies
    0
    Views
    429
    I tested this on my Intel Core i7-4785T on a MSI Z97 Gaming 7 mainboard. With the Intel HD Graphics driver version 15.40.47.5166, MediaPortal crashes when I try to play MPEG2 (SD) recordings/live TV. With H.264 (HD) ts files or live TV, it works. I also tested it with...
    I tested this on my Intel Core i7-4785T on a MSI Z97 Gaming 7 mainboard. With the Intel HD Graphics driver version 15.40.47.5166...
    Hello everyone. I've run into this issue recently on 2x systems that I manage for friends and family. Both run MP 1.25 using the...
    Replies
    12
    Views
    5K
    Hi CyberSimian THANKS!!!! deleting the channels then doing an 'all regions' scan has fixed it :) I had retuned many time before that without success so I think it was deleting the old channels that was different this time. Thanks again for the very clear and detailed suggestions and quick response. Regards Paul
    Hi CyberSimian THANKS!!!! deleting the channels then doing an 'all regions' scan has fixed it :) I had retuned many time before...
    Hi, I recently had to rebuild my mediacenter running mediaportal 2.2.2 because of an SSD failure. This has all worked perfectly...
    Replies
    2
    Views
    597
    Top Bottom