Updated ICSharpCode.SharpZipLib.dll causes crash in manual Scan (1 Viewer)

ASiDiE

Retired Team Member
  • Premium Supporter
  • January 14, 2005
    902
    5
    USA
    As of 2/4/09 the ICSharpCode.SharpZipLib.dll has been updated to version 0.85.5.452. When I try to do a manual scan I get the error in the screen shot. The latest SVN of media portal on this form show have the new file in there. I am using the latest public build of tv-series plug-in (2.1.3321). I put back the older dll of version 0.84.0.0 and it works just fine.

    I am using build 21669 that came out on the 7th but didn't notice this until now.

    I am trying to test this out once more but can't get it to happen again. I had to process one file and then i copied over the .84 file and processed it... I then put the newer DLL back in there and removed some shows.. Don't know why it's not coming up now.

    Is anyone else getting this error?
     

    Attachments

    • tverror.png
      tverror.png
      6 KB

    dukus

    Portal Pro
    January 20, 2006
    783
    748
    44
    Home Country
    Romania Romania
    I changed the ICSharpCode.SharpZipLib.dll , mpi installer, to work the TVSeries need to be recompiled to work
     

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,751
    7,196
    Sydney
    Home Country
    Australia Australia
    If I compile against the latest DLLs in 1.0.1, will it be backwards compatible with MP 1.0.0.0 users? The Project references:

    * Core
    * Utils
    * Dialogs
    * Databases
    * ICSharpCode.SharpZipLib


    I think the only way to handle this is release a 2.2 SVN test build, if you are comfortable using MP SVN test builds then you should be comfortable using TVSeries SVN releases.
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    I think the only way to handle this is release a 2.2 SVN test build, if you are comfortable using MP SVN test builds then you should be comfortable using TVSeries SVN releases.

    Yep. if using one SVN then you are already living on the edge and risking the daily operation. One more wont hurt :)
     

    Juggels

    Portal Member
    January 12, 2008
    28
    0
    I for one don't mind using SVN versions, as I hardly ever notice any problems with these (this one is actually the first).

    For now i 'fixed' the problem by using the .dll file from my backup folder, but a rebuilt TV Series SVN would still be very much appreciated :)
     

    Jeditrav

    Portal Pro
    May 17, 2007
    319
    20
    Home Country
    New Zealand New Zealand
    For now i 'fixed' the problem by using the .dll file from my backup folder, but a rebuilt TV Series SVN would still be very much appreciated :)

    I'm getting this issue too - replaced .dll with backup - a new/rebuilt TVSeries SVN would be greatly appreciated :D
     

    lloydsmart

    MP Donator
  • Premium Supporter
  • January 10, 2009
    134
    4
    UK
    Home Country
    Wales Wales
    One more request for an updated SVN build. Sorry if this amounts to nagging! :D
     

    Users who are viewing this thread

    Top Bottom