"Upgrade" fails to replace files and causes that does not work TV (1 Viewer)

domb

Portal Pro
October 30, 2006
213
7
Just upgraded from MP 1.1 RC6 to 1.1 final. It hasn't upgraded the TVPlugin. Now I can't starMP or MP config as it says...

TVPlugin and MediaPortal don't have the same version.

MpConfig Version. 1.1.0.0
TvPlugin Version: 1.0.10.0
 

catavolt

Design Group Manager
  • Team MediaPortal
  • August 13, 2007
    12,838
    9,233
    Lanzarote
    Germany Germany
    Country flag
    AW: Upgrade from 1.1RC 6 to 1.1 Final unsuccessful...

    This has been answered already in different posts. Please uninstall TVServer manually (use the first option to save all your settings).
    Then reinstall the MP package. It is recommended to reboot your system afterwards. ;)
     

    jameson_uk

    Retired Team Member
  • Premium Supporter
  • January 27, 2005
    7,258
    2,528
    Birmingham
    United Kingdom United Kingdom
    Country flag
    re: "Upgrade" fails to replace files and causes that does not work TV

    This should be deleted as there are no logs but I will give you the benefit of the doubt as I have a feeling logs would not show much anyway.

    This seems to be caused by TVservice not being stopped by installer but no-one has been able to replicate or identify the issue.

    Unfortunately the upgrade has not worked in your case. Looking through the RC bug reports it appears that you need to re-install the TV server component.
     

    yoavain

    Extension Dev
  • Premium Supporter
  • May 24, 2009
    427
    467
    42
    Israel Israel
    Country flag
    re: "Upgrade" fails to replace files and causes that does not work TV

    Had the same problem, didn't report for 2 reasons:
    1. I have many plugins & a skin installed (it's not a clean upgrade)
    2. I managed to resolve it by building an SVN build and installing "Setup-MediaPortal-svn-1.1.0.26099.exe" + "Setup-TvEngine-svn-1.1.0.26099.exe" :rolleyes:

    Anyway, I still have the logs, (though I couldn't find any abnormality there).

    Attached, first is MP, second is TV.

    Anyway, what I think you should do before uninstalling anything is this:
    1. Run the MP 1.1 Final installation (don't press "Next")
    2. Goto %temp%\MediaPortal Installation\deploy
    3. Copy aside "package-mediaportal.exe" & "package-tvengine.exe"
    4. Stop MP 1.1 installation (Press the "X")
    5. Run "package-mediaportal.exe" and choose upgrade
    6. Run "package-tvengine.exe" and choose upgrade

    This is an unofficial answer
     

    OleBent

    MP Donator
  • Premium Supporter
  • May 14, 2005
    75
    3
    re: "Upgrade" fails to replace files and causes that does not work TV

    I´ve had some somewhat similar difficulties.

    Cannot provide some deep and clever explanation what goes on under the hood between MP and UAC but seems to be something in that area.
    At least I´ve found a rather simple way through to a succesfull upgrade.

    Setup is runnung on W7 x64.

    UAC setting is standard and user account is local admin.

    If I right click and run the MP deploytool as admin (Right click "Run as administrator") the tv plugin doesnt get upgraded and i get the err about wrong version when starting MP config.

    If I on the other hand run the deploy tool as currently logged on user accepting the prompt for elevated privileges the tv service upgrade fails.


    Therefore my path to a succesfull upgrade at least from RC4->RC5->RC6 and on to the final 1.1.0 has proven to be...

    - Stop the tv service

    - Run the deploytool as currently logged on user accepting the prompt for elevated privilegies.

    Everything then upgrades perfectly.
     

    Lucky-Eagle

    MP Donator
  • Premium Supporter
  • April 15, 2008
    5
    0
    Sweden Sweden
    re: "Upgrade" fails to replace files and causes that does not work TV

    Thank you yoavain! Your method made it.
     

    domb

    Portal Pro
    October 30, 2006
    213
    7
    re: "Upgrade" fails to replace files and causes that does not work TV

    in the end i just extracted the tv plugin from the installer and upgraded it manually. found it strange that upgrades worked from svns and every RC but the final version fails.
     

    globaldonkey

    MP Donator
  • Premium Supporter
  • April 23, 2007
    755
    79
    Country flag
    re: "Upgrade" fails to replace files and causes that does not work TV

    +1 for this problem. Did as Catavolt suggested to fix it.
     

    infinite.loop

    Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    The problem is that on some systems, one of the files (i.e. TvService.exe) is "locked" by windows - hence it can not be replaced by our installer during an upgrade.
    We tried hard to find out why this happens, but without any luck.
    Only way out is to completelly rework our upgrade procedure to check if all files were replaced, and if not request a reboot and then replace the files after that.

    Or check if any of the files which will get replaced are currently "locked". If it is we need to find out if we can "unlock" it. If this is not possible we will have to request a reboot before the upgrade starts.

    http://mantis.team-mediaportal.com/view.php?id=2975
     

    domb

    Portal Pro
    October 30, 2006
    213
    7
    I see what you're saying but I didn't have a problem with the TV Service, it was the client plug-in for MediaPortal. The only reason I can see this being locked is if MediaPortal is open but obviously it wasn't.

    The only plug-in that I have activated which I didn't before was the power scheduler. Perhaps this interacts with the TV client in some way? I didn't do much experimenting to be honest, just replaced it and got on with things but a restart before/after upgrading isn't going to hurt if it solves these problems.

    :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    joecrow Online Videos fails after MP 1.23 upgrade. 1.23 Pre Release 37
    D Upgrade to MP2.2 pre release fails with failure to start service 2.2 Archive 32
    A [solved] DiseqC problems after upgrade to 1.25 General Support 1
    DHosein 1.25 Upgrade and movie covers/backdrops General Support 9
    cerberus Erfahrungsbericht Upgrade Win 10.1909 MP 1.24 Installationsprobleme? 2
    G [solved] Black Screen on all videos after upgrading to either 1.23 or 1.24 from 1.22 General Support 4
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    F [solved] Could not find the MediaPortal.Common.Logging.ILogger service after upgrading from 2.2.2 to 2.2.3 General 2
    T Upgrading HTPC for 4K General 5
    johns11 Multiple programs responding to IR commands since upgrade from 1.12 Remotes 3
    D PC rebuild & MP2 upgrade - how to preserve database and settings? General 1
    W Playback stuttering after upgrade from MP1 on Windows 7 to MP2 on Windows 10 General 2
    R [solved] TV Server after upgrading from MP 1.18 to MP 2.2 General 14
    caveman Upgrade from Mediaportal 1.X to 2.2 General 6
    B Is it Feasible to upgrade a working Mediaportal 1.20.100.0 to V2? Newcomers Forum 1
    T [further infos missing] MP2.2 client crashes on open (after upgrade) 2.2 Archive 34
    J Things I noticed with MP2.2 almost within minutes after upgrading it over the 2.13 version General 6
    C Upgrade from ancient MP Installation, configuration support 12
    Steve.Rayner61 TV "Unable to play" on Client - Working until Win 10 Server upgraded to Version 1803 Television (MyTV frontend and TV-Server) 5
    J upgraded to mp2 but have a few queries! General 17
    Undel MediaPortal 1.1 upgrade Installation, configuration support 3
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 3
    M MovingPictures: Hang at retrieving details (connection fails) ? Moving Pictures 23
    Grisu002 Failed to startup - TV Server funktioniert nicht Allgemeines Support- und Diskussionsforum 0
    Similar threads

























    Top Bottom