Using FFDshow for Codecs and AC3 Passthrough to S/PDIF

Commodore 64

Retired Team Member
  • Premium Supporter
  • June 20, 2005
    328
    0
    44
    I always see people referring to "Codec Pack Hell" and advising people not to install codec packs. I've used FFDShow from Day 1 in my MediaPortal life and I think it is the easiest and simplest way to get My Videos to play my various AVI, MKV and OGM files. I'm going to run through how I use FFDshow.

    I DO NOT USE FFDSHOW FOR POST-PROCESSING!. IMHO, it is not needed with VMR9 and hardware scaling being what it is these days. If you disagree with me, fine. Do not start any Flame Wars here. This thread is about FFDshow as a codec pack and replacement for AC3Filter.

    Start with a fresh install. Do not install any Divx, Xvid, or AC3 filters. I install the nVidia Mpeg2 decoders and a Matroska Splitter (register it with Radlight). If you don't play .mkv files, don't worry about the matroska splitter.

    Download FFDshow, I use this one: http://www.afterdawn.com/software/video_software/codecs_and_filters/ffdshow.cfm

    Install it as follows:

    Leave this at default settings.


    Make sure you do not install Mpeg1 or Mpeg2 decoders.


    I enable the FLAC plug in and leave every thing else as is.


    Make sure none of the video filters are on by default.


    I uncheck Volume Normalization.

    From here, just finish installing FFDshow. Now we need to make a few simple configuration changes so that you can get AC3 or DTS to pass through to S/PDIF.


    Fire up the Audio Decoder config.


    Note that under the Codecs Menu, you will need to set AC3 and DTS to SPDIF using the simple drop-down menu.


    Highlight the "output" menu and you will see this. DO NOT CHECK THE AC3 or LPCM OPTIONS!. Leave them alone.

    OK. Now you are done. You should be able to playback any AVI file with AC3 and output that AC3 directly to your receiver. These changes will not affect your Mpeg 2 decoders. For your DVDs, you will have to set those up yourself.

    If you have AC3FIlter installed, go into configuration and set it to "S/PDIF (disabled)" and go to the systems tab and select "Prefer other decoder". Do not mess with the merit of AC3Filter with Radlight Filter Manager.

    For Video Concerns:
    .

    If you think you may have a Video Postprocesing filter activated or Mpeg2 decoders enabled check here and make sure everything is unchecked, and that your Mpeg 1 and Mpeg 2 entries are disabled.

    Hope this helps
     

    rtv

    Retired Team Member
  • Premium Supporter
  • April 7, 2005
    3,622
    83
    Osnabruck
    Thank you very much for this detailed post!
    I'm also day-1 user of ffdshow and I'd like to add:
    If you experience sound stuttering with AC3-channels, check your ac3filter config (set to prefer ac3filter and try wave with older sound cards) and set ffdshow configuration to "none" instead of "SPDIF".
     

    Efros

    Portal Pro
    January 23, 2006
    511
    18
    Maine
    Thanks for this been having endless problems with one xvid file, that just would not play despite having the xvid codec installed. followed this guide enabled ffdshow postprocessing hey presto it worked!
     

    tkortell

    Portal Pro
    April 13, 2005
    320
    16
    39
    Vaasa / Sulva
    Thanks Commodore 64,

    Also I have been using ffdshow from day one but have always have problems with some videofiles. If I get one working good anotherone stops.. But I will try this tonight.

    Thanks again ;)

    R / tk
     

    Commodore 64

    Retired Team Member
  • Premium Supporter
  • June 20, 2005
    328
    0
    44
    For you post-processing fiends

    https://forum.team-mediaportal.com/viewtopic.php?t=15644

    Kevon27 is the self-proclaimed king of upscaling and he has put some good info in that thread. To save you the click, I'll put the most important stuff here. Thanks Kevon!

    I the KING of Video Upscaling can help you (i'm really that good).

    1. Get THIS version of FFdshow from this site. http://dvd.box.sk/ddivx.soft.link.php?rid=8270
    Don't not use any of those 2006 versions or the one from sourceforge.
    I'm current using the 2005-11-15 and I can upscaling video beyound 1920 x 1080.

    2. unistall any current version of 'show you have (unless you already have 2005-11-15)
    3. intall the download
    4. after install, find the folder in ALL PROGRAMS that contains the FFDshow files.
    5. choose video decoder Config.
    6. Ffdshow Properties screen should popup. on the left hand side (under the ffdshow tab) scroll down until you see (RESIZE AND ASPECT SETTINGS). Check that box. Now move to the right hand side. Under the SPECIFY SIZE, enter your new figure (1280 x 720).
    Now move to the right hand side of that and choose RESIZE ALWAYS.
    Move down to the ASPECT RATIO section
    Choose (KEEP ORIGINAL ASPECT RATIO).
    Now Press APPLY.

    If you want to enhance the image a little more than you can go back to the left and move down one and chose the Settings option. It is right below resize & aspect Settings.
    Move to the right of Settings. In the Method options choose Lanczos. Next to that (Parameter) choose 4 (playaround with the numbers to see which give you betting quality). (note the Higher the settings the more strain is put on your cpu)

    Under Luma Sharpen choose a number (see what is best for you)
    Under Chroma Sharpen .. Do the same thing.
    Now press apply.

    Now go to Media portal setup.
    Under DVD (expand it first), choose DVD post Processing. Move to the right and choose ENABLE FFDSHOW POST PROCESSING.

    YOU ARE DONE.

    Now ffdshow performance depends on your cpu. On my Xp2400 (2.0 ghz) 1 gig mem.. I am upscaling video to 1920 x 1280 with Lanczos Parameter set at 2 and Luma and chroma sharpen at 1.00

    I learn ffdshow by spending a lot of time playing around with different values and settings.
     

    NLS

    Portal Pro
    April 26, 2006
    922
    16
    45
    I have a question (with the blessing of CBM64) related to the thread:

    If I need to post process videos and I have enabled ffdshow to decode videos... do I need to tick "ffdshow postprocessing" in MP config too?

    I mean doesn't ffdshow filter get's "run" anyway?

    So if I have post processing in ffdshow enabled, I expect I don't need to tick anything on MP config... or am I wrong?

    I would tick it anyway, but then I am afraid if it passes ffdshow filter... twice (!).

    Comments?
     

    bennyy

    Portal Member
    October 21, 2006
    6
    0
    48
    Bad "Noisy" TV reception

    I wonder. Should ffdshow resolve my "noisy" picture and if yes, how? I have analog cable reception that is more than decent if I tune channels on my Sony TV directly. My problem is when connecting the cable to my Lifeview DVB-T Dou card, the TV reception is noisy not to say also scattery (and I have tried all suggestions around the forum) I have to say that through the Lifeview proprietary program it is a bit better but not 100% not even 90 :)

    I would appreciate an answer, quite frustrated with it :(
     
    Top Bottom