Version 0.2.0.1 beta

Discussion in 'ASIO music player' started by Symphy, October 10, 2008.

  1. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Well, have been trying to fix some issues:
    • Added support for 24 bit ASIO channels, so should work on Xonar now. Untested, because i only have 32 bit channels available here. See also the warning below!
    • Attempted to fix the DTS forward problem. Guesswork for the most part, so don't be surprised if it's not working :) (Only changed the forward/rewind function, will do pause later if this turns out to work)
    • Attempted to fix the crash when no ASIO driver is installed. Guesswork here too, because i could not reproduce the problem here.

    Warning!
    To prevent damage to your speakers, turn down the volume before trying this. I'm not 100% sure i've got the byte-order right on the 24 bit chans. If you get awfull noise instead of music, also with a normal mp3, i got it wrong :rolleyes:



    There's no need to install the vcredist if you already have 0.2.0.0
     

    Attached Files:

    • PureAudio.mpi
      File size:
      30.6 KB
      Uploaded:
      October 10, 2008
      Views:
      221
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mark1234

    mark1234 Portal Member

    Joined:
    October 8, 2007
    Messages:
    27
    Likes Received:
    0
    Ratings:
    +0 / 1
    "Attempted to fix the crash when no ASIO driver is installed. Guesswork here too, because i could not reproduce the problem here."

    Symphy,

    It's solved now!!! Great work!
    Thanks for this incredible plugin.
     
  4. edterbak
    • Team MediaPortal

    edterbak Test Group

    Joined:
    March 4, 2008
    Messages:
    2,114
    Likes Received:
    736
    Gender:
    Male
    Occupation:
    Researcher
    Ratings:
    +1,178 / 5
    Home Country:
    Netherlands Netherlands
    Show System Specs
    :D :D :D
    :D
    I will test tonight with MP1 RC2 + svn 14sept..

    ---------- tested a bit.. ------------

    24bit asio is working!!! sweet. Great work Symphy!!!!

    BUT.... Im sorry to report that the fastforward, backward or pause still causes the white noise. Ill post a log for it within a couple of minutes.

    [edit2]
    Below are the logs of the Xonar ASIO driver set at 24bit. I played a DTS file and after 10 seconds of playing I pressed (1)pause or (2)fastforward and (3)rewind. If I set the Xonar ASIO driver to 16bit I get the same result, white noise with the mentioned actions.
     
  5. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Well a 2 out of 3 score is not too bad :)

    Thanx for the feedback sofar, will keep looking for the forward/pause issue.
     
  6. edterbak
    • Team MediaPortal

    edterbak Test Group

    Joined:
    March 4, 2008
    Messages:
    2,114
    Likes Received:
    736
    Gender:
    Male
    Occupation:
    Researcher
    Ratings:
    +1,178 / 5
    Home Country:
    Netherlands Netherlands
    Show System Specs
    want anything else to be tested? Just ask, because I just did what I thought would be handy... other file types or...?

    Good luck on the problem solving... Personally Im not that bother with it. All my files are single songs, no cue sheets. So it doesnt realy bug me. But ofcourse it would be nice to be able to if needed to pause/forward etc.

    Ed
     
  7. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    You did exactly the right tests :) The log proofs that indeed 24 bit asio format is used. It does not tell me what causes the whitenoise, but i can't think of any other tests right now that would help.

    If i have something, i'll let you know :)
    Thanx,
     
  8. anvandarnamn

    anvandarnamn Portal Pro

    Joined:
    February 15, 2007
    Messages:
    84
    Likes Received:
    3
    Ratings:
    +3 / 0
    Home Country:
    Sweden Sweden

    Hi symphy!

    first of all - great plugin!

    Im still having problems with the Rewind / Fastforward /Pause. THIS IS NOT ONLY A PROBLEM WITH DTS FILES...
    I have a lot of HDCD albums encoded to flac/WAV.

    they all play flawless, but as soon as i Rewind / Fastforward /Pause the track, the sound gets distorted and the HDCD indication on my receiver starts to flash - not bitperfect sound anymore...

    thanks!

    Best Regards!
     
  9. Helios61
    • Premium Supporter

    Helios61 Retired Team Member

    Joined:
    January 30, 2008
    Messages:
    4,587
    Likes Received:
    584
    Gender:
    Male
    Location:
    NRW
    Ratings:
    +897 / 4
    Home Country:
    Germany Germany
    Show System Specs
    Hello Symphy!

    Thanks for your work. I have made a few Tests with my Files!

    DTS (.wv Image)

    Fleetwood Mac - Rumours -> sounds great, but no sound after "fast forwarding" or "pause"!
    Verdi - Aida -> sounds great, but no sound after "fast forwarding" or "pause"!

    .ape Image

    Chopin - Nocturnes -> all works fine

    .flac files

    Oscar Peterson Trio - Night Train -> all works fine

    .wv Image

    David Gilmour - Remember That Night -> all works fine

    .mp3 files

    Paul McCartney - Tripping The Live Fantastic (Live Recording) -> there is a "humming" (i hope, thats the right word; in German i mean "Brummen") between the Tracks!

    I attach the logs!
    Best Regards
    Helios
     
  10. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Thanx Helios. Gives a good insight in what's working and what not.


    Yep, humming is the right word for Brummen :) I assume you mean the typical 50Hz or maybe 60Hz hum. Humming is a typical analog problem, and if it's only on this particular album, its most likely in the recording itself. Can always occur during live recordings.
     
  11. Helios61
    • Premium Supporter

    Helios61 Retired Team Member

    Joined:
    January 30, 2008
    Messages:
    4,587
    Likes Received:
    584
    Gender:
    Male
    Location:
    NRW
    Ratings:
    +897 / 4
    Home Country:
    Germany Germany
    Show System Specs
    Hello!
    Because i have to convert all my files new to single .flac Files, i made a new test with gapless Playback. One of the best Album for Testing is IMO "The Beatles - Sgt. Pepper's Lonely Hearts Club Band" first three Tracks! After setting the Latency from 256 to 1024 samples, the Humming between the Tracks disappeared!

    Best Regards

    Helios
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!