VMR9 and NVIDIA the culprit to washed-out video

Discussion in 'Codecs, External Players' started by geov, October 19, 2007.

  1. geov
    • Premium Supporter

    geov MP Donator

    November 1, 2006
    Likes Received:
    Business & Solution Analyst
    Cape Town
    +38 / 0
    Home Country:
    South Africa South Africa
    TV-Server Version:
    MediaPortal Version: SVN
    MediaPortal Skin: Blue
    Windows Version: XP Profesional SP2
    CPU Type: Pentium D 3.2GHZ
    HDD: 2 X 240GB
    Memory: 1Gig
    Motherboard: ASUS P5PE-VM
    Motherboard Chipset: Intel 865G
    Motherboard Bios: American Megatrend Ver1201
    Video Card: Nvidia FX 5200
    Video Card Driver:
    Sound Card: Sound Blaster
    Sound Card AC3:
    Sound Card Driver:
    1. TV Card: Hauppage PVR500
    1. TV Card Type: Analog
    1. TV Card Driver:
    2. TV Card:
    2. TV Card Type:
    2. TV Card Driver:
    3. TV Card:
    3. TV Card Type:
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec: MPV
    MPEG2 Audio Codec: MPA
    Satelite/CableTV Provider: DSTV MultiChoice
    HTPC Case: ThermalRock Mystic
    Cooling: 3 X ThermalTake Fans
    Power Supply: Dont Know
    Remote: Microsoft MCE Model:1039
    TV: Tedelex
    TV - HTPC Connection: VGA

    Hi, I've been having a lot of problems with image quality in MediaPortal, especially with all DVD and AVI. I could never understand why my video always looked washed-out, because in Windows Media Player the quality is always great. I started playing with GraphEdit and realised that the only difference between the graphs being generated was that MediaPoratl uses VMR9 and WMP does not. Knowing nothing about video I decided to do some research on the web and quickly found out that my problem is related to VMR9, and that it is related to how bad my old Nvidia (GeForce FX 5200) graphics card is handling VMR9. I have not found a solution for this yet, and was hoping that some of you that understand VMR9 and the problem with Nvidia would be able to give me some more detail and tips on how to resolve this. Would a new graphics-card sort out my problems (which one), or are there some settings or drivers that I can use to resolve my problem?

  2. Google AdSense Guest Advertisement

    to hide all adverts.
  3. Darre

    Darre Portal Pro

    April 21, 2007
    Likes Received:
    +80 / 0
    Home Country:
    Norway Norway
    Cant you just disable WMR9 in the MP settings? its located under "directshow filter control-->Video Mixer 9 settings"
  4. Commodore 64
    • Premium Supporter

    Commodore 64 Retired Team Member

    June 20, 2005
    Likes Received:
    +1 / 0
    Home Country:
    United States of America United States of America
    No you cannot disable VMR9. MP will always use Video Mixing Renderer 9.

    There are some settings in your nV control panel related to tweaking video settings. Some people have had some success using those. For myself, I don't have any complaints about washed out colors...so I would hope it is something you can tweak to your liking.

    See this post for some additional info: https://forum.team-mediaportal.com/showpost.php?p=188693&postcount=9
  5. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    January 7, 2005
    Likes Received:
    +4,810 / 3
    Correct way to solve the washed out colors is to select a correct colour space from Nvidia drivers. At least latest drivers have setting what can be used to select beween RGB and YUV colour spaces. If you are using an older drivers the change must be done manually from registry.

    Here's how to do it (unfortunately I cannot remember where I did got these instructions...)

    Code (Text):
    2. OK...I found the registry hack and it seems to be working great for me! Here is how you do it for anyone interested:
    4. Launch regedit and determine the current primary display
    5. looking in HKey_Local_Machine\Hardware\DeviceMap\Video
    6. and note the GUID (global unique identifier assigned by
    7. which is the long string in brackets { } at the end of the entry
    8. device\video0".
    9. Look in
    10. HKey_Local_Machine\SYSTEM\CurrentControlSet\Contro l\
    11. GUID}\0000
    12. where {GUID} is the number derived from the previous step.
    13. Open the "0000" directory and create a new DWORD called
    14. VMRCCCSStatus and give it a value of
    15. 0x1 - to force use of the standard YUV range of 16-235
    16. 0x3 - to force use of the extended YUV range of 0-255
    18. So I made the DWORD VMRCCCStatus in the following registry folder:
    19. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Video\{GUID}\0000
    20. and gave it a HEX value of 3. I rebooted and seems to work great.
    22. \Registry\Machine\System\CurrentControlSet\Control\Video\{D1A6C810-2415-4441-8264-61C09815A007}\0000
  6. daniel771

    daniel771 New Member

    October 17, 2007
    Likes Received:
    +0 / 0
    Home Country:
    Finland Finland
    Thank you very much for this tip. It worked beautifully with my 6150.

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.


  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!