VMR9 Renderless *Exclusive* (1 Viewer)


Portal Member
October 30, 2005
Area: Media Portal Program, TV section
MP Version: Apparent in all 0.2 versions (using the latest CSV right now)
Skin: mce (not that it makes a difference here)
Windows Version: Windows XP SP2 English (ALL updates applied)
CPU Type: AMD Athlon 64 3800+ (2.4 Ghz)
Memory: 1536 MB PC3200 low latency (Corsair)
Motherboard Chipset: ASUS A8N-E (nForce4 Ultra)
Video Card: GeForce 7800GTX (Gainward)
Video Card Driver: 81.87
Video Card Resolution: 1280x720
Video Render Type: VMR9 Renderless (Overlay and VMR7/VMR9 Windowsless: doesn't make a difference)
Video Codec Type & Version: nVidia PureVideo 1.02.177
Audio Codec Type & Version: default bundled with MP
TV Card: Digital Everywhere FloppyDTV-C/CI
TV Card Type: (Software) DVB-C
TV Card Driver: BDA 1.0.4


I've been told that when timeshifting and recording MediaPortal goes into VMR9 Renderless Exclusive Mode as opposed to the regular VMR9 Renderless Mode.

I was just wondering if it might be possible to add an option to always run in exclusive mode in a future release or if there is some tweak or plugin I can apply to make this happen.

The reason I'm asking is becase I get terrible tearing in MediaPortal. (I don't get this in any other apps no matter what res, refreshrate, codec, renderer etc. I use so it is not in any way related to any option or configuration issue like many posts here on this forum would suggest.)
But when I start timeshift or recording the tearing instantly goes away providing a perfectly stable picture.

I've tried some tweaking with the SHIFT+1 command.
When not TS/recording I get about 40 fps and loads of tearing, yet it says "sync = 1", when TS7recording I get a constant 25 fps no tearing whatsoever and sync is 0.

Now ofcourse I can cure my tearing problems by TS/rrecording so it's not the end of the world but problem is MP, channel changing etc. gets very unresponsive when having TS active.

So I guess, if what I've heard is true, the renderer goes into exclusive mode when recording or timeshifting which will make the tearing go away it this is the case a simple toggle for "always use exclusive mode" would solve all the tearing problems I, and probably a lot of other people, have.

Thanks for any input.


Portal Member
October 30, 2005
tklon said:
Did you already enable use Exclusive DirectX Mode for fullscreen tv/video under General in mp Setup?

Yup, doesn't seem to do the trick.

To be exact I'm not sure it is Exclusive mode that I need so badly. I just need MP to do the rendering like, whatever it does to the video rendering when recording or timeshifting, ALL the time.
From what I've been told Exclusive mode just kicks in when recording or timeshifting thus the title of my thread but I could of course be misinformed. :)

So in any case: MP does something special with the video rendering when it is recording or timeshifting that takes away all forms of tearing. I would like MP to do this all the time. ;)


I just tried disabling Exclusive mode in the general settings and now I get tearing even when recording. This, to me, seems to indicate that Exclusive mode is, as I've heard, only "applied" when recoding/timeshifting.


Portal Pro
June 20, 2005
Home Country
Denmark Denmark
This issue has been raised countless times the last few months, with no reply from any of the developers that can actually fix this. It seems this should be a fairly easy fix...

Users who are viewing this thread

Top Bottom