[confirm] - WinAmp Visualizations (eg, MilkDrop) Cause MP 1.1RC2 to Freeze During Launch

Discussion in 'MediaPortal 1.1.0 RC 1 & 2' started by neverness, May 17, 2010.

  1. neverness

    neverness Portal Member

    Joined:
    October 28, 2007
    Messages:
    9
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    MediaPortal Version: 1.1.0.0RC2
    MediaPortal Skin: Blue3wide
    Windows Version: Windows 7 32-bit
    CPU Type: Intel
    HDD: Samsung HD501LJ x 1
    Memory: 2GB
    Motherboard: Intel DG33TL
    Video Card: nVidia 7600GS
    Video Card Driver: nVidia 8.16.11.9107
    Sound Card: On-Board
    Sound Card AC3: Optical Out (from On-Board Sound)
    Sound Card Driver:
    1. TV Card: AverMedia Duo Hybrid
    1. TV Card Type: DVB-T & Analog
    1. TV Card Driver:
    2. TV Card: DigitalNow Dual Hybrid PCI-E S2
    2. TV Card Type: DVB-T & Analog
    2. TV Card Driver:
    3. TV Card:
    3. TV Card Type:
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec: MPV
    MPEG2 Audio Codec: MPA
    h.264 Video Codec: ffdshow
    Satelite/CableTV Provider:
    HTPC Case: Antec NSK2480
    Cooling: Scythe Ninja-Mini, SFlex-D
    Power Supply:
    Remote: MCE
    TV: Sony Bravia 46"
    TV - HTPC Connection: HDMI

    When MilkDrop 2.0 or 2.0c are enabled as the visualization module, MediaPortal 1.1RC2 freezes on launch 98% of the time. Very rarely, it actually loads, but nearly always it freezes with a blank/black MilkDrop window open. For previous versions of MediaPortal (with the same versions of MilkDrop), the black MilkDrop window would appear for a moment then vanish, but with 1.1RC2 it doesn't get past that. The splash screen freezes on "Loading window plugins".

    Here are my installation notes for MilkDrop, in case I've done something wrong:

    - Install WinAmp 5.51, to get MilkDrop 2.0c
    - Copy vis_milk2.dll to the MediaPortal\MusicPlayer\plugins\visualizations folder
    - Copy the presets to MediaPortal\MusicPlayer\plugins\visualizations\Milkdrop2
    - Copy nscrt.dll to the root MediaPortal folder
    - Copy the milk2.ini file to MediaPortal\plugins\plugins\milk2.ini (yes, with the double "plugins" folder... that seems to be an error, but if you put the config file there, it works! Or at least, it used to, as of MediaPortal 1.0.2, which was the last version I tried when MilkDrop was known to work.)



    Note, the version of MilkDrop that is currently shipped with the latest WinAmp version is 2.2, however this produces an error message in MediaPortal, and can't be loaded or configured. To get MilkDrop 2.0c you need WinAmp 5.51, a quick search for winamp551_full_emusic-7plus_en-us.exe will give you a few places to get it.

    Logs are attached. Although I usually run a fair few plugins and custom skins, for the logging I was sure to use only Blue3wide and the standard plugins. All custom plugins were disabled, by hand. (Looking forward to the RC3 debug logging helper!!)

    Thanks, and love your work!

    -- Neverness
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!