Wrong movie duration in .ts file (1 Viewer)

dacool

Portal Member
March 14, 2011
7
0
MediaPortal Version: 1.2.0
MediaPortal Skin: default
Windows Version: Win7 SP1
CPU Type: Intel Core 2 Duo P7550 2,26GHz
HDD: Macmini HD
Memory: 2GB
Motherboard: Macmini
Video Card: Geforce 9400
Video Card Driver: nvidia 8.15.11.8684
Sound Card: Onboard
Sound Card AC3:
Sound Card Driver: Realtek 6.0.1.5936
1. TV Card: EyeTV Hybrid
1. TV Card Type: DVB-C
1. TV Card Driver: 5.9.813.1
2. TV Card: EyeTV Hybrid
2. TV Card Type: DVB-C
2. TV Card Driver: 5.9.813.1
3. TV Card: Terratec H5
3. TV Card Type: DVB-C
3. TV Card Driver:5.9.1202.0
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec: FFDSHOW Video decoder
MPEG2 Audio Codec: AC3Filter
h.264 Video Codec: FFDSHOW DXVA Video decoder
Satelite/CableTV Provider: Welho (Finland)
HTPC Case: Mac mini
Cooling: fanless
Power Supply:
Remote: Logitech MX 5000
TV: Sony 46" LCD
TV - HTPC Connection: DVI to HDMI, Audio: 3.5mm jack

Im sorry for my bad english.
I started to search why mtn don't do thumbs for videos what have recorded from scrabled channels. I quess tswriter don't write movie duration to the file when using mdapi decoder. At least mtn says 24h duration for file:

Code:
\Team MediaPortal\MediaPortal\MovieThumbnailer>mtn.exe "\\mediasrv1\sharename$\tvrecords\Discovery Channel - 2012-08-21 - 22_00.ts"  -c 2 -r 2 -D 8 -B 500 -o .jpg -i -P -W -t
 
File: \\mediasrv1\sharename$\tvrecords\Discovery Channel - 2012-08-21 - 22_00.ts
Size: 1265706240 bytes (1,18 GiB), duration: 24:05:57, avg.bitrate: 117 kb/s
Audio: mp2, 48000 Hz, stereo, 256 kb/s (fin)
Audio: ac3
Video: mpeg2video, yuv420p, 720x576, 10000 kb/s, 25,00 fps(r)
  * scaling input * 720x576 => 1024x576 according to sample_aspect_ratio 64/45
  step: 17251 s; # tiles: 2x2, tile size: 512x288; total size: 1024x576
  all rows're skipped?

I run one file with projectx and it fixed 1429 out of sequence warnings/errors. Now it's showing duration to 10h, when it's should be around 1h. And now the ProjectX fixed something, that mtn will run thumb file. But it makes only 1 picture and while block next to it, because it's trying to get second picture from 4:25:14 what is out of endof file.

Code:
\Team MediaPortal\MediaPortal\MovieThumbnailer>mtn.exe "\\mediasrv1\sharename$\tvrecords\Discovery Channel - 2012-08-21 - 22_00[remux].ts" -c 2 -r 2 -D 8 -B 500 -o .jpg -i -P -W -t
 
File: \\mediasrv1\sharename$\tvrecords\DiscoveryChannel - 2012-08-21 - 22_00[remux].ts
Size: 1266089948 bytes (1,18 GiB), duration: 10:50:35, avg.bitrate: 259 kb/s
Audio: mp2, 48000 Hz, stereo, 256 kb/s (deu)
Audio: ac3
Video: mpeg2video, yuv420p, 720x576, 10000 kb/s, 25,00 fps(r)
  * scaling input * 720x576 => 1024x576 according to sample_aspect_ratio 64/45
  step: 7707 s; # tiles: 2x2, tile size: 512x288; total size: 1024x576
  skipping shot at 04:25:14 because got previous shot
  skipping shot at 06:33:41 because got previous shot
  skipping shot at 08:42:08 because got previous shot
  changing # of tiles to 2x1 because of skipped shots; total size: 1024x288
  0,23 s, 4,27 shots/s; output: \\mediasrv1\sharename$\tvrecords\Discovery Channel - 2012-08-21 - 22_00[remux].jpg

Is there any command line tool, to fix those ts files after recording, before mtn will run. Or better mdapi for newcs client.
 

Users who are viewing this thread

Similar threads

That seems likely. I tried the h264 ts cutter (found here) and it sort of works with HEVC/x265. The Preview has problems decoding the image, but if you know the area where to cut you can find a place. I had to change the settings (as a dialogbox suggested) to I-Frames as Cut-In-Points and All-Frames as Cut-Out-Points or else the...
That seems likely. I tried the h264 ts cutter (found here) and it sort of works with HEVC/x265. The Preview has problems decoding...
Hi there, I have a strange problem with mkvmerge when processing some recordings from german DVB-T2. So what's happening: I...
Replies
2
Views
943
It is looking and working very well now and I am almost at the point of switching my HTPC to MP2, madvr would definitely push me over the edge for sure.;)
It is looking and working very well now and I am almost at the point of switching my HTPC to MP2, madvr would definitely push me...
We are proud to present MediaPortal 2.3 MediaPortal 2.3 is a full-blown media center software that addresses the most common user...
Replies
4
Views
3K
Been testing and mostly solved by using Automatic - yet this morning the TV recording of BBC1 Andrew Marr went out of sync. Windows 7 worked lovely windows 10 on Intel NUC seems to have all sorts of issues (Mostly Windows 10 - MS deciding that it knows best and I got a update/reboot when I'd told it not too!)
Been testing and mostly solved by using Automatic - yet this morning the TV recording of BBC1 Andrew Marr went out of sync...
Have an issue with several AAC 2.0 files going out of sync Video plays fine, audio gets delayed. that is video is ahead of sound -...
Replies
2
Views
2K
Sorry you can't play my files. Basically they are broadcast as 3 x Mpeg-Audio 2.0 tracks (one track has left/right, one has center/LFE, and one has surround left/right). So the only way to get them to "usable" is to convert them...DTS-HDMA is the best choice since it keeps it "lossless". While it's still a transcode, it's a transcode...
Sorry you can't play my files. Basically they are broadcast as 3 x Mpeg-Audio 2.0 tracks (one track has left/right, one has...
I have some .TS files that wouldn't play in MediaPortal. The solution was to check the box in MediaPortal Configuration that says...
Replies
9
Views
2K
Okay, no problem. At least we know that there was no problem with TV Server because the new CAM works. Marking thread as "no bug"...
Okay, no problem. At least we know that there was no problem with TV Server because the new CAM works. Marking thread as "no bug"...
MediaPortal Version: 1.15.0 Description I've just added a CAM to my Technotrend c-1501 on a well-working system (w10, asus...
Replies
5
Views
2K
Top Bottom