Wrong Title used for recording (1 Viewer)

jameson_uk

Retired Team Member
  • Premium Supporter
  • January 27, 2005
    7,258
    2,528
    Birmingham
    United Kingdom United Kingdom
    Country flag
    RC4:
    RC4:
    Blue3 Wide:
    XP Home:
    Pinnacle 7010ix:
    Dual DVB-T and dual DVB-S:
    Latest:

    Whilst testing MP going into and out of S3 standby I set it to record a couple of short programs today. I set it to record a 5 min program starting at 10:30 and finshing at 10:35 called Tate Modern. The file and info however were taken from the program starting after this (my big gay prom)

    Extract from tvserver_tv.log.... notice how at 10:25:02.109375 it is going to record
    Code:
    Recording Tate Modern  added in _recordingsInProgressList
    but at 10:25:09.359375 it is now using info from next program
    Code:
    record to C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\recordings\My Big Gay Prom - Channel 4 - 2008-12-04.mpg
    Code:
    2008-12-04 08:57:37.127375 [PowerEventThread]: PowerScheduler: Set wakeup timer to wakeup system in 86.3814708333333 minutes
    2008-12-04 10:24:01.515625 [PowerScheduler Waiter]: PowerScheduler: OnResume
    2008-12-04 10:24:09.578125 [PowerEventThread]: TV service PowerEventThread 30
    2008-12-04 10:24:09.578125 [WinController exit thread]: WindowsController: ExitWindows performed, result: True
    2008-12-04 10:24:09.703125 [PowerEventThread]: OnPowerEvent: PowerStatus: ResumeAutomatic
    2008-12-04 10:24:09.703125 [PowerEventThread]: OnPowerEventHandler: PowerStatus: ResumeAutomatic
    2008-12-04 10:24:09.703125 [PowerEventThread]: PowerScheduler: System has resumed automatically from standby
    2008-12-04 10:24:09.718750 [PowerEventThread]: PowerScheduler: System changed from idle state to busy state
    2008-12-04 10:24:09.734375 [PowerEventThread]: Controller: epg start
    2008-12-04 10:24:09.781250 [PowerEventThread]: TV service PowerEventThread 30
    2008-12-04 10:25:02.109375 [Scheduler timer]: Recording Tate Modern  added in _recordingsInProgressList
    2008-12-04 10:25:02.109375 [Scheduler timer]: Scheduler : time to record TvDatabase.Channel 04/12/2008 10:25:02-04/12/2008 10:35:00 Tate Modern
    2008-12-04 10:25:02.109375 [Scheduler timer]: Controller: find free card for channel Channel 4
    2008-12-04 10:25:02.109375 [Scheduler timer]: Controller:   got 1 tuning details for Channel 4
    2008-12-04 10:25:02.109375 [Scheduler timer]: Controller:   channel #1 DVBT:tv:Channel 4 TV Channel 4 Freq:658167 ONID:9018 TSID:8198 SID:8384 PMT:0x104 FTA:True LCN:4 BandWidth:8 
    2008-12-04 10:25:02.109375 [Scheduler timer]: Controller:    card:1 type:DvbT is available priority:7 #users:0 same transponder:False
    2008-12-04 10:25:02.109375 [Scheduler timer]: Controller:    card:2 type:DvbT is available priority:6 #users:0 same transponder:False
    2008-12-04 10:25:02.109375 [Scheduler timer]: Controller:    card:3 type:DvbS cannot tune to channel
    2008-12-04 10:25:02.109375 [Scheduler timer]: Controller:    card:4 type:DvbS cannot tune to channel
    2008-12-04 10:25:02.109375 [Scheduler timer]: Controller:    card:5 type:Analog cannot tune to channel
    2008-12-04 10:25:02.109375 [Scheduler timer]: Controller:    card:6 type:Analog cannot tune to channel
    2008-12-04 10:25:02.125000 [Scheduler timer]: Controller:    card:7 type:RadioWebStream cannot tune to channel
    2008-12-04 10:25:02.125000 [Scheduler timer]: Controller: found 2 available
    2008-12-04 10:25:02.125000 [Scheduler timer]: Scheduler : record on free card:1 priority:7
    2008-12-04 10:25:02.125000 [Scheduler timer]: Scheduler : record, first tune to channel
    2008-12-04 10:25:02.125000 [16]: card: Tune 1 to Channel 4
    2008-12-04 10:25:02.125000 [16]: card: user: scheduler14:1:-1 tune DVBT:tv:Channel 4 TV Channel 4 Freq:658167 ONID:9018 TSID:8198 SID:8384 PMT:0x104 FTA:True LCN:4 BandWidth:8
    2008-12-04 10:25:02.125000 [16]: dvbt:  Tune:DVBT:tv:Channel 4 TV Channel 4 Freq:658167 ONID:9018 TSID:8198 SID:8384 PMT:0x104 FTA:True LCN:4 BandWidth:8
    2008-12-04 10:25:02.125000 [16]: dvbt: tune: Assigning oldChannel
    2008-12-04 10:25:02.125000 [16]: dvbt: tune: Current channel is null
    2008-12-04 10:25:02.125000 [16]: dvbt: tune: Graph is tunning
    2008-12-04 10:25:02.125000 [16]: dvbt: tune: Getting default locator
    2008-12-04 10:25:02.125000 [16]: dvbt: tune: Putting bandwidth 8
    2008-12-04 10:25:02.125000 [16]: dvbt: tune: put_ONID 9018
    2008-12-04 10:25:02.125000 [16]: dvbt: tune: put_SID 8384
    2008-12-04 10:25:02.125000 [16]: dvbt: tune: put_TSID 8198
    2008-12-04 10:25:02.125000 [16]: dvbt: tune: Carrier frequency 658167
    2008-12-04 10:25:02.125000 [16]: dvbt: tune: put_Locator
    2008-12-04 10:25:02.125000 [16]: dvbt: tune: Submitting tune request: SubId -1, channel DVBT:tv:Channel 4 TV Channel 4 Freq:658167 ONID:9018 TSID:8198 SID:8384 PMT:0x104 FTA:True LCN:4 BandWidth:8
    2008-12-04 10:25:02.125000 [16]: dvbt: tune: Submitting tune request: System.__ComObject
    2008-12-04 10:25:02.125000 [16]: dvb:Submiting tunerequest Channel:Channel 4 subChannel:-1 
    2008-12-04 10:25:02.140625 [16]: dvb:Getting new subchannel
    2008-12-04 10:25:02.140625 [16]: dvb:GetNewSubChannel:0 #0
    2008-12-04 10:25:02.140625 [16]: dvb:Submit tunerequest size:1 new:0
    2008-12-04 10:25:02.140625 [16]: subch:0 OnBeforeTune
    2008-12-04 10:25:02.140625 [16]: dvb:Submit tunerequest calling put_TuneRequest
    2008-12-04 10:25:05.562500 [16]: dvb:Submit tunerequest done calling put_TuneRequest
    2008-12-04 10:25:05.562500 [16]: subch:0 OnAfterTune
    2008-12-04 10:25:05.562500 [16]: dvbt: tune: Running graph for channel TvLibrary.Implementations.DVB.TvDvbChannel
    2008-12-04 10:25:05.562500 [16]: dvbt: tune: SubChannel 0
    2008-12-04 10:25:05.562500 [16]: subch:0 OnGraphStart
    2008-12-04 10:25:05.562500 [16]: subch:0 Graph already running - skip WaitForPMT
    2008-12-04 10:25:05.562500 [16]: dvb:  RunGraph
    2008-12-04 10:25:08.562500 [16]: dvb:  LockedInOnSignal waiting 20ms
    2008-12-04 10:25:08.593750 [16]: dvb:  LockedInOnSignal waiting 20ms
    2008-12-04 10:25:08.625000 [16]: dvb:  LockedInOnSignal waiting 20ms
    2008-12-04 10:25:08.656250 [16]: dvb:  LockedInOnSignal waiting 20ms
    2008-12-04 10:25:08.687500 [16]: dvb:  LockedInOnSignal waiting 20ms
    2008-12-04 10:25:09.312500 [16]: dvb:  LockedInOnSignal ok
    2008-12-04 10:25:09.312500 [16]: subch:0 OnGraphStarted
    2008-12-04 10:25:09.312500 [16]: subch:0 SetupPmtGrabber:pid 104 sid:20C0
    2008-12-04 10:25:09.312500 [16]: subch:0 set pmt grabber pmt:104 sid:20C0
    2008-12-04 10:25:09.312500 [16]: WaitForPMT: Waiting for PMT.
    2008-12-04 10:25:09.328125 [11]: subch:0 OnPMTReceived() True
    2008-12-04 10:25:09.328125 [16]: WaitForPMT: Found PMT after 0.015625 seconds.
    2008-12-04 10:25:09.328125 [16]: subch:0 SendPmt:20C0 20C0 FFFFFFFF 11
    2008-12-04 10:25:09.328125 [16]: Decode pmt
    2008-12-04 10:25:09.328125 [16]: Set descriptor data with length 3
    2008-12-04 10:25:09.328125 [16]: Set descriptor data with length 6
    2008-12-04 10:25:09.328125 [16]: PROBLEM : descriptor lengths dont match 3 9
    2008-12-04 10:25:09.328125 [16]: Set descriptor data with length 6
    2008-12-04 10:25:09.328125 [16]: PROBLEM : descriptor lengths dont match 3 9
    2008-12-04 10:25:09.328125 [16]: Set descriptor data with length 10
    2008-12-04 10:25:09.328125 [16]: Set descriptor data with length 3
    2008-12-04 10:25:09.328125 [16]: Set descriptor data with length 3
    2008-12-04 10:25:09.328125 [16]: Set descriptor data with length 3
    2008-12-04 10:25:09.328125 [16]: Set descriptor data with length 3
    2008-12-04 10:25:09.343750 [16]: subch:0 SendPMT version:17 len:165 8384
    2008-12-04 10:25:09.343750 [16]: subch:0 cam flags:True
    2008-12-04 10:25:09.343750 [16]: subch:0 SetMpegPidMapping
    2008-12-04 10:25:09.343750 [16]: subch:0  pid:0 pcr
    2008-12-04 10:25:09.343750 [16]: subch:0  pid:104 pmt
    2008-12-04 10:25:09.343750 [16]: subch:0  pid:B0A video type:MPEG-2
    2008-12-04 10:25:09.343750 [16]: subch:0    map pid:B0A video type:MPEG-2
    2008-12-04 10:25:09.343750 [16]: subch:0  pid:B0B audio lang: type:MPEG-1
    2008-12-04 10:25:09.343750 [16]: subch:0    map pid:B0B audio lang: type:MPEG-1
    2008-12-04 10:25:09.343750 [16]: subch:0  pid:B0D audio lang: type:MPEG-1
    2008-12-04 10:25:09.343750 [16]: subch:0  pid:B0C subtitle type:6
    2008-12-04 10:25:09.343750 [16]: subch:0  pid:7EE type:B
    2008-12-04 10:25:09.343750 [16]: subch:0  pid:8B8 type:B
    2008-12-04 10:25:09.343750 [16]: subch:0  pid:8B7 type:B
    2008-12-04 10:25:09.343750 [16]: subch:0  pid:8B9 type:B
    2008-12-04 10:25:09.343750 [16]: subch:0 stop tif
    2008-12-04 10:25:09.343750 [16]: WaitForPMT: sending PMT to CAM took 0.015625 seconds.
    2008-12-04 10:25:09.343750 [16]: dvbt: tune: Graph running. Returning TvLibrary.Implementations.DVB.TvDvbChannel
    2008-12-04 10:25:09.359375 [16]: card: Tuner locked: True
    2008-12-04 10:25:09.359375 [16]: **************************************************
    2008-12-04 10:25:09.359375 [16]: ***** SIGNAL LEVEL: 80, SIGNAL QUALITY: 100 *****
    2008-12-04 10:25:09.359375 [16]: **************************************************
    2008-12-04 10:25:09.359375 [16]: card: tuned user: scheduler14 subchannel: 0
    2008-12-04 10:25:09.359375 [16]: user:scheduler14 add
    2008-12-04 10:25:09.359375 [Scheduler timer]: Scheduler : record to C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\recordings\My Big Gay Prom - Channel 4 - 2008-12-04.mpg
    2008-12-04 10:25:09.359375 [16]: card: StartRecording 1 C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\recordings\My Big Gay Prom - Channel 4 - 2008-12-04.ts
    2008-12-04 10:25:09.359375 [16]: StartRecording to C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\recordings\My Big Gay Prom - Channel 4 - 2008-12-04.ts
    2008-12-04 10:25:09.359375 [16]: subch:0 StartRecord(C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\recordings\My Big Gay Prom - Channel 4 - 2008-12-04.ts)
    2008-12-04 10:25:09.359375 [16]: subch:0 record transport stream mode
    2008-12-04 10:25:09.375000 [16]: subch:0-0 tswriter StartRecording...
    2008-12-04 10:25:09.375000 [16]: SetRecorderPids
    2008-12-04 10:25:09.375000 [16]: DVB subch:0 Started recording
     

    Paranoid Delusion

    Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    United Kingdom United Kingdom
    Think i may have seen this myself, but it did not register at the time, so have set 2 short recordings, bbc news northwest tonight and weather, lets see what names come up :)
     

    Paranoid Delusion

    Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    United Kingdom United Kingdom
    jameson_uk

    Can you change your recording settings for all your cards to ts format, mpeg is causing some issues, this may be one of them as unable to repeat.

    This could also resolve some other issues as well that you seem to have.
     

    jameson_uk

    Retired Team Member
  • Premium Supporter
  • January 27, 2005
    7,258
    2,528
    Birmingham
    United Kingdom United Kingdom
    Country flag
    jameson_uk

    Can you change your recording settings for all your cards to ts format, mpeg is causing some issues, this may be one of them as unable to repeat.

    This could also resolve some other issues as well that you seem to have.
    Think this is a little bug with the log. I am recording as ts format (see log it only quote mpg on first line). I will check later to see if other recordings are doing the same (ie. saying mpg in first line and then ts or whether this is related to the standby issues I seem to be having)
    Code:
    2008-12-04 10:25:09.359375 [Scheduler timer]: Scheduler : record to C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\recordings\My Big Gay Prom - Channel 4 - 2008-12-04.mpg
    2008-12-04 10:25:09.359375 [16]: card: StartRecording 1 C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\recordings\My Big Gay Prom - Channel 4 - 2008-12-04.ts
    2008-12-04 10:25:09.359375 [16]: StartRecording to C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\recordings\My Big Gay Prom - Channel 4 - 2008-12-04.ts
    2008-12-04 10:25:09.359375 [16]: subch:0 StartRecord(C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\recordings\My Big Gay Prom - Channel 4 - 2008-12-04.ts)
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    Hi,

    Are you sure you are recording in .TS for all tuners? They need to be set individually.

    Not trying to teach you to suck eggs, but I've slipped up on this one myself.

    Mark
     

    jameson_uk

    Retired Team Member
  • Premium Supporter
  • January 27, 2005
    7,258
    2,528
    Birmingham
    United Kingdom United Kingdom
    Country flag
    Are you sure you are recording in .TS for all tuners? They need to be set individually.

    Not trying to teach you to suck eggs, but I've slipped up on this one myself.
    I checked this the other day and definately all tuners set to records as TS.

    File created was definately called "My Big Gay Prom - Channel 4 - 2008-12-04.ts"
     

    Paranoid Delusion

    Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    United Kingdom United Kingdom
    That's strange because the logs would definately state ts also, have you got webradio pointing to the folders as well, and have you got a timeshfting folder inside the recording folder, using same folder not advised for both.
     

    jameson_uk

    Retired Team Member
  • Premium Supporter
  • January 27, 2005
    7,258
    2,528
    Birmingham
    United Kingdom United Kingdom
    Country flag
    That's strange because the logs would definately state ts also, have you got webradio pointing to the folders as well, and have you got a timeshfting folder inside the recording folder, using same folder not advised for both.
    I have not done anything with Web Radio but I am not at home to check what the defaults are. Is this turned off normally??
     

    Paranoid Delusion

    Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    United Kingdom United Kingdom
    Nope its enabled, and shows up in manual control setting.

    Tried some short recordings and they worked fine (5 minute shows).

    The only thing i have experienced is WebEPG the data has failed for Channel E4 from Radio Times since thursday, so have switched back to DVB epg and now i'm having some recording issues, had to uninstall TVServer\plugin, delete the MSSql database and reconfigure to get recordings to work correctly again.
    So it does not look to be a good idea to switch from one to the other on a running setup, just in case that information may help you.
     

    jameson_uk

    Retired Team Member
  • Premium Supporter
  • January 27, 2005
    7,258
    2,528
    Birmingham
    United Kingdom United Kingdom
    Country flag
    Nope its enabled, and shows up in manual control setting.

    Tried some short recordings and they worked fine (5 minute shows).

    The only thing i have experienced is WebEPG the data has failed for Channel E4 from Radio Times since thursday, so have switched back to DVB epg and now i'm having some recording issues, had to uninstall TVServer\plugin, delete the MSSql database and reconfigure to get recordings to work correctly again.
    So it does not look to be a good idea to switch from one to the other on a running setup, just in case that information may help you.
    I am just using the default out of the box setting at the minute. I am only using the DVB EPG (not got the damn satellite connection in my flat working yet)

    I currently have all recordings going to
    C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\recordings
    and timeshift to
    C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer

    I will change these at some point in the future when I decide where to store stuff but for the time being do you think it would help to move the web radio to a different folder?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Fred Fred TV recording with wrong title 1.19 0
    horned_reaper 1.25.0 Wrong processing of / character in artist name ID3 tag Bugreports 5
    M 1.25.0 Wrong signal strenth with Digital Devices Max M4 and CineS2 TV-Server 0
    horned_reaper [solved] Wrong MBID for Artist Fanart Handler 7
    vuego themoviedb.org - Covers downloaded in the wrong language Moving Pictures 8
    doskabouter wrong link Website/Forum/Wiki Feedback 0
    doskabouter wrong link Website/Forum/Wiki Feedback 0
    G 1.23.0 Wrong return value for refresh rate / DRR Bugreports 4
    doskabouter 1.23.0 MatroskaTagInfo uses the wrong casing for tags Bugreports 27
    doskabouter Wrong links Website/Forum/Wiki Feedback 0
    doskabouter Wrong link Website/Forum/Wiki Feedback 0
    azzuro [fixed] [MP2-813] Album artist filter wrong display Submit: Bug Reports 75
    Terra Homepage forum links on website are wrong Website/Forum/Wiki Feedback 0
    R Media portal resumes with wrong screen resolution General Support 3
    Ralph Holmes Wrong audio source in TV General 1
    N [solved] When MP2-Client is trying to register credentials, it uses the wrong machine name MediaPortal 2 7
    D Recorded TV: Wrong running time being reported General 3
    fischy667 wrong/no sync with trakt on some series Trakt 2
    M Wrong DVB-T tuning parameters for Sweden, Vannas - Granlundsberget 1.20 Pre Release 1
    joecrow (Solved) EPG wrong General Support 18
    joEhSuper [solved] Latest Media Handler wrong version in MPE Fanart Handler 3
    FlatEric [solved] 5016: Same position for title and speed-info when forwarding watch/edit Videos 3
    R MP 2.2.3 Search TV program only with the correct begin of show title General 7
    J [fixed] Import issue with alternate movie title matching the name of another movie Submit: Bug Reports 7
    J [fixed] Importer confused on specific movies with the same title, different years and different NFO's Submit: Bug Reports 3
    Similar threads

























    Top Bottom