XBNE : Editeur pour la base de données Vidéo (2 Viewers)

Vincent81

Portal Member
June 29, 2010
49
14
Home Country
France France
Bonjour,
Je ne sais pas si je suis dans la bonne section, mais je n'ai pas trouvé de section "Logiciels Externes".

J'ai modifié mon logiciel XBNE pour qu'il puisse accéder et modifier la base de données vidéo de MediaPortal.
Je l'ai fait un peu pour m'amuser et n'étant pas un spécialiste de MediaPortal, je ne sais pas trop si cela peut servir à beaucoup ?
Il permet d'éditer les champs et les images des films, il récupère les infos avec Ciné-Passion, TheMovieDB, ImDB et tous les scraper de XBMC. Il peut faire de l'édition multiples, des renommages automatiques et plein d'autres choses encore...
Il est en Anglais et Français, mais c'est la version "Beta" pour MediaPortal, alors soyez indulgent et retournez moi les bugs SVP. Et si le soft vous parait intéressant, dites moi ce qu'il lui manque, je le rajouterais...


Téléchargement
 

vinch100

MP Donator
  • Premium Supporter
  • August 21, 2006
    107
    8
    Home Country
    Switzerland Switzerland
    Je ne connaissais pas du tout mais c'est une très bonne idée, merci !:D
     

    MEGA180
    Country flag

    Portal Pro
    January 8, 2007
    102
    5
    57
    Home Country
    France France
    Bonjour,
    ça a l'air de bien fonctionner
    il récupère la base MP et les recherches fonctionnent bien.
    Je n'ai en revanche pas compris si il y avait une manip à faire pour sauvegarder les modifications dans la base MP.
    Merci
     

    Vincent81

    Portal Member
    June 29, 2010
    49
    14
    Home Country
    France France
    Hello,
    Normallement c'est automatique, mais comme ça fait longtemps que je n'ai pas essayé la version MP (aucun retour), peut-être que ça marche pas, j’essaierais de regarder dans la semaine...
     

    Vincent81

    Portal Member
    June 29, 2010
    49
    14
    Home Country
    France France
    Bon, je viens d'installer MediaPortal, et essayer de le configurer (un peu seulement, 1/2 heure, faut pas pousser), fait un scrap (grab) avec ImDB (le seul qui marche), il a tant bien que mal trouver 2 ou 3 films, jusque la OK, ils apparaissent bien dans XBNE, mais aprés, je ne sait même pas les voir dans MP (skin standard), il me montre tout les fichiers de mon rep, pas seulement ceux de la base, et dans l'éditeur du configurateur, il n'y en à toujours qu'un.
    Bon désolé, les gas, j'abandonne la version MP de XBNE, c'est trop galère comme soft, déjà que XBNE est compliqué, je vais pas ajouter une usine à gaz à une autre.
    Quand j'aurais 2 ou trois jours devant moi, pour faire marcher MP, et si il y a un besoin,....
    :sorry:
     

    MEGA180
    Country flag

    Portal Pro
    January 8, 2007
    102
    5
    57
    Home Country
    France France
    Dommage, ça me plaisait bien !
    mais je galère aussi bien dans moving pictures que dans l'option video d'origine ...
    Espérons que tu aies 3 jours à perdre ... cet été !
     

    Vincent81

    Portal Member
    June 29, 2010
    49
    14
    Home Country
    France France
    Bon, finalement j'ai eu 3 jours à perdre ;)
    Vous pouvez essayer la version 11.8.3.0, j'ai corrigé le problème d'écriture dans la base.
    XBNE V11.8.3.0
    C'était une histoire de point à la place de la virgule dans le rating ImDB.
    Des retours seraient appréciés...
     

    MEGA180
    Country flag

    Portal Pro
    January 8, 2007
    102
    5
    57
    Home Country
    France France
    Bonjour Vincent et merci pour ta réalisation et ton implication sur MP.

    J'ai installé la version 1.8.3.0, je suis sous Vista x64 et même en installant par clic droit, exécuter en mode admin windows m'indique que l'installation ne s'est pas déroulée correctement. Je suppose donc un problème de droits d'accès.
    XBNE semble fonctionner cependant, j'ai ma liste de films, je peux faire des corrections. Je ne sais pas quelles sont les options importantes à cocher et si il faut lui demander de recopier la base XBNE vers MP.

    Je ne vois toujours pas ces infos dans MP (v 1.2 beta)/video.
    Quand je vais dans MP config/video/database : je n'ai pas la liste de mes films.

    Dis-moi ce qu'il faut que je teste.
    @+
     

    Vincent81

    Portal Member
    June 29, 2010
    49
    14
    Home Country
    France France
    Hello,
    Est tu sûr que tu à bien la dernière version, elle doit être indiqué dans le titre de la fenêtre.
    J'ai essayé avec la dernière version de MP, je ne sais plus laquelle.
    Si tu à quand même le problème, passe en mode "debug" dans les options, édite un film, fait une sauvegarde et envoi moi le fichier debug.log du rep de XBNE.

    Edit: C'est la 1.1.3 avec laquelle j'ai testé, je ne sais pas ou trouver la 1.2 beta, si tu à un lien pour que j'essaye.
    La sauvegarde est automatique, dés que tu fait une modif et que tu clique sur sauvegarde, XBNE envoi les nouvelle donnée à MP.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 2)

    Top Bottom