Advice needed - seeing some problems (1 Viewer)

Pamela

New Member
January 15, 2013
5
0
65
Home Country
United Kingdom United Kingdom
I am using Mediaportal 1.3 beta on win 7 home. I really like the interface and want to keep using it, but I am having a few problems.

Here are the issues I am seeing;

· Recordings stop ~10 minutes before the end of the programme, regardless of how much additional time has been configured.
· The index will show a recording is the correct length of time, e.g 47 mins, but when you access it, only a few mins has been recorded
· While watching a programme that is still being recorded (timeshifting), even without fast forwarding through, it believes it has caught up to the current point and throws you out.
· Cleanup sometimes deletes half watched recordings
· Frequently unable to change the volume level
· Frequently has no sound at all when waking from standby even though I have told it to restart the client on wakeup
· The client often freezes and can only be restarted via task manager
· Unable to start the client at all without a reboot

Are these known issues? Has anyone else seen some or all of these? To be fair MS Mediacenter also had several issues, but that’s why I moved to Mediaportal…
 

JimCatMP

Documentation Group
  • Team MediaPortal
  • April 1, 2010
    652
    283
    Leeds
    Home Country
    United Kingdom United Kingdom
    Hello Pamela

    1st - need the logs so community can take a look at your config and error messages. Start MP in debug mode

    MP_Debug1.jpg

    Select the "export all currently present logs" then upload the zip file.

    Without logs, 1st three issues seem likely to be related to disk system on TV Server, is TS buffer and recordings set to networked drive?
    Clean up - again, may be related to disk system - could be that the actual duration of the recording is being used and 1/2 watched by index time is more than enough for clean up to think you've watched more than X% (I did have a quick look to see if this is defined in configs, not that I could find, but was a quick look only on server & client).

    Sound issues - Win7 and master volume control is a known problem for MePo, need logs to confirm.

    Freezing client - no ideas, but as you say MediaCentre had issues, so this could be OS and/or hardware and not MePo.

    Cheers - JCMP
     

    Pamela

    New Member
    January 15, 2013
    5
    0
    65
    Home Country
    United Kingdom United Kingdom
    Thanks for that Jim,

    I've attached the log file as requested. If you could take a look it would be much appreciated!

    Regards
    Pamela[DOUBLEPOST=1358453261][/DOUBLEPOST]I exited MP to get the logs and it will not restart.

    It appears to be because mediaportal.ex *32 is still running.
    If I then kill the process in taskmanager I get two watchdog debugs...

    If I just kill the process before trying to restart I just get the one watchdog debug...

    Regards
    Pamela
     

    JimCatMP

    Documentation Group
  • Team MediaPortal
  • April 1, 2010
    652
    283
    Leeds
    Home Country
    United Kingdom United Kingdom
    Ok - not brilliant at logs by any means.

    From system event log...

    03/12/2012 07:19:54 Service Control Manager (0) Information The IPsec Policy Agent service entered the running state.
    03/12/2012 07:19:54 Service Control Manager (0) Information The Computer Browser service entered the running state.
    03/12/2012 07:20:00 Service Control Manager (0) Information The Computer Browser service entered the stopped state.
    03/12/2012 07:21:00 Service Control Manager (0) Information The Computer Browser service entered the running state.
    03/12/2012 07:21:06 Service Control Manager (0) Information The Computer Browser service entered the stopped state.

    This is change in how your system is running, from this point on, the Computer Browser starts every minute, then stops 6 seconds later - something of an overhead on a AMD-350 system, suggest looking at task scheduler for something run every minute. This change does not coincide with MePo install that I can see.

    Recordings & Time shift are to D: - assume this is local drive and not mapped?

    TV Server Error log - noted problem in connecting to MySQL

    2013-01-16 23:53:39.026461 [(23)]: plugin:xmltv StartImport - File [C:\TEMP\DG2XML\tvguide.xml] doesn't have read access : The process cannot access the file 'C:\TEMP\DG2XML\tvguide.xml' because it is being used by another process.
    2013-01-16 23:54:39.047894 [(23)]: plugin:xmltv StartImport - File [C:\TEMP\DG2XML\tvguide.xml] doesn't have read access : The process cannot access the file 'C:\TEMP\DG2XML\tvguide.xml' because it is being used by another process.
    2013-01-16 23:55:39.053327 [(5)]: plugin:xmltv StartImport - File [C:\TEMP\DG2XML\tvguide.xml] doesn't have read access : The process cannot access the file 'C:\TEMP\DG2XML\tvguide.xml' because it is being used by another process.
    2013-01-16 23:56:42.237941 [XmlTvImporter(17)]: channel#74 doesnt contain an id
    2013-01-16 23:56:42.241941 [XmlTvImporter(17)]: channel#77 doesnt contain an id
    2013-01-17 05:58:00.325662 [Channel state thread(24)]: ChannelState.DoSetChannelStates: An unknown error occured while setting channel states - The database backend (provider MySQL) could not be reached.
    Check the connection string: Server=HTPC;Database=MpTvDb;User ID=root;Password=MediaPortal;charset=utf8;Connection Timeout=30;
    Error: DatabaseUnavailableUnclassified
    Gentle.Common.GentleException: The database backend (provider MySQL) could not be reached.
    Check the connection string: Server=HTPC;Database=MpTvDb;User ID=root;Password=MediaPortal;charset=utf8;Connection Timeout=30; ---> System.Threading.ThreadAbortException: Thread was being aborted.
    at System.Net.UnsafeNclNativeMethods.OSSOCK.recv(IntPtr socketHandle, Byte* pinnedBuffer, Int32 len, SocketFlags socketFlags)

    However as from logs generally, you have TV service, not sure why this would occur.

    The quality of your signal seems to vary, with 25th & 30th Dec + 1st->3rd Jan + 8th Jan (very bad day), you may want to check your aerial connection.

    Beyond that, nothing I can see, but as said above, not brilliant on logs, hopefully someone more adept at reading the TV & TS logs will take a look.

    Cheers - JCMP
     

    findftp

    MP Donator
  • Premium Supporter
  • September 20, 2011
    184
    35
    Nootdorp
    Home Country
    Netherlands Netherlands
    Hi,

    I've got a similar problem which gets me to force a restart of tvservice once in a while.
    Mediaportal gives a message that there is not a free card available.
    My error log looks like:

    Code:
    2013-05-19 21:35:52.787108 [Channel state thread(24)]: ChannelState.DoSetChannelStates: An unknown error occured while setting channel states - The database backend (provider MySQL) could not be reached.
    Check the connection string: Server=mediacenter;Database=MpTvDb;User ID=root;Password=MediaPortal;charset=utf8;Connection Timeout=30;
    Error: DatabaseUnavailableUnclassified
    Gentle.Common.GentleException: The database backend (provider MySQL) could not be reached.
    Check the connection string: Server=mediacenter;Database=MpTvDb;User ID=root;Password=MediaPortal;charset=utf8;Connection Timeout=30; ---> System.Threading.ThreadAbortException: Thread was being aborted.
      at MySql.Data.MySqlClient.NativeDriver.Ping()
      at MySql.Data.MySqlClient.MySqlPool.CheckoutConnection()
      at MySql.Data.MySqlClient.MySqlPool.GetPooledConnection()
      at MySql.Data.MySqlClient.MySqlPool.GetConnection()
      at MySql.Data.MySqlClient.MySqlConnection.Open()
      at Gentle.Provider.MySQL.MySQLProvider.GetConnection()
      --- End of inner exception stack trace ---
      at Gentle.Common.Check.FailWith(Severity severity, Error error, Exception e, String msg)
      at Gentle.Common.Check.Fail(Exception e, Error error, Object[] args)
      at Gentle.Provider.MySQL.MySQLProvider.GetConnection()
      at Gentle.Framework.PersistenceBroker.Execute(SqlStatement stmt, IDbConnection dbConnection, IDbTransaction dbTransaction)
      at Gentle.Framework.SqlStatement.Execute()
      at TvDatabase.Channel.ReferringTuningDetail()
      at TvDatabase.TvBusinessLayer.GetTuningChannelsByDbChannel(Channel channel)
      at TvService.ChannelStates.DoSetChannelStates(IDictionary`2 cards, ICollection`1 channels, ICollection`1 allUsers, IController tvController)System.Threading.ThreadAbortException: Thread was being aborted.
      at MySql.Data.MySqlClient.NativeDriver.Ping()
      at MySql.Data.MySqlClient.MySqlPool.CheckoutConnection()
      at MySql.Data.MySqlClient.MySqlPool.GetPooledConnection()
      at MySql.Data.MySqlClient.MySqlPool.GetConnection()
      at MySql.Data.MySqlClient.MySqlConnection.Open()
      at Gentle.Provider.MySQL.MySQLProvider.GetConnection()

    tv.log looks like:
    Code:
    2013-05-19 21:35:52.738102 [(20)]: subch:1-1 tswriter StopTimeshifting...
    2013-05-19 21:35:52.740102 [(20)]: FreeSubChannel MD: freeing sub channel : 1
    2013-05-19 21:35:52.741102 [(20)]: FreeSubChannel MD: subchannel : 1 on channel RTL8 HD is still active
    2013-05-19 21:35:52.742102 [(20)]: tvcard:FreeSubChannel: subchannels count 2 subch#1
    2013-05-19 21:35:52.742102 [(20)]: DVB subch:1 Decompose()
    2013-05-19 21:35:52.747103 [(20)]: FreeSubChannel CA: freeing sub channel : 1
    2013-05-19 21:35:52.749102 [(20)]: user:Medion remove
    2013-05-19 21:35:52.750103 [(20)]: CardReservation.RemoveStopTicket: removed STOP reservation with id=10
    2013-05-19 21:35:52.753104 [TS_File_Cleanup(23)]: card: delete timeshift files C:\timeshift\live2-1.ts
    2013-05-19 21:35:52.754103 [(20)]: Controller:Timeshifting stopped on card:2
    2013-05-19 21:35:52.755103 [(20)]: RTSP: remove stream stream2.1
    2013-05-19 21:35:52.756105 [TS_File_Cleanup(23)]: card:  trying to delete C:\timeshift\live2-1.ts.tsbuffer
    2013-05-19 21:35:52.760104 [Channel state thread(24)]: Controller: DoSetChannelStates for 64 channels
    2013-05-19 21:35:52.795108 [Channel state thread(24)]: ChannelStates.DoSetChannelStates took 34 msec
    2013-05-19 21:35:52.798110 [Channel state thread(25)]: Controller: DoSetChannelStates for 64 channels
    2013-05-19 21:35:52.806109 [Channel state thread(25)]: ChannelStates.GetAllTimeshiftingAndRecordingChannels took 1 msec
    2013-05-19 21:35:52.821112 [(20)]: CiMenuSupported called cardid 3
    2013-05-19 21:35:52.822113 [(20)]: CiMenuSupported card Digital Devices DVB-S/S2 Tuner 1 supported: False
    2013-05-19 21:35:53.250166 [Channel state thread(25)]: ChannelStates.DoSetChannelStates took 453 msec
    2013-05-19 21:35:55.607111 [(20)]: PS: RegisterRemote tag: 3, uris: http://localhost:31458/92433ade_7fba_4d6d_b904_75075dba772d/kw68cxlgcskuwdke1rl+ym6a_46.rem, http://localhost:31458/92433ade_7fba_4d6d_b904_75075dba772d/kw68cxlgcskuwdke1rl+ym6a_46.rem
    2013-05-19 21:35:55.613114 [(20)]: PS: Set time of last user activity to 9:35:52 PM
    2013-05-19 21:35:57.758225 [TS_File_Cleanup(23)]: card: delete timeshift files C:\timeshift\live2-1.ts
    2013-05-19 21:35:57.760226 [TS_File_Cleanup(23)]: card:  trying to delete C:\timeshift\live2-1.ts.tsbuffer
    2013-05-19 21:35:57.761228 [TS_File_Cleanup(23)]: card:  deleted file C:\timeshift\live2-1.ts.tsbuffer
    2013-05-19 21:35:57.762227 [TS_File_Cleanup(23)]: card:  trying to delete C:\timeshift\live2-1.ts.tsbuffer1.ts
    2013-05-19 21:35:57.789230 [TS_File_Cleanup(23)]: card:  deleted file C:\timeshift\live2-1.ts.tsbuffer1.ts
    2013-05-19 21:35:57.794230 [TS_File_Cleanup(23)]: card:  trying to delete C:\timeshift\live2-1.ts.tsbuffer2.ts
    2013-05-19 21:35:57.821234 [TS_File_Cleanup(23)]: card:  deleted file C:\timeshift\live2-1.ts.tsbuffer2.ts
    2013-05-19 21:35:57.823234 [TS_File_Cleanup(23)]: card:  trying to delete C:\timeshift\live2-1.ts.tsbuffer3.ts
    2013-05-19 21:35:57.849237 [TS_File_Cleanup(23)]: card:  deleted file C:\timeshift\live2-1.ts.tsbuffer3.ts
    2013-05-19 21:35:57.854239 [TS_File_Cleanup(23)]: card:  trying to delete C:\timeshift\live2-1.ts.tsbuffer4.ts
    2013-05-19 21:35:57.856239 [TS_File_Cleanup(23)]: card:  deleted file C:\timeshift\live2-1.ts.tsbuffer4.ts
    2013-05-19 21:36:07.705490 [PS StandbyWakeup(15)]: PS: StandbyWakeupThread triggered by check interval
    2013-05-19 21:36:07.714491 [PS StandbyWakeup(15)]: PS: LoadSettings()
    2013-05-19 21:36:07.764517 [PS StandbyWakeup(15)]: PS: SetWakeupTimer()
    2013-05-19 21:36:07.765497 [PS StandbyWakeup(15)]: PS: Inspecting PowerController:
    2013-05-19 21:36:07.767498 [PS StandbyWakeup(15)]: PS: Inspecting Scheduled Recordings:
    2013-05-19 21:36:07.774499 [PS StandbyWakeup(15)]: PS: Inspecting XmlTvImport:
    2013-05-19 21:36:07.781500 [PS StandbyWakeup(15)]: PS: Inspecting Client Plugin:
    2013-05-19 21:36:07.782501 [PS StandbyWakeup(15)]: PS: No pending events found in the future which should wakeup the system
    2013-05-19 21:36:07.783500 [PS StandbyWakeup(15)]: PS: CheckForStandby()
    2013-05-19 21:36:07.784501 [PS StandbyWakeup(15)]: PS: Inspecting PowerController:
    2013-05-19 21:36:07.784501 [PS StandbyWakeup(15)]: PS: Inspecting Remote Client:
    2013-05-19 21:36:07.785501 [PS StandbyWakeup(15)]: PS: Inspecting Active Streams: StandbyPrevented
    2013-05-19 21:36:07.788503 [PS StandbyWakeup(15)]: PS: Inspecting TV Controller (Remote timeshifting): AwayModeRequested
    2013-05-19 21:36:07.790503 [PS StandbyWakeup(15)]: PS: Inspecting Processes:
    2013-05-19 21:36:07.791502 [PS StandbyWakeup(15)]: PS: Inspecting Active Network:
    2013-05-19 21:36:07.792501 [PS StandbyWakeup(15)]: PS: Inspecting Active Shares:
    2013-05-19 21:36:07.802503 [PS StandbyWakeup(15)]: PS: Inspecting Client Plugin (Media playing): StandbyPrevented
    2013-05-19 21:36:07.802503 [PS StandbyWakeup(15)]: PS: SetStandbyMode(AwayModeRequested)
    2013-05-19 21:36:07.803503 [PS StandbyWakeup(15)]: PS: System is busy and should not go to standby
    2013-05-19 21:36:10.628863 [(20)]: PS: RegisterRemote tag: 3, uris: http://localhost:31458/92433ade_7fba_4d6d_b904_75075dba772d/kw68cxlgcskuwdke1rl+ym6a_46.rem, http://localhost:31458/92433ade_7fba_4d6d_b904_75075dba772d/kw68cxlgcskuwdke1rl+ym6a_46.rem
    2013-05-19 21:36:10.635863 [(20)]: PS: Set time of last user activity to 9:36:07 PM
    2013-05-19 21:36:22.804409 [PS StandbyWakeup(15)]: PS: StandbyWakeupThread triggered by check interval
    2013-05-19 21:36:22.813410 [PS StandbyWakeup(15)]: PS: LoadSettings()
    2013-05-19 21:36:22.865418 [PS StandbyWakeup(15)]: PS: SetWakeupTimer()
     
    Last edited:

    LKA

    Portal Member
    February 26, 2012
    30
    4
    Home Country
    Germany Germany
    @findftp
    I have had a similar issue. I solved it with change TVService from Automatic to Automatic (Delayed start). With a reboot all worked smooth again.
     
    Last edited:

    findftp

    MP Donator
  • Premium Supporter
  • September 20, 2011
    184
    35
    Nootdorp
    Home Country
    Netherlands Netherlands

    Users who are viewing this thread

    Top Bottom