Assembly Reference Problems (1 Viewer)

Vic Demented

Retired Team Member
  • Premium Supporter
  • March 4, 2013
    42
    25
    51
    Brugge, Belgium
    Home Country
    United States of America United States of America
    Forgive the newbie post, but I really need to get up to speed on this quickly. I am trying to wrap my head around plugin & skin development for MP2, and I am running into a bunch of issues. First of all I am able to successfully build both the client and the server solutions. However when I load the UIPluginTemplate(MyPlugin) project, it is unable to find a reference to MediaPortal.Core.General.

    Error 25 The type or namespace name 'Core' does not exist in the namespace 'MediaPortal' (are you missing an assembly reference?) C:\Users\Administrator\Projects\MediaPortal-2\MediaPortal\Resources\Templates\UIPluginTemplate\Models\MyWorkflowModel.cs 27 19 MyPlugin


    Furthermore is it not possible to use the XAML designer in VS2010? I tried to use XamlPadX, but regardless of which tool I use, I keep getting an error that says:

    The type 'Screen' was not found. Verify that you are not missing an assembly reference and that all referenced assemblies have been built.

    I get the same error for the following tags:
    <Include>
    <DockPanel>
    <Resource>
    <Label>
    <ControlTemplate>
    <ResourceWrapper>
    <StackPanel>

    Any help would be greatly appreciated. I am just trying to get a stable dev environment up so I can get started.
     
    Last edited:

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,845
    7,185
    Home Country
    Germany Germany
    Hi,

    I never looked at the UIPluginTemplate before, so I guess it might be outdated. This could explain the issues. I will check this project over this weekend (or @chefkoch, can you take a look?)

    I think it could be easier to start with a copy of the "Weather" plugin, it has a quite simple structure. Be sure you check the http://wiki.team-mediaportal.com/2_MEDIAPORTAL_2/Contribute/Plugin_Development/New_plugin_checklist.

    The XAML stuff is a bit more difficult, for me as well: I currently don't know any way to use a graphical designer directly with MP2 skin files and resources. Even if there would be a way to "teach" the editors how to use our MPF-controls (like Screen), they would not work in editor, because MP2 uses different rendering than WPF.

    I can recommend to use Expression Blend 4 (now available for free, see also https://forum.team-mediaportal.com/...ow-titan-gets-transformed.114860/#post-946300), use it to design your control styles and copy the xaml-code into MP2 resource definitions. Another hint: separate styles from the actual screen layouts, i.e. define a button background gradient only once, use it multiple times.

    Morpheus
     

    Vic Demented

    Retired Team Member
  • Premium Supporter
  • March 4, 2013
    42
    25
    51
    Brugge, Belgium
    Home Country
    United States of America United States of America
    Yea, it looks like MediaPortal.Core.General no longer exists. I'll take a look at the weather portal and see if I can make some headway. Thanks Morpheus.
     

    Users who are viewing this thread

    Similar threads

    MP1 MP2 Building TV Plugin DE
    Thanks - i'll do the same.
    Thanks - i'll do the same.
    Hello, I am trying to build TVPlugin, from: https://github.com/MediaPortal/MediaPortal-1 Master Branch for 1.24. Commit ID...
    Replies
    49
    Views
    3K
    Azzuro and doskabouter, got it working. Resetting the database worked. And after linking to the server via current IP and making a new db, I relinked to the original db and all settings were restored. Thanks again and Happy New Year to all!
    Azzuro and doskabouter, got it working. Resetting the database worked. And after linking to the server via current IP and making a...
    A couple weeks ago the TV server service stopped working. Not urgent, so waited till today to research it. Did an upgrade to 1.26...
    Replies
    4
    Views
    655
    What is the status of the fix? I seem to be hitting this exact problem at channel 24 (in Seattle it is KUNS-DT).
    What is the status of the fix? I seem to be hitting this exact problem at channel 24 (in Seattle it is KUNS-DT).
    MediaPortal 2 Version: 2.2.2 Description I am setting up a new Windows 10 Pro system to replace my old Windows 7 WMC server to be...
    Replies
    33
    Views
    2K
    After uninstalling MySQL make sure you delete the MySQL folders in Program Files/Program Files (x86) and Program Data (if you do not see the Program Data folder you need to change the view to see hidden folders). A full reinstall of MP should then work
    After uninstalling MySQL make sure you delete the MySQL folders in Program Files/Program Files (x86) and Program Data (if you do...
    Hi I am running MediaPortal 1.2.3.0 as I am used to using it and found a newer version more difficult to use so I prefer not to...
    Replies
    2
    Views
    1K
    Yep then we have the exact same issue.... Anyone here who has a clue what to do???
    Yep then we have the exact same issue.... Anyone here who has a clue what to do???
    Hi! I installed MPExtended 0.6.0-beta and WebMediaPortal 0.6.0-beta and everything works almost perfect. But i have problem when i...
    Replies
    2
    Views
    2K
    Top Bottom