Broken Links on Contribute Page (1 Viewer)

rsbrux

Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,135
    115
    Home Country
    Switzerland Switzerland
    On the Contribute page, the following links under the heading "Documentation" are broken:
    Although I belong to the Documentation team, i don't find a way to edit the page.

    P. S. On the Documentation page and the Support page the following links are broken:
    The last two wind up on the Wiki homepage. A web search of the team-mediaportal.com site didn't turn up any likely candidates.

    I want to get active again in contributing to the documentation, but I never used Confluence much and have forgotten what little I knew.
    Where can I find some guidance on basic operations and the current standards?
     
    Last edited:

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    4,150
    2,399
    Nuenen
    Home Country
    Netherlands Netherlands
    Are you logged in on that page?
    If so, bottom left should show an edit icon.
    Don't know of any guidance, but using confluence should be pretty straightforward, and as long as you keep your changes nice and clear, there shouldn't be any problem
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,406
    1,456
    Southampton
    Home Country
    United Kingdom United Kingdom
    there shouldn't be any problem
    Hmm :unsure:

    In a previous life, I wrote various programming-related documents, but I coded the GML tags directly (used with "BookMaster") -- I never used a "wysiwyg" text editor. So I found using the Wiki system a bit of a culture shock. :eek:

    Also, I am currently still using my Windows XP laptop with an old version of Firefox (because this version is the last version of Firefox that runs on WinXP), and almost every time I have difficulty finding the "logout" button. It does not seem to be available on every panel, so I have to wander around various screens until I find it. (But I accept that this may be a consequence of using an old version of Firefox.)

    Also, I changed a page heading to make it more appropriate, only to find that it duplicated a page elsewhere in the Wiki, so I had to revert the title to its original value. This was a shock -- I would have expected that the page heading text was not related to the page file name, or to the page id used to store the page in a database (if that is where the pages are stored). It means that somewhat inappropriate, verbose, or inelegant headings have to be used merely to avoid duplications. Example: prefix every MP1 heading with the text "MP1: " prefix ecery MP2 heading with the text "MP2: ", and prefix every "TV Server" heading the text "TV Server: " (plus similar for the extensions and other tools). But this would look poor in the left side menu, where every heading would begin with this prefix text, and the meaningful part of the heading would be severely truncated by the limited width of the left side menu.

    Finally, when the Wiki was converted from the old software to the new, many of the links became garbled, but I suspect that this will be a large job to correct (every link would have to be reviewed manually, and corrected if necessary).

    -- from CyberSimian in the UK
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,135
    115
    Home Country
    Switzerland Switzerland
    Are you logged in on that page?
    If so, bottom left should show an edit icon.
    Don't know of any guidance, but using confluence should be pretty straightforward, and as long as you keep your changes nice and clear, there shouldn't be any problem
    I am happy to edit the mentioned pages and correct the links for which I have an idea where they should point. However, I would be grateful for suggestions on how to correct the links for which I haven't identified potential targets, particularly the links that point back to the page they're on. If worst comes to worst, I suppose I could just delete them, but presumably they once had a purpose. I would guess that they once pointed to content on the old wiki that didn't make it onto the new one.

    P.S. I have fixed what I could. The broken links on the Support page that I found evidently came from embedding the content of the Documentation page, so they didn't/don't need to be fixed separately. However, the Support page includes some other embedded pages which had similar problems, e.g.:
    • Forums Overview
    • Documentation: Use the Wiki!
    To my surprise, I was unable to find the former as an independent page.
    The errors I fixed appear to be due to incorrect formatting in converting links from the old Wiki, so perhaps there would be a way of detecting and fixing at least these problems automatically. For example:
    Correct link: Website/Forum/Wiki Feedback
    Previous (broken) link: http://forum.team-mediaportal.com/website-forum-wiki-feedback-58/
     
    Last edited:

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    4,150
    2,399
    Nuenen
    Home Country
    Netherlands Netherlands
    or pointing to a specific part on the same page?
    Usually that is done with # in the url, but I don't have a guide at hand on how to place the targets....
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,406
    1,456
    Southampton
    Home Country
    United Kingdom United Kingdom
    how to correct the links for which I haven't identified potential targets, particularly the links that point back to the page they're on.
    From the broken links that I have noticed, it looks as though some (many?) of them link to the supplementary pages, i.e. the pages that give more details about particular aspects of the topic described by the current page. So one could start by looking at the tree structure in the left side menu, and seeing if there are any supplementary pages that look appropriate for the broken links. (The supplementary pages are the ones that are indented relative to the parent page.)

    Of course, some links refer to pages outside the current topic, so if they are broken it may be more difficult to identify the intended destination :(. One would need to review the entire Wiki to see where it would have been appropriate to link as the destination (e.g. some links in the MP1 part linking to pages in the TV Server part).

    I have also noticed some cases where an image seems to be missing. I don't know whether those are still available somewhere, or whether new images would need to be created.

    I wonder if the old Wiki is still online somewhere? It would be out-of-date, but might contain the missing images and valid links.

    -- from CyberSimian in the UK
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,135
    115
    Home Country
    Switzerland Switzerland
    @CyberSimian Thanks for the tips! You probably replied while I was editing my last post, so you may want to read the update.
     

    Users who are viewing this thread

    Similar threads

    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the next release. We allocate about one month for Pre Release testing. In that time we will only fix bugs, after which comes the final release! Highlights of this release Bugfixes: [MP1-5081] - WatchDog...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Replies
    0
    Views
    730
    • Sticky
    We have just released MediaPortal 1.29 The Phantom Menace Highlights of this release Bugfixes: [MP1-5081] - WatchDog not switch Mediaportal log to Debug level [MP1-5082] - Error when MP restart [MP1-5086] - XMLTV Import error - An item with the same key has already been added. Since Pre-Release : [MP1-5089] - MpurlSourceSplitter...
    We have just released MediaPortal 1.29 The Phantom Menace Highlights of this release Bugfixes: [MP1-5081] - WatchDog not switch...
    We have just released MediaPortal 1.29 The Phantom Menace Highlights of this release Bugfixes: [MP1-5081] - WatchDog not switch...
    Replies
    0
    Views
    849
    I never dealed in detail with this, because I needed just to connect my IRSS, install the driver and directly it worked out of the box with MP2. Maybe other users may confirm, what they did or you tell us which remote you have. There is also an input device manager within MP2 which you can try.
    I never dealed in detail with this, because I needed just to connect my IRSS, install the driver and directly it worked out of the...
    The MediaPortal2 setup guide indicates IR Remotes require IRSS. It links to this page, which indicates IRSS is compatible with...
    Replies
    1
    Views
    538
    Just for your information: couldn't find the ns*.tmp file...
    Just for your information: couldn't find the ns*.tmp file...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Replies
    39
    Views
    3K
    It's very strange, but you can see that it happens. The logic of NSIS is a complete mystery. :)
    It's very strange, but you can see that it happens. The logic of NSIS is a complete mystery. :)
    We have just released MediaPortal 1.28 Summer Breeze Highlights of this release Bugfixes: [MP1-5053] - TV framerate is not...
    Replies
    12
    Views
    2K
    Top Bottom