Experimental TsReader development (1 Viewer)

HomeY

Test Group
  • Team MediaPortal
  • February 23, 2008
    6,466
    4,635
    45
    ::1
    Netherlands Netherlands
    Country flag
    Mr Duck probably has just PopPlayer + TsReader.ax isntalled manually. TsReader's main target is to work on MediaPortal, if it wont work on some other player side then it is up to the other player developers to have a peek.
    So that's what i get for jumping in and giving a quick answer ;) Missed that previous post :rolleyes:
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    I had to create the folder "C:\ProgramData\Team MediaPortal\MediaPortal\log" before the logs would appear. But after I did that, v69 started working! I tried deleting the folder and then v69 stopped working, nearly locking up the system as before! So if the folder isn't there, don't try and write the logs I guess :)
    OK - it's a logging issue (which was one of the changes)
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    I had to create the folder "C:\ProgramData\Team MediaPortal\MediaPortal\log" before the logs would appear. But after I did that, v69 started working! I tried deleting the folder and then v69 stopped working, nearly locking up the system as before! So if the folder isn't there, don't try and write the logs I guess :)
    OK - it's a logging issue (which was one of the changes)
    Just posted noStopMod70 on the front page, with a fix for the logging issue.

    Tony
     

    toga67

    Portal Pro
    October 15, 2010
    181
    11
    Germany Germany
    Hi Tony,
    i have always some dropped frames. Not very much but they are existing. I also tried a lot of your tsreader versions but nothing really helps. Do you have any idea what is wrong with my system? Perhaps you can see something in my logs. I have only a single seat installation. For example in the evr.log i see the following messages:
    03-03-2013 10:10:33.383 [730]Dropping frame, nextSampleTime -5.20 ms, last sleep 5.00 ms, last pres -11.00 ms, paint 2.49 ms, queue count 4, SOP 175, EOP 315, LFr 3, RawFRRatio 1, dropped 14, drawn 2138
    03-03-2013 10:11:21.729 [730]Dropping frame, nextSampleTime -11.81 ms, last sleep 0.00 ms, last pres -18.00 ms, paint 17.84 ms, queue count 3, SOP 176, EOP 55, LFr 3, RawFRRatio 1, dropped 15, drawn 4554

    Thanks
    Thomas
     

    DragonQ

    Portal Pro
    August 30, 2011
    644
    79
    United Kingdom United Kingdom
    Country flag
    What are your system specs? What codec are you using? What renderer are you using? What's your display's refresh rate? What's the video frame rate? Does it happen with SD and HD? Does it happen with just TV or all content?
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,466
    4,635
    45
    ::1
    Netherlands Netherlands
    Country flag
    @toga67 The dropped frames you're seeing are right after you enabled the Stats window. This seems to happen on many systems, probably has something to do with the info that gets displayed on screen. You shouldn't worry about those. Dropped frames during a longer time of playback are the ones to keep an eye on, but according to your log playback went fine for at least 2 minutes.
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    @toga67 The dropped frames you're seeing are right after you enabled the Stats window. This seems to happen on many systems, probably has something to do with the info that gets displayed on screen.
    There is few DirectX resources being allocated when the ! stats are displayed for the first time - it will block the rendering for a brief moment and it depends on luck + GPU + CPU + video material etc. if there will be dropped frames.

    Those resources aren't allocated in the startup to make it a bit less prone to drop the frames at the start of the playback.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom