[Approved] [French] allocine.fr (2009-01-31) (1 Viewer)

vinch100

MP Donator
  • Premium Supporter
  • August 21, 2006
    107
    8
    Switzerland Switzerland
    @fmarci : Thanks a lot for your great job!

    zamoth : Sorry for not having answered, I had no time at all these last days
    For your information, there is a "Frenchie" plugin called MyVideoGrabber that permits to grab on multiple sites, it could be a good workaround...
     

    fmarcia

    Portal Member
    April 20, 2008
    76
    6
    Boussy Saint Antoine
    France France
    Hi,

    I finally located the missing translation in the code. It's in /trunk/mediaportal/Databases/Video/IMDBFetcher.cs, method "_fetchActorsInMovie".

    A patch is attached.

    You also need to add the string #1059 in /trunk/mediaportal/MediaPortal.Base/language/strings_en.xml:
    Code:
        <String id="1059"> as </String>
    And, as I'm french, here is the string for strings_fr.xml:
    Code:
        <String id="1059"> est </String>
    I'm not sure about the id I chose.

    Please, tell me where to post this if it's not the right place.

    vinch100: thank to you!
     

    Attachments

    fmarcia

    Portal Member
    April 20, 2008
    76
    6
    Boussy Saint Antoine
    France France
    For the record: this patch will not work alone. There are 3 more files to modify:
    /trunk/mediaportal/Configuration/Sections/MovieDatabase.cs
    /trunk/mediaportal/WindowPlugins/GUIVideoFiles/GUIVideoFiles.cs
    /trunk/mediaportal/Databases/Video/SqlLite/VideoDatabaseSqlLite.cs

    I built and tested it. It works fine.
     

    JustOne72

    New Member
    December 12, 2008
    1
    0
    Hi

    Thank you for this script ! Great job !
    However, one question : Is it possible to add the length of the film ?

    PS : Sorry for my english...
     

    chefkoch

    Retired Team Member
  • Premium Supporter
  • October 5, 2004
    3,130
    1,630
    Dresden / Munich / Maastricht
    Germany Germany
    latest file, should be available via update in mpconfig again, sorry for the delay, we had login issues to our servers ;)

    also update version history in first post

    Would be nice, if anyone could verify, that everything is fine using the update.

    regards
    chefkoch
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom