[ATI] HDMI Audio disconnected when MP turn monitor OFF (1 Viewer)

azzuro

Test Group
  • Team MediaPortal
  • May 10, 2007
    9,880
    5,543
    France - IDF
    Home Country
    France France
    Country flag
    • Thread starter
    • Moderator
    • #11
    Ok. Must try. But first cleaning home. Wife instruction . If not. You know the story lol
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,880
    5,543
    France - IDF
    Home Country
    France France
    Country flag
    • Thread starter
    • Moderator
    • #12
    So. Tested this day dyring cleaning lol. I have try to all uncheck. And let windows manage the screen. The screen go off and the audio too.

    Homey you use sound from hdmi on your dev machine ?
    Can you say me driver gpu driver ? And the hdmi audio driver.

    Turn off monitor shutdown screen only if MP Screensaver is activated.
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    46
    ::1
    Home Country
    Netherlands Netherlands
    Country flag
    Homey you use sound from hdmi on your dev machine ?
    Nope, only video (no speakers in my monitors).

    HD4000 driver version is 10.18.10.3958 (30-9-2014), no audio driver (using onboard audio with 2.1 speaker setup).

    Given the fact that i don't experience this problem on my HTPC (which does have both video + audio over HDMI > Receiver > HDMI Splitter >> TV + Projector), it might be a HDMI handshake issue.
    On my HTPC i always turn off the TV myself when listening to radio/music, and never had the audio stop.

    But i was able to reproduce your problem on DEV, and there i don't have audio over HDMI.
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    46
    ::1
    Home Country
    Netherlands Netherlands
    Country flag
    I use audio driver on hdmi connection..
    So your ATI card is also set in Windows as default audio device?
    That might explain it :) MP thinks your audio device is gone, but then again... That checkbox should have fixed that :/
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,880
    5,543
    France - IDF
    Home Country
    France France
    Country flag
    • Thread starter
    • Moderator
    • #16
    Yes. Hdmi is set as defaut card.
    I must try with winamp and look if monitor is shuting down.
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    46
    ::1
    Home Country
    Netherlands Netherlands
    Country flag
    Yes. Hdmi is set as defaut card.
    Then i it's normal. You tell MP to turn of your monitor, which is listed as default audio device. So that means you remove/disable your default audio device and then the sounds stops.
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,567
    10,387
    France
    Home Country
    France France
    Country flag
    Yes. I think. Vut i dont why i think audio & display was not sync.
    What do you mean ? :)

    For sure, if screen goes to blank (screen saver) and we have Audio from HDMI, Windows remove the audio device and then MP stop playback (Radio/Music/Video) but only if the option 'stop playback when device audio is removed'.

    If we uncheck this option, MP can lead to a crash because no more audio device and MP try to play something and in most of case, MP CRASH lol.
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,880
    5,543
    France - IDF
    Home Country
    France France
    Country flag
    • Thread starter
    • Moderator
    • #20
    I dont have crash ! [emoji6]
    But i think its not related to mp.
    Nobody have hdmi audio use ?
    Connected to tv or amp ?
     

    Users who are viewing this thread

    Similar threads

    I have just tested the dll, and it works fine on my thpc too :)(y) Thanks
    I have just tested the dll, and it works fine on my thpc too :)(y) Thanks
    Since the update to MediaPortal 1.27 it takes about three seconds to jump to the next or previous track. Also adding files and...
    Replies
    11
    Views
    2K
    Guys, I have added a bin here: MP hangs after suspend or TV off based on 1.20Final to try to see if it's not related to a wrong GUI SUSPENDING call not resumed by a RUNNING call. So you need to reproduce it with debug level :)
    Guys, I have added a bin here: MP hangs after suspend or TV off based on 1.20Final to try to see if it's not related to a wrong GUI...
    I have been running 1.12 for many years. Thought I would give a newer version a try. Basic functions all work and not issue tuning...
    Replies
    21
    Views
    3K
    this seems to be related to the Ares skin. It can be somewhat fixed by replacing the mytvrecordedtv.xml with the one found in the DefaultWide skin. It really messes up the overlays though.
    this seems to be related to the Ares skin. It can be somewhat fixed by replacing the mytvrecordedtv.xml with the one found in the...
    For the past year or so I have not been able to get into my TV recordings menu. MediaPortal wont crash, but it just hangs and...
    Replies
    1
    Views
    647
    Hello This happens when an audio or video device - which could be the device that is or should be used for playback - is disconnected or connected. Refer to the MediaPortal Configuration -> General -> Startup/Resume Settings -> stop playback on removal of an audio renderer
    Hello This happens when an audio or video device - which could be the device that is or should be used for playback - is...
    Got a problem with mediaportal. Tv and videos turns themselves off. this is what happens: [2017-09-29 20:18:15,360] [Log ]...
    Replies
    1
    Views
    793
    Would it be possible to automate the process of updating MP Extension Manager with the latest versions of important components?
    Would it be possible to automate the process of updating MP Extension Manager with the latest versions of important components?
    Hi there, i've got a problem with the playback of some movies. The sound format is listed as DTS HD 7.1 but the receiver detects it...
    Replies
    6
    Views
    1K
    Top Bottom