How do I get the mouse to work. (1 Viewer)

GeeZer

New Member
August 18, 2021
4
0
Home Country
United States of America United States of America
I am using Windows 7, Media Portal 2.32, WMC skin and have 5 satellite TV cards installed. The only error I get when I start Media portal is that the FROG.dll is not installed. Doesn't seem like it hurts anything and is just a "nag". Anyway I can start the server and it scans in satellite Cband and ATSC channels fine. However accessing them is another story. I have to use a keyboard for just about everything so far is scrolling and the skin data is sometimes superimposed on the video and I have no idea how to get it to go away out side of killing the program and starting over. The escape key, arrows and enter key are about all that works. This seems real primitive from DVBViewer and PotPlayer which I also have. Is there a skin that is less like Kodi and more like DVBViewer which has pull down menus and easily accessible commands..

Thanks!
 

ge2301

Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    8,188
    3,242
    Stuttgart
    Home Country
    Germany Germany
    I have to use a keyboard for just about everything
    Full mouse support exists in WMC skin, compared to other skins it’s even optimized for it. When moving the mouse, overlayed controls appear and you can also close MP2 from top right as every Windows dialog, I see the controls also from your screenshot in another thread. From your explanation I can unfortunately not follow what you are trying to do. Could you please describe it more precise with e.g. a screenshot, so I can tell you what the problem might be.
     

    GeeZer

    New Member
    August 18, 2021
    4
    0
    Home Country
    United States of America United States of America
    I'm just going to focus in on a couple things so as not to inundate you with questions. First the optimFrog.dll. Again I can just click on past the "nag" if it's not hurting anything. Doesn't appear in any other programs and have seen other people mention it. First image.

    Next is when I get to the main menu screen. I'm using a combo keyboard with touch pad that has two buttons for mouse effect. I get the main menu with Image, Settings..etc. I have a mouse pointer so I would think you could just click on say "TV" and it would open. But I guess you just use the little arrows at the top and bottom of the screen. Image 2

    However if you use the arrows, the menu will highlight the next menu entry on the first click, but then on the next click it goes into that category instead of just moving up the "ladder" of menu items. Image 3. I was actually on "NEWS" before taking the third image instead of "Settings" as shown in the second image, but I also can't figure out how to delete an image in this thread, so I can't correct that.


    I have some more but help with these would be great. Note: If I use the keyboard arrows the the program moves "up the ladder" correctly.

    Thanks again
    Spencer.. In USA, Charlotte North Carolina
     

    Attachments

    • Frog.png
      Frog.png
      281.5 KB
    • image2.png
      image2.png
      233.7 KB
    • image3.png
      image3.png
      291.9 KB

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    8,188
    3,242
    Stuttgart
    Home Country
    Germany Germany
    I'm just going to focus in on a couple things so as not to inundate you with questions. First the optimFrog.dll. Again I can just click on past the "nag" if it's not hurting anything. Doesn't appear in any other programs and have seen other people mention it. First image.
    This seem to happen only occasingly for some users. I never saw it for example with my windows 10 system. As you said it doesn't cause any mis-functionality, it is just annoying. It's on the bugfix agenda for next MP2.4 release.

    Next is when I get to the main menu screen. I'm using a combo keyboard with touch pad that has two buttons for mouse effect. I get the main menu with Image, Settings..etc. I have a mouse pointer so I would think you could just click on say "TV" and it would open. But I guess you just use the little arrows at the top and bottom of the screen. Image 2
    That's correct, there are two options: Using the navigation buttons or the mouse wheel. It's also described in the WIKI for WMC skin here.
    Generally it could be helpful to take a quick look into this document to understand the structure incl. navigation.

    However if you use the arrows, the menu will highlight the next menu entry on the first click, but then on the next click it goes into that category instead of just moving up the "ladder" of menu items. Image 3. I was actually on "NEWS" before taking the third image instead of "Settings" as shown in the second image, but I also can't figure out how to delete an image in this thread, so I can't correct that.
    I tried to reproduce the steps exactly as you described and I think I found the potential issue. I never realized, because I use my mouse wheel and never clicked more than once on the arrows.
    Once the navigation arrow is clicked, the vertical main menu scrolls, but the locus is lost from that navigation arrow (you see that from the brightness). So clicking a second time without slightly mousing the mouse to get the focus on the arrow again results into the result you described.

    This is definitely not intended behaviour, so I'll take a look to see how this can be improved. Of course the focus should remain on the element.
    Meanwhile you need just the slightly move the mouse until the highlight on the arrow is back.

    Edit: I checked the code behind and see the difficulty. When the arrow is selected Command="{Command Source={StaticResource HomeMenuModel},Path=MovePrevious}" is executed and sets the focus on the next menu item (in the rectangle focus frame). In that moment the mouse position is ignored. To get the focus back on the arrow, the mouse needs to be moved at least for a few pixel.
    Maybe @Brownard has an idea. I could only imagine one solution, that "MovePrevious" sets the focus back on the upper arrow button and "MoveNext" on the lower arrow button by code (is MouseIsUsed = True).
     
    Last edited:

    Users who are viewing this thread

    Top Bottom