[confirm] ISO image not unmounted, when movie playing has finished (1 Viewer)

alexirion

MP Donator
  • Premium Supporter
  • February 8, 2010
    170
    12
    46
    St. Georgen im Schwarzwald
    Home Country
    Germany Germany
    Hello,
    I have the reproducible issue, that an ISO of a BD is not unmounted, when playing has finished, thus the movie can not be deleted. However, if I stop the movie playback with the STOP button, the ISO is unmounted and deletion works. I'm using Virtual Clone Drive.
    Regards,
    --Alex
     

    alexirion

    MP Donator
  • Premium Supporter
  • February 8, 2010
    170
    12
    46
    St. Georgen im Schwarzwald
    Home Country
    Germany Germany
    Attached missing logs and reproduced error:

    movie mounted and start playing:

    [2014-02-25 21:51:15,755] [Log ] [MPMain ] [INFO ] - Start process C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\daemon.exe -mount 0,"D:\movies\SHOOTOUT.ISO"
    ....
    movie finished:
    [2014-02-25 21:52:09,919] [Log ] [MPMain ] [INFO ] - g_Player.Process() player stopped...
    ...
    [2014-02-25 21:52:31,307] [Error ] [MPMain ] [ERROR] - Util: FileDelete D:\movies\SHOOTOUT.ISO error: The process cannot access the file 'D:\movies\SHOOTOUT.ISO' because it is being used by another process.

    In the Windows explorer it can be seen that the ISO is not unmounted, when the movie has finished.
     

    Sebastiii
    Country flag

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,370
    10,164
    France
    Home Country
    France France
    Hi,
    I didn't look yet your issue so i can't confirm and for now i'm not sure someone else look too. But we will :)
     

    Sebastiii
    Country flag

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,370
    10,164
    France
    Home Country
    France France
    So you watch an BD .iso and delete right after finish to viewing it ?
    The unmount call is send on stop (manual one) will try to look if it can be done on finish :)
     

    Sebastiii
    Country flag

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,370
    10,164
    France
    Home Country
    France France
    In your log : you have a lot of error about : MediaSlayer
    Can you disable it or uninstall it (it will surely not fix the issue but have more cleaner log and maybe solve other issue lol) ?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Thread starter Similar threads Forum Replies Date
    U 1.7.0 Pre Release 4
    Top Bottom