ist es möglich die IP Adresse nicht in Namen aufzulösen? (1 Viewer)

Holger Hessling

Portal Member
January 12, 2013
15
0
51
Germany Germany
Hallo NG,

ich habe festgestellt, daß die IP-Adresse des Servers, die ich in die Konfiguration des Clients eintrage, in einen Namen umgewandelt/aufgelöst wird. Soll heißen, nach einem Start von MP und nachfolgendem Aufrufen der Konfiguration von MP, steht als TV-Server nicht mehr die IP-Adresse drin, sondern der Windows Name des Servers. Kann man das auch unterbinden? Ich würde gerne ausschließlich mit IP-Adressen arbeiten.

Danke für Eure Hinweise

Holger
 
Last edited:

Scythe42

Retired Team Member
  • Premium Supporter
  • June 20, 2009
    2,065
    2,703
    47
    Berlin
    Germany Germany
    Warum? Finde ich recht seltsam es sich umständlich zu machen. Die IPs in meinem Netzwerk interessieren mich seit Anfang dieses Jahrtausends nicht mehr (seit jeder billig Router DHCP und NAT kann). Eimal DHCP im Router konfiguriert und gut ist's.

    Warum willst du die Uhr 20 Jahre zurückdrehen? Macht doch nur mehr Arbeit und bringt keinerlei Vorteile.

    PS: Und wenn du willst kannst du DHCP auch statisch adressen zuweisen lassen.
     
    Last edited:

    Holger Hessling

    Portal Member
    January 12, 2013
    15
    0
    51
    Germany Germany
    Nun, die Namensauflösung funktioniert bei mir leider nicht über einen Router hinweg. Daher das Anliegen. Ich machs aber jetzt so, daß ich dem TV-Server aus dem anderen Netz einen fiktiven Namen in der hosts-Datei zuweise. Dann geht's ja auch. Das muß ich halt dann an jedem client so machen... Paßt schon, danke für Deine Antwort :)
     

    Holger Hessling

    Portal Member
    January 12, 2013
    15
    0
    51
    Germany Germany
    Ich korrigiere mich. Ich schreibe keinen fiktiven Namen in die hosts-Datei, sondern den Windows Namen des TV-Servers. ABER: So wie ich das verstehe, bekommt der Client vom Server die Datei oder Inhalt von Gentle.config zugewiesen. Und darin steht nur der einfache WIndows Name vom Server drin. Leider nicht voll qualifiziert. In meinem Fall bekomme ich "SERVER" vom TV-Server. Vollständig heißt er aber server.lutz.net

    Ist es möglich, daß in der Gentle.config der FQDN steht, in meinem Fall also server.lutz.net?
     
    Last edited:

    Scythe42

    Retired Team Member
  • Premium Supporter
  • June 20, 2009
    2,065
    2,703
    47
    Berlin
    Germany Germany
    Ah, ein allgemeines DNS Problem. Müsste jetzt dein Setup genauer kennen. Im Moment sieht es aus als ob Netz A absolut nichts von Netz B weiss.

    Einfachste Lösung: nur einer Router spielt DHCP und DNS Forwdarder ins Inernet (die DHCP Einträge hat er im DNS cache, deswegen kann er sie auflösen). Alle andere Router forwarden DHCP Broadcasts und DNS anfragen zu diesem. Und schon ist's Problem gelöst.

    Kannst du mit einem Router kein DHCP Relay spielen, gibt's auch andere Möglichkeiten das gleiche zu erreichen. Müsste ich aber dein Setup genauer für kennen. Ggf. einfach eine anständige Firmware auf die fraglichen Router packen.
     

    Scythe42

    Retired Team Member
  • Premium Supporter
  • June 20, 2009
    2,065
    2,703
    47
    Berlin
    Germany Germany
    Ist es möglich, daß in der Gentle.config der FQDN steht, in meinem Fall also server.lutz.net?
    Das jetzt kein FQDN in der Config steht würde ich mal als Bug bezeichnen. Mach einen Bug Report mit verweis auf diesen Post auf, dann generiere ich oder ein andere Dev ein passendes Ticket, damit das im Laufe der Zeit behoben wird. Der "shortname", also nur der hostname, sollte nur dann in der config stehen, wenn keine FQDN verfügbar ist.

    Ich gehe von aus, in deinem Setup ist er, sprich DNS Auflösung von server.lutz.net funktioniert...

    Ansonsten: Konfiguriere deine DNS Einstellungen in den TCP/IP settings deiner Netzwerkkarte so, dass diverse Endungen an reine Hostnamen rangehangen werden. Dann probiert Windows das in der Reihenfolge aus bis es eine Antwort bekommt. Damit kann man solche Issues immer umgehen. Das Problem ist ein absoluter Klassiker in Heimnetzwerken.
     
    Last edited:

    Holger Hessling

    Portal Member
    January 12, 2013
    15
    0
    51
    Germany Germany
    Hehe, ja ich hol mal weiter aus :) Kann man hier Bilder anhängen? Ich versuchs mal...




    Okay, das hat schon mal geklappt. Weiter geht's...

    Auf der linken Seite siehst Du mein Netzwerk zuhause mit dem IP-Bereich 192.168.16.0/24. Die Rechner hängen alle über einen Switch zusammen. Alle diese Rechner beziehen ihre IPs über den .16.1, meinem Windows Home Server. Dieser ist auch der DNS Server im Netz.
    Ins Internet gehe ich über einen Dual WAN Router, hier im LAN die .16.253. Er entscheidet, ob der Verkehr über die T-DSL Leitung läuft, oder über meinen Nachbarn, er hat die schnellere DSL Anbindung ;-) Somit ist im Normalfall mein Nachbar mein I-Net...
    Zusätzlich habe ich mein Netz mit dem meines Nachbarn über einen weiteren Router miteinander verbunden. Dieser Weg ist eine Gigabit Verbindung. Der Router ist ein mit dem Projekt FLI4L erstellter Ethernet-Router. Er hat die IP .16.254. Alle meine Rechner bekommen via DHCP eine statische Route mitgeteilt, daß Verkehr zum Nachbarn eben über diesen Router .16.254 zu laufen hat. Die Standardroute ist der Dual WAN Router.
    Wenn mein DNS Server einen Namen nicht auflösen kann, fragt er den DNS meines Nachbarn. Das läuft dann eben über den fli4l-Router (sollte der Weg zum Nachbarn mal blockiert sein, läuft bei mir erstmal gar nichts mehr, dann muß ich meinem DNS Server sagen, er soll bei .10.253 nachfragen, meinem Internet Gateway. Dieser nimmt dann die T-DSL Verbindung im Fall einer Blockade).

    Das sau dumme ist nun aber, daß mein Windows Home Server auch "SERVER" heißt. Somit habe ich einen "Server" und mein Nachbar auch. Und deshalb ist es schade, daß in der Gentle.config nur SERVER drin steht und nicht server.lutz.net[DOUBLEPOST=1358515571][/DOUBLEPOST]
    Mach einen Bug Report mit verweis auf diesen Post auf, dann generiere ich oder ein andere Dev ein passendes Ticket, damit das im Laufe der Zeit behoben wird. Der "shortname", also nur der hostname, sollte nur dann in der config stehen, wenn keine FQDN verfügbar ist.
    Ja, das werde ich tun, danke! Aber das Problem wird sein, daß es auch einen "SERVER" in meinem Netz gibt ;-)
     

    Holger Hessling

    Portal Member
    January 12, 2013
    15
    0
    51
    Germany Germany
    Ich gehe von aus, in deinem Setup ist er, sprich DNS Auflösung von server.lutz.net funktioniert...
    Also wenn ein ping auf den Server mit seinem Namen geht, dann sollte die FQDN verfügbar sein, oder? Hier mal ein ping an server.lutz.net:

    C:\Users\holger>ping server.lutz.net

    Ping wird ausgeführt für server.lutz.net [192.168.10.151] mit 32 Bytes
    Daten:
    Antwort von 192.168.10.151: Bytes=32 Zeit=3ms TTL=126
    Antwort von 192.168.10.151: Bytes=32 Zeit=1ms TTL=126
    Antwort von 192.168.10.151: Bytes=32 Zeit=1ms TTL=126
    Antwort von 192.168.10.151: Bytes=32 Zeit=1ms TTL=126

    Ping-Statistik für 192.168.10.151:
    Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
    (0% Verlust),
    Ca. Zeitangaben in Millisek.:
    Minimum = 1ms, Maximum = 3ms, Mittelwert = 1ms


    Ein nslookup sieht so aus:

    C:\Users\holger>nslookup server.lutz.net
    Server: server
    Address: 192.168.16.1

    Nicht autorisierende Antwort:
    Name: server.lutz.net
    Address: 192.168.10.151

    Gruß
    Holger[DOUBLEPOST=1358525030][/DOUBLEPOST]Darf ich den 'bug report' auch in Deutsch verfassen?
     

    Holger Hessling

    Portal Member
    January 12, 2013
    15
    0
    51
    Germany Germany
    Aber ist es nicht so, daß der TV-Server dem MP-Client über die Gentle.config seinen Namen für die SQL Verbindung mitteilt? Dann müßte ja der Server seine eigene FQDN ermitteln können, oder? Hm, und das geht momentan auf dem betreffenden Server nicht. Sieh mal:

    Ein ping vom TV-Server aus auf sich selbst:

    C:\Users\tom>ping -4 server

    Ping wird ausgeführt für SERVER [192.168.10.151] mit 32 Bytes Daten:
    Antwort von 192.168.10.151: Bytes=32 Zeit<1ms TTL=128
    Antwort von 192.168.10.151: Bytes=32 Zeit<1ms TTL=128
    Antwort von 192.168.10.151: Bytes=32 Zeit<1ms TTL=128
    Antwort von 192.168.10.151: Bytes=32 Zeit<1ms TTL=128

    Ping-Statistik für 192.168.10.151:
    Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
    (0% Verlust),
    Ca. Zeitangaben in Millisek.:
    Minimum = 0ms, Maximum = 0ms, Mittelwert = 0ms

    oder mit seinem FQDN:

    C:\Users\tom>ping -4 server.lutz.net
    Ping wird ausgeführt für SERVER.lutz.net [192.168.10.151] mit 32 Bytes Daten:
    Antwort von 192.168.10.151: Bytes=32 Zeit<1ms TTL=128
    Antwort von 192.168.10.151: Bytes=32 Zeit<1ms TTL=128
    Antwort von 192.168.10.151: Bytes=32 Zeit<1ms TTL=128
    Antwort von 192.168.10.151: Bytes=32 Zeit<1ms TTL=128
    Ping-Statistik für 192.168.10.151:
    Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
    (0% Verlust),
    Ca. Zeitangaben in Millisek.:
    Minimum = 0ms, Maximum = 0ms, Mittelwert = 0ms

    Und jetzt ein nslookup auf seine eigene IP:

    C:\Users\tom>nslookup 192.168.10.151
    Server: localhost
    Address: 192.168.10.155
    Name: localhost

    Und genau hier ist doch ein Fehler in der Konfiguration des PCs, auf dem der TV-Server läuft, oder? Der bekommt nur als Namen 'localhost' mitgeteilt. Siehst Du das auch so?

    Also vielleicht doch kein Bug in MP ;-)

    Danke für Deine Mühe :-D

    Gruß
    Holger
     
    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    R [solved] MP2 Client ist extrem langsam Allgemeines Support- und Diskussionsforum 5
    M VPN: Mediaportal TV-Server ist not using all available bandwidth which results in TV stuttering Newcomers Forum 0
    II-IRON [solved] MP2 - 2.2 - Es ist kein Player für die Wiedergabe des Medien-Object 'stream 3.0' registriert Allgemeines Support- und Diskussionsforum 16
    S Ab MP 1.22 Fehlermeldung "abspielen nicht möglich" bei mp4 dateien Video & DVD 0
    muellinger Disney+ Integration möglich? TV / Streaming 2
    M.Hulot [solved] Netflix und amazon Prime in MP1 möglich? TV / Streaming 6
    Patrik-See Unitymedia HD+ Fernsehen mit Media Portal legal möglich? TV / Streaming 0
    D Keine Client-Ansteuerung mehr möglich nach Windows10-Updated Allgemeines Support- und Diskussionsforum 7
    T Abspielen nicht möglich Musik - CD / MP3 6
    S Abspielen von Aufnahemen nicht möglich: MPEG Video Version 2 Elektronischer Programmführer (EPG) 1
    Golf4 Client verliert immer wieder die Verbindung Allgemeines Support- und Diskussionsforum 4
    Mainhattan Olli [solved] MediaPortal 2.2.1 und die aufzunehmenden Sendungen Allgemeines Support- und Diskussionsforum 6
    Kolbenschieber Wenn die HTPC-Uhr rückwärts läuft... Tipps, Tricks & Tutorials 0
    Lehmden Media-Buddy, die "eierlegende Wollmilchsau" unter den Medien-Tools. 3rd Party Software 83
    muellinger MePo 1.19 und PowerDVD 12 für Blu-Ray. Tips für die Konfiguration benötigt Video & DVD 5
    olli14 Inhalt der Moving Pictures Datenbank in die Plex Datenbank kopieren MediaPortal Café 69
    Top Bottom