Live TV streaming/recording issues (1 Viewer)

jockefc23

Portal Member
January 10, 2015
6
0
40
Great Britain (UK) Great Britain (UK)
Hello,

I have Mediaportal TV Server running on my HP Microliant Server using WHS2011. Playback is done through both a Linux HTPC and Windows 7 Laptop both using KODI

I can start Live TV in Kodi fine and the majority of the time it will run normally, but about 25% of the time during the playback the sound and video will become glitchy and then after a little bit of this the feed will cut out and I will be back to the channel select/epg screen without an error message.

I thought at first this may be a buffering issue but then I noticed that sometimes my recordings (stored on the server side) were being cut short. I checked this and the same thing is happening to these as well.

Does anyone have an idea what could be causing this? I thought it may be a problem with a dodgy hdd but I have since changed the hdd being used and the issue is still occuring.

If there are any log files I can get to help then just let me know, I only currently know how to get the kodi.log file up, not any mediaportal ones.

Thanks
 

HomeY

Test Group
  • Team MediaPortal
  • February 23, 2008
    6,465
    4,631
    45
    ::1
    Netherlands Netherlands
    Country flag
    Hi and welcome jockefc23, ;)

    We definitely need your TV Server logfiles.
    You can find those on your server in the following directory:
    C:\ProgramData\Team MediaPortal\MediaPortal TV Server\log

    Please zip them ALL up and attach them here.
    Also please fill in your system specs.
     

    jockefc23

    Portal Member
    January 10, 2015
    6
    0
    40
    Great Britain (UK) Great Britain (UK)
    Thanks for the reply, attached all the log files in the folder.

    The server running the TV Server is a HP Microliant running WHS 2011 and with a 2tb WD Green hdd.
    2gb RAM
    AMD Turion II Neo N40L (1.5 Ghz)

    streaming to a HTPC Linux via Ethernet cable and a windows 7 laptop via wireless, both with the same problem
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello

    Some specific dates and times where you've had problems would help.

    In the meantime I can see that there are sometimes continuity errors in the TsWriter log. Those errors are usually caused by signal strength/quality issues or high HDD load.
    Do you have any security software installed?
    If so, please be aware that security software scanning has been known to cause problems like this when it scans the TV Server program, timeshift and/or record directories. Solution is usually to exclude at least the timeshift and record directories from scanning.

    Regards,
    mm
     

    jockefc23

    Portal Member
    January 10, 2015
    6
    0
    40
    Great Britain (UK) Great Britain (UK)
    Last night (9th) at around 21:06 but I will try and replicate and get a proper time.

    In terms of the security software I don't have any. All the server does is run my video files and download my torrents. Could it be the low ram and constant use for torrents downloading? Would it help to be on a separate hdd?
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Last night (9th) at around 21:06 but I will try and replicate and get a proper time.
    Hmmm, okay. There are continuity errors at around 22:15, but none at 21:06.

    In terms of the security software I don't have any. All the server does is run my video files and download my torrents. Could it be the low ram and constant use for torrents downloading? Would it help to be on a separate hdd?
    I think it is unlikely to be a RAM issue (timeshifting and recording doesn't require much RAM).
    I don't know whether the torrenting could affect it. Theoretically anything that hammers the HDD could cause TsWriter continuity errors... but then, I'm not sure that the glitchiness you're seeing is actually caused by that. It could be something completely different. For example, XBMC/KODI could be having playback problems (and I wouldn't be able to identify or assist you with that).
     

    jockefc23

    Portal Member
    January 10, 2015
    6
    0
    40
    Great Britain (UK) Great Britain (UK)
    I will run it and let you have a proper time in the next 24 hours.

    I thought it was maybe something to do the playback on KODI, however it happens when I record as well. I don't notice this until I go to play the recording and I find that it has cut out during it.
     

    jockefc23

    Portal Member
    January 10, 2015
    6
    0
    40
    Great Britain (UK) Great Britain (UK)
    Right, its taken me a while but I was just watching TV and it happened again. Starts getting glitchy then gets worse and worse until it cuts out completely.

    logs attached should hopefully show this, time was around 20:22pm GMT.
     

    jockefc23

    Portal Member
    January 10, 2015
    6
    0
    40
    Great Britain (UK) Great Britain (UK)
    Hello, has anyone been able to look at the above for me?

    It seems to occur around the same point each Sunday evening, which leads me to think it is something overloading my server. It also happens at other times but not so regularly.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello, has anyone been able to look at the above for me?
    Yes, I've looked... but there's nothing that I (or probably anybody else) can say that I didn't say in my previous posts.

    Again, there are continuity errors in the TsWriter log. Inadequate signal strength/quality and HDD overload are the most common causes of these.

    With the information you've provided and without access to the system I cannot be more helpful. It is really up to you to investigate further. For example, when the problems occur you can open task manager -> performance tab -> resource monitor and check the HDD load and programs that are hitting it. You can also use the manual control section of TV Server configuration to check signal levels.

    P.S. Of course there are other less-common-but-still-possible causes of such problems. In my opinion it makes sense to start from the most common causes and only move on to the less common if/when the common causes are ruled out.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    amatesi MP2.2pre Client crash while streaming Live TV from remote MP2.2pre Server (both offline) 2.2 Archive 8
    K Flickering live TV playback Newcomers Forum 3
    H [solved] MP2 Wiedergabe von Aufnahmen und Live TV geht nicht Allgemeines Support- und Diskussionsforum 6
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    vvulture UNKNOWN ERROR when starting live TV General Support 6
    H random black screen live tv and videos (amended) General Support 0
    404 [solved] Live TV...video and audio freeze General Support 20
    404 How to turn off narration on live tv General 2
    Volker MP2 Rewind / zurückspulen bei Live TV funktioniert nicht Allgemeines Support- und Diskussionsforum 3
    G Occasional Black screen on Live TV and Recorded TV Watch / Listen Media 5
    G Live Tv friert ein Allgemeines Support- und Diskussionsforum 47
    U [solved] Beginner needs help recording live TV General 19
    limpwhizkid 1.22.0 Stutter and or artifact problem when recording and watching the same live tv channel 1.22 2
    rbo Fehlermeldung im Live-TV TV / Streaming 6
    R Pixellation on live TV every few seconds General Support 11
    M After a while Live TV or Recorded TV doesn't play first time General Support 9
    S [solved] Live TV subtitle issue if not using 100% font General 31
    S [solved] Live TV playing stopped General 13
    S Mediaportal 1.22 Pre-Release remote live-tv freezes MediaPortal 1.22 Pre Release 0
    H Live TV info OSD not displaying number of audio channels General Support 3
    E [solved] No Live TV in MP2.2 Client - Can TEST Successfully in "MediaPortal 2 TV Configuration" utility General 8
    D Skip to end/live during dvbip recording causes it to stop playing instead. General Support 15
    porky996t Still Unable to play Live or Recorded TV General Support 4
    Similar threads

























    Top Bottom