Meine erste Harmony (1 Viewer)

jesseblue

Portal Pro
June 8, 2007
77
3
42
Hallo,

ich habe mir vor kurzem eine Harmony One+ zugelegt und betreibe diese zusammen mit einem RC6 IR-Empfänger den ich von AEOne hier aus dem Forum erhalten habe. Die Grundeinrichtung der Harmony für bspw. Fernseher oder Stereoanlage ging recht flott, was mir allerdings große Probleme bereitet, ist die Steuerung des PC.

Als Geräte zur Steuerung des PC habe ich sowohl "Microsoft Windows Media Center SE" als auch "Microsoft MCE Keyboard" ausprobiert. Wenn Mediaportal einmal läuft, lässt es sich bei beiden Varianten mit der Harmony steuern, wobei ich mit dem MCE Keyboard die Tasten zur Bedienung von MP um einiges besser konfigurieren kann. Was bis jetzt leider noch nicht geschafft habe, ist es Mediaportal vernünftig zu starten bzw. zu beenden.

Am liebsten hätte ich es eigentlich, dass mit einem Tastendruck auf der Harmony (z.B. Aktion "Mediportal starten") der Fernseher eingeschaltet wird, der Rechner aus dem Standby aufgeweckt und Mediaportal gestartet wird (falls Mediaportal noch nicht läuft). Und wenn ich auf den Standby-Knopf drücke sollte dann der Fernseher ausgeschaltet und der PC in den Standby-Modus gefahren werden. Sollte doch eigentlich machbar sein, oder? Aber wenn ich als Eingang für das Microsoft Windows Media Center SE bspw. "MCE Startpage" auswähle, wird Mediaportal zwar gestartet, es ist aber nicht das aktive Fenster, d.h. ich muss erst mit der Maus irgendwo in Mediaportal reinklicken, damit ich es weiter bedienen kann. Wenn ich das MCE Keyboard als Gerät auswähle, kann ich Mediaportal nicht einmal starten. Außerdem tut sich beim Drücken der Standby-Taste (oben links über dem Display) nicht das geringste am PC. Lediglich die Taste Toggle Power auf dem Display funktioniert.

Normalerweise stelle ich mich bei sowas nicht so dämlich an, aber trotz laaaangem Suchen in diversen Foren komme ich irgendwie auf keinen grünen Zweig. Wäre deshalb sehr dankbar, wenn ein erfahrener Harmony-Besitzer sich meiner erbarmt und mir erklärt wie er das bei sich gelöst hat.

p.s. Die Einrichtung habe ich sowohl über Myharmony.com als auch über die Software Logitech Harmony Remot 7.7.0 probiert. Konnte keine großen Unterschiede feststellen, außer dass ich die vor allem fürs Tasten-Mapping die Online-Variante etwas übersichtlicher finde.
 

jesseblue

Portal Pro
June 8, 2007
77
3
42
Wenn ich Mediaportal normal starte (Maus oder Tastenkombination), hat es nen Autofokus, nur nicht beim Start über die Harmony. Dann ist nämlich die Taskleiste sichtbar und angewählt. Oder meinst du eine Einstellung in Mediaportal speziell für die MCE Remote?
 

jesseblue

Portal Pro
June 8, 2007
77
3
42
Okay, bin jetzt schon ein bisschen weitergekommen. Kann Mediaportal jetzt per Tastendruck auf der Harmony starten und dann bedienen. Habe dazu die Aktion "Mediaportal starten" definiert, die den Fernseher startet (HDMI1), Media Center SE startet (MCE Startpage) und MCE Keyboard startet (kein Eingang). Habe das MCE Keyboard zusätzlich in die Aktion mit reingenommen, damit ich das Tastenmapping einfacher durchführen kann, z.B. L für Subtitles. Mit den Fernbedienungstasten finde ich das irgendwie kompliziert.

So, was jetzt noch nicht klappt:
1. Beim Drücken der Standby-Taste passiert nichts am PC. Hätte eigentlich gerne, dass der PC in den Energiespar-Modus fährt. Eigentlich sollten mit Beenden der Aktion doch die entsprechenden Geräte (also auch der PC) beendet werden.
2. Aufwecken auf dem Energiesparmodus funktioniert nicht richtig. Hätte es eigentlich gerne, dass der Rechner mit der Aktionstaste "Mediaportal starten" geweckt wird, aber das hat bis jetzt noch nicht geklappt. Habe dann probiert sowohl auf dem Display als auch auf den Tasten der Harmony die Befehle "Power Toggle", "Power On" und "Power Off" zu verwenden. Konsequenz: In den Energiesparmodus fahren klappt gut. Aber aus dem Energiesparmodus aufwecken klappt aber erst nach mehrmaligem Drücken von "Power Toggle" bzw. "Power On". Bekommt der IR-Empfänger nicht genügend Strom? Habe ein Testsystem aufgebaut (Laptop mit eingebautem IR-Empfänger) und da klappt das An- und Ausschalten des Energiesparmodus problemfrei.
3. Mediaportal wird mit der Aktion "Mediaportal starten" nur dann gestartet, wenn ich als Administrator angemeldet. Andernfalls passiert nichts.

Sehr verwirrend alles. Habe jetzt schon etliche Stunden hier hereinversenkt. Wäre über Hilfe deshalb sehr dankbar...
 

jesseblue

Portal Pro
June 8, 2007
77
3
42
Habe eben versucht den IR-Empfänger im Geräte-Manager zu finden. Wenn ich ihn anschließe wird mir eine zusätzliche HID-konforme Maus sowie drei Microsoft eHome devices angezeigt. Kommt mir irgendwie komisch vor. Leider hat aber keines dieser Geräte unter Eigenschaften den Reiter Energieeinstellungen, wo man das aktivieren aus dem Ruhezustand aktivieren könnte.

Problem bleibt bestehen: Wecken aus Standby mit Tastatur/Maus funktioniert. Wecken mit Harmony erst nach mehrmaligem Drücken der Power-Toggle Taste.
 

Attachments

  • Geräte-Manager.jpg
    Geräte-Manager.jpg
    31.7 KB
Last edited:

jesseblue

Portal Pro
June 8, 2007
77
3
42
Neues Update: Habe in den Betriebseinstellungen (Definition von Ein- und Ausschaltebefehlen) der jeweiligen Geräte im Harmony-Menu rumgespielt und jetzt mittlerweile fast alles im Griff. Nur noch 2 kleine Probleme:

1. Mediaportal startet nur wenn ich als Admini angemeldet bin fokussiert. Als Nicht-Admin bleiben Fenster die auf meinem Desktop eventuell geöffnet waren im Vordergrund. Jemand eine Idee, wie das mit den Zugriffsrechten zusammenhängt bzw. eine Lösung wie man auch als Nicht-Admin richtig starten kann.
2. Wecken aus dem Standby klappt nur ab und zu. Manchmal reicht einfaches Betätigen der Power-Taste, aber meistens muss man mehrmals drücken. Die Taste lange zu drücken bewirkt leider nichts, das könnte man ja sogar der Harmony beibringen. Hab den USB-Port im Energiesparmodus mit einem Multimeter vermessen: Es liegt eine Spannung von 5.02V an. Strom ist also da. Bei meinem Laptop stellt sich übrigens das gleiche Problem ein, wenn ich den USB IR-Receiver verwende. Mit dem integrierten IR-Receiver funkioniert alles tadellos. Gehe mittlerweile deshalb davon aus, dass es am USB-Receiver liegt. Werde demnächst mal AEOne hierzu konsultieren.
 

Users who are viewing this thread

Top Bottom