Missed Recordings (1 Viewer)

gonzo90017

Portal Pro
September 3, 2012
238
26
22
Home Country
United States of America United States of America
Woke up this morning and turned on one of the clients. I kept getting can't connect to TV Server error. I thought I was having Networking issues again (damn you windows 7). After 30 minutes of trouble shooting it turns out the problem was that the TV Service on the server was not running. Hope someone can tell me why it wasn't running?
 

RonD

Test Group
  • Team MediaPortal
  • December 20, 2011
    910
    278
    SillyValley CA
    Home Country
    United States of America United States of America
    Country flag
    gonzo,

    Both windows zip-extract and 7-zip report a problem (CRC error with 7-zip) on your tv.log file. did you run out of space when you made the zip file?

    Looks like you ran out of space on your recording drive. The tv.BAK file has the following error message.

    Code:
    2012-11-15 00:29:15.991631 [(2)]: Tvservice stopped due to an unhandled app domain exception System.IO.IOException: There is not enough space on the disk.
     
      at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
      at System.IO.FileStream.WriteCore(Byte[] buffer, Int32 offset, Int32 count)
      at System.IO.FileStream.FlushWrite(Boolean calledFromFinalizer)
      at System.IO.FileStream.Dispose(Boolean disposing)
      at System.IO.FileStream.Finalize()
     
    ##### a little before the error, the TV Server started a new recording ######
     
    2012-11-15 00:29:14.685556 [scheduler thread(10)]: StartRecording to D:\TV Recordings MP\5 CW\Friends\Friends - 2012-11-15 - E88_466617 - The One With All the Rugby.ts
    2012-11-15 00:29:14.685556 [scheduler thread(10)]: subch:0 StartRecord(D:\TV Recordings MP\5 CW\Friends\Friends - 2012-11-15 - E88_466617 - The One With All the Rugby.ts)
     
    ##### the error.BAK file also has the following error  at the same time #######
     
    2012-11-15 00:29:16.422656 [scheduler thread(10)]: Exception  :System.IO.IOException: There is not enough space on the disk.

    I'm not a programmer, so I don't know if the TV Server should have detected and recovered from the disk space problem. But you should probably look at how much disk space you have for recordings. Maybe enable TV Server quotas for your recording drive. I always use a quota of 25 GB for my recording drive/folder. If I run out of disk space I need to delete either an old recording or a new recording. I use quotas so I get rid of the old recordings to get space for new.

    see wiki for quota info
    http://wiki.team-mediaportal.com/1_...guration/TV-Server_Configuration/07_Recording
     
    Last edited:

    gonzo90017

    Portal Pro
    September 3, 2012
    238
    26
    22
    Home Country
    United States of America United States of America
    Thank you. There was no space left in my recording drive. Just wish MediaPortal would pop up some kind of message when this sort of thing happens. It would really save time when troubleshooting.
     

    Users who are viewing this thread

    Similar threads

    MP1 MP2 Import stuck DE
    Full permission is necessary. For me I set no protection on my NAS and activated cretidentials anyway, just left username and password empty.
    Full permission is necessary. For me I set no protection on my NAS and activated cretidentials anyway, just left username and...
    I am kind of at my wits end, I have been working on this since Friday using TMM to manage the data files and then trying to import...
    Replies
    15
    Views
    619
    So after a long search and a lot of experiments I did find out the culprit: I did disable events of the Common Information Model Object Manager. As soon as they are disabled TV server will always show "port 554 is already bound". Enabling/disabling events is done by this reg key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WBEM\CIMOM]...
    So after a long search and a lot of experiments I did find out the culprit: I did disable events of the Common Information Model...
    I've got a Digital Devices Cine S2 V7A Twin and a DigitalEverywhere FloppyDTV for Satellite TV. I've been running MediaPortal 1.4.0...
    Replies
    1
    Views
    363
    I found the resolution: I had set this registry value set to 0: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WBEM\CIMOM] "EnableEvents"="0" As soon as I set it back to the default value 1, TV server did no longer say port 554 is bound and TV was working. On MediaPortal 1.4.0 and earlier the reg value could be set to 0 without any problem...
    I found the resolution: I had set this registry value set to 0: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WBEM\CIMOM]...
    I've described my problem here: https://forum.team-mediaportal.com/threads/satellite-tv-not-working-in-mediaportal-1-28.140530/ And...
    Replies
    1
    Views
    707
    P.S. - Strangely, the TV Server my single seat setup (1.27 on a modest machine running Windows 10 Pro x64) is working from my office machine MP client. Same exact network, firewall, Defender settings. It's a slightly older version of Win 10 though - I haven't updated to 20Hx on it yet. Maybe I shouldn't (or maybe I should image it...
    P.S. - Strangely, the TV Server my single seat setup (1.27 on a modest machine running Windows 10 Pro x64) is working from my...
    Let me start by asking if anyone has TV Server running PROPERLY on a Windows 10 machine, and if so are you using RTSP or UNC share...
    Replies
    9
    Views
    837
    Yes I think it's best to test with TVE3.5 the different combinations. The MTD and MCD modes are handled differently, so we have an option more to evaluate
    Yes I think it's best to test with TVE3.5 the different combinations. The MTD and MCD modes are handled differently, so we have an...
    Hi, i wrote this problem already in the german section, but the problem could not be solved until now. @morpheus_xx tryed it with...
    Replies
    21
    Views
    2K
    Top Bottom