MP TV-Client for dummies (1 Viewer)

Enzio

Portal Member
February 1, 2008
12
0
45
Gothenburg
Sweden Sweden
Hello I've been struggeling with this app for few nights now and can't get it to work, been reading the forum post forward and backward. Are there a friendy soul who could write a how to install tutorial. You need to edit the "Gentle.config" but how do you do that and wich parameters? Open ports on the firewall, settings in VLC and so on.

:(
 

level20peon

MP Donator
  • Premium Supporter
  • January 4, 2007
    1,082
    100
    38
    Aachen
    Germany Germany
    Country flag
    1. Download MpTvClient and extract the archives content to a place you like.

    2. Take your TV-Servers "gentle.config" out of "C:\Documents and Settings\<username>\Application Data\Team MediaPortal\MediaPortal TV Server\" and copy it into the folder you previously extracted to.

    Hint: To prevent DNS-problems you should edit the "gentle.config" (both) like:
    Code:
    <DefaultProvider name="*****" connectionString="Server=[COLOR="Red"]DNSNAME[/COLOR]; [...]
    to
    <DefaultProvider name="*****" connectionString="Server=[COLOR="Red"]192.168.*.*[/COLOR]; [...] [COLOR="Red"]<-[/COLOR] insert your TV-Servers IP there
    3. Run the "MPTvClient.exe"

    4. Go to "Configuration -> Server Connection", enter your TV-Servers IP there

    5. Go to "Configuration -> External Player", select the path (search for) to your "vlc.exe"

    6. You just finished configuration, now simply Click on "Connect" to connect to your TV-Server (and close the connection test after it has been run) and double-click on any channel in the list to start watching TV.


    -level20peon


    PS: The connection test will tell you which ports to open in your firewall (disable it to test if the basic setup is working !)
     

    Enzio

    Portal Member
    February 1, 2008
    12
    0
    45
    Gothenburg
    Sweden Sweden
    leve20peon:

    Thanks, exelent guide got it working. I'm just a little bit confused because the TCP Port 1433 fails during the test. I've got no Windows firewall activaited and my router is configured to have all the nesesary ports open and the are re-directed to my HTPC. But when I choose connect anyway everything works in my LAN.

    When I try to do the same thing from my office computer it fails to connect, is it possible to use this app WAN?

    I've changed the following settings:

    <DefaultProvider name="*****" connectionString="Server=DNSNAME; [...] <-- Same as internal
    to
    <DefaultProvider name="*****" connectionString="Server=192.168.*.*; [...] <-- IP provided from ISP

    Is the Server DNSNAME the same as I named my Computer ex. HTPC?

    I took a couple of screenshots to show the error message I've got trying to connect via WAN.
     

    Attachments

    samo_yea

    Portal Pro
    November 12, 2007
    54
    27
    Italy Italy
    For the test of TCP port failing you have to activate the ms sql TCP/IP with the SQLServerManager. I give you a screenshot of the configuration manager (mine is in Italian :) ).
     

    Attachments

    Enzio

    Portal Member
    February 1, 2008
    12
    0
    45
    Gothenburg
    Sweden Sweden
    samo_yea:

    Thanks for the tip, I already have those settings activaited. So that ain't the problem, are there any other serttings regarding SQL that I can try?

    :D
     

    level20peon

    MP Donator
  • Premium Supporter
  • January 4, 2007
    1,082
    100
    38
    Aachen
    Germany Germany
    Country flag
    You really should black out your username / password in your screenshots ;)


    I'm just a little bit confused because the TCP Port 1433 fails during the test. I've got no Windows firewall activaited and my router is configured to have all the nesesary ports open and the are re-directed to my HTPC. But when I choose connect anyway everything works in my LAN.
    Other users are experiencing the same error but there has been no hint what the cause might be, yet. You could of course switch to MySQL if you have trouble with you DB.


    When I try to do the same thing from my office computer it fails to connect, is it possible to use this app WAN?
    It is possible. However you need lots of bandwith to stream over the net, but the standard answer from someone in Sweden will be "got it" anyways, so I am just talking to my self here ;).


    I've changed the following settings:

    <DefaultProvider name="*****" connectionString="Server=DNSNAME; [...] <-- Same as internal
    to
    <DefaultProvider name="*****" connectionString="Server=192.168.*.*; [...] <-- IP provided from ISP

    Is the Server DNSNAME the same as I named my Computer ex. HTPC?
    No, the DNSNAME would be an external dynamical DNS Name which you can find out by running a "tracert" to your external IP. You also can sign up at dyndns.org for DNS Names. It is also possible to just use your home-computers external IP there (inserted in the gentle.config of your office computer). Have a look at the other threads in this forum... you're not the first to ask this and since I use to write up things too complicated you're probably better off reading someone elses descriptions ;). PS: The error on your screenshot occurs if your client cannot connect (for whatever reason).


    -level20peon
     

    Frenchy2k1

    Portal Member
    September 30, 2008
    10
    0
    Bay Area
    United States of America United States of America
    Hi,

    I'm new to Media Portal and trying to get the same type of setup going.
    I installed TV-server RC2. It recognized my 2 ATSC tuners perfectly and works correctly in local (I can see a stream on the TV server itself with VNC).
    The next step was to get a stream going on my client with VNC and manual control and once again, this works great.

    I'm now trying to get the TV client to work, but I get the common problem of SQL TCP connection fail. (UDP works).
    I'm on a LAN, no firewall on any computer.

    Note 1: the thread linked in the wiki/docs is to the release 1.2.5 of this tool. I would advise to link to the forum root or this thread.

    Note2: after I installed the release 1.3.1, the DB connection tool helped a lot, as the default scheme for the DB is RC1 and the current release uses a scheme ending in RC2. Does that scheme gets reflected in the config file after the db connection tool worked? (I have not tried to read the config file yet, as I thought about that after leaving for work, update tonight).
     

    Frenchy2k1

    Portal Member
    September 30, 2008
    10
    0
    Bay Area
    United States of America United States of America
    Ok, so I tried some experimentation.
    Problem seems to come from MS SQL, not TV server, as any remote DB program will fail.
    I cannot understand why, though...

    I switched to MySQL and got another handful of problem (server refused to start. It seems the MySQL server 5.0 does not like to have a space in its name). MySQL is now working and I can finally connect using the TV client. Kinda.

    All the connection checks work. The program connects to the server, load the channel line up, but once I try to timeshift, I get the following error. The streaming still starts (although VLC does not start automatically), but I cannot control it after that (no stopping for example).
     

    Attachments

    level20peon

    MP Donator
  • Premium Supporter
  • January 4, 2007
    1,082
    100
    38
    Aachen
    Germany Germany
    Country flag
    Frenchy2k1: Try to replace DNS-Names in your gentle.config files (both, on server AND client side) to IPs (See Post #2 in this thread).

    Channel changing problem seems to be a bug a bunch of people are having atm. See this thread for information about it (if this is what YOU are experiencing)... no fix for it, yet.

    Have you inserted the correct path to VLC in your MpTvClient ? Which version of VLC are you using ?


    -level20peon
     

    samo_yea

    Portal Pro
    November 12, 2007
    54
    27
    Italy Italy
    Ok. I finally found the problem with the MSSQL TCP port check failed.

    You must open the SQL Server Configuration Utility, under "Protocols for SQLSERVEREXPRESS" select the tcp/ip option, right-click it, select "Proprieties" , select tab "IP Adresses". In that window you must enabel your IP and under tcp port you enter 1433. Save & restart the sql serer.
     

    Attachments

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    P Blocking TV recordings on client? General 5
    -Merkur- MP2 Client startet nicht, "libXBMC_addon.dll" fehlt Allgemeines Support- und Diskussionsforum 1
    C Current NUC or Intel Stick as an MP client for HD playback - minimum requirements? General 6
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 1
    O [Question] Advice Wanted on Developing a Client Application for a Disabled Family Member MPExtended 7
    ge2301 [WiP] MP2Web - A platform independent web client for MP2 MediaPortal 2 68
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    ge2301 Android based client for MP2 MediaPortal 2 3
    T Client / Server slow channel-to-channel change (zapping) General Support 1
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    J Where the heck is the Client side setup? General 2
    T Server / client channel logo location Installation, configuration support 6
    framug [solved] Some changes/fix in MP1 configuration client and server Submit: code patches (MediaPortal/TV-Server/etc.) 14
    C Streaming to clients over Wifi. MP1 or MP2? Newcomers Forum 0
    Golf4 Client verliert immer wieder die Verbindung Allgemeines Support- und Diskussionsforum 4
    A Synchronizing client databases MediaPortal 1 Talk 10
    P Streaming to two clients from the same card Newcomers Forum 1
    TLD Can not watch tv from remote clients Television (MyTV frontend and TV-Server) 19
    R [further infos missing] some movies freezing evry seconds Submit: Bug Reports 9
    R [solved] MP2 Client ist extrem langsam Allgemeines Support- und Diskussionsforum 5
    I MP Server goes into suspend, because it doesn't detect the MP Client General Support 6
    A Client/Server Setup: Slow TV Startup Television (MyTV frontend and TV-Server) 0
    P MP2 Client Screen Flickering on Resume General 2
    J Server vs Client Install General 5
    Similar threads

























    Top Bottom