MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 (1 Viewer)

CanadianEh

MP Donator
  • Premium Supporter
  • July 21, 2011
    127
    14
    United States of America United States of America
    Country flag
    Good morning.

    Back a few months ago, I replaced my original HTPC with updated hardware. I have a few Hauppauge ATSC tuners I'm reusing, but I replaced the Hauppauge HD-PVR with a Colossus 2, since the HD-PVR was on its last legs.

    What I'm noticing is that my true MediaPortal clients are able to play the Colossus 2 recordings without issue. However, the Kodi clients (running the latest build of LibreElec on Raspberry Pi 3 / 4's) receive a PMT error when trying to play any live TV or recordings captured by the Colossus 2. The Kodi clients can play live and recorded video from the ATSC tuners, as well as recordings performed by the HD-PVR. I'm a little puzzled on how to continue troubleshooting this issue, since I'm struggling to find the error.

    Attached are all error logs from my TV server. Any help would be greatly appreciated. The most recent example in the logs would be trying to play live TV from channel 821 TENISHD / show name: Center Court.


    Thanks
     

    Attachments

    CanadianEh

    MP Donator
  • Premium Supporter
  • July 21, 2011
    127
    14
    United States of America United States of America
    Country flag
    So, I think the issue may likely be on the Kodi client side. Attached is a log I was able to find on one Kodi client.

    The error condition seems to start with:
    OpenStream - Unsupported stream 0. Stream disabled.

    I'm curious why the Happauge Colossus 2 stream would be different from the original HD-PVR stream, and if there's a way I can address this on the MediaPortal TV Server side? I'm not finding much on this issue.
     

    Attachments

    CanadianEh

    MP Donator
  • Premium Supporter
  • July 21, 2011
    127
    14
    United States of America United States of America
    Country flag
    Good afternoon. I realized I never got back to posting the solution I found. Basically, I think I broke this on my own. I had made some registry changes to attempt to increase the video quality, which ended up not being supported by Kodi. Attached is a screenshot of what my final (working) settings are, just in case anyone else runs into this - or in case I blow it up again :). I used mediaarea.net/mediainfo to analyze the original working and the newer non-working videos to find the differences.
     

    Attachments

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    rsbrux 1.27.0 Supported SQL Server version(s) / TV Service dependency on SQL Server / Wait for TV Server startup Installation, configuration support 2
    B Apply button in TV Server Confiurator Feature Requests 6
    R MpExtended fails to find MediaPortal TV Server Installation, configuration support 0
    Н .не открывается TV-Server Configuration Помощь по MediaPortal 11
    rsbrux MP 1.26 fails to connect to SQL Server Installation, configuration support 13
    S Problem with connecting to the TV server from outside Installation, configuration support 0
    T MP TV Service null reference after 1.26 install (server) Installation, configuration support 4
    S TV-Server Configuration Fehler Allgemeines Supportforum 1
    N [solved] MP2 TV-Server DD cine 2 V6, Astra keine deutschen Sender mehr General 4
    C 1.25.0 Need explanation - TV Servers/Scan settings TV-Server 1
    G MP2 - V2.3 Tv Server information General 2
    R Deadlock in TV Server if recording while importing EPG TV-Server 10
    W [solved] MP2 Server stürzt immer nach kurzer Zeit ab Allgemeines Support- und Diskussionsforum 89
    W TV Server didn't show Magic-Pro ProHDTV Diamond2 card TV-Server 2
    JimCatMP Problems with TV Server on dual homed host. General Support 0
    cbr954rr EPG Genre map categories do not match tv server categories General 4
    R Firewall on server blocking client General 10
    E [solved] TV-Server Configuration Missing TV-Server 9
    F MediaPortal 1.16 server crashing due to user error? General Support 5
    E TV-SERVER control TV-Server 3
    M 1.25.0 Tv Server Configuration Italian Dvb-t2 test channel preview error Television (MyTV frontend and TV-Server) 8
    M TV Server Preview Window is blank, sounds works Television (MyTV frontend and TV-Server) 3
    catalpa ...immer mal wird der Server abgekoppelt :( Allgemeines Support- und Diskussionsforum 0
    A Keine Verbindung mit Kodi auf Server Allgemeines Support- und Diskussionsforum 11
    CyberSimian Unhandled exception in TV Server TV-Server 0

    Similar threads

    Top Bottom