MSBuild V14 is missing on my dev machine (1 Viewer)

disaster123

MP Donator
  • Premium Supporter
  • May 14, 2008
    3,555
    434
    Germany Germany
    Country flag
    Hey guys,

    since being absence for a few years - a lot has happened here.

    I'm currently trying to reinstall a dev machine for MP-1 but i'm failing to build MP-1 using the MSBUILD .bat files. While building MP, Directshow and TVE works fine in my local VS2019 - those .bat files fail due to missing MSBUILD v14 - where to get it? VS2019 was installed with VS2015 v140 build deps.

    Thanks!

    Greets,
    Stefan
     

    disaster123

    MP Donator
  • Premium Supporter
  • May 14, 2008
    3,555
    434
    Germany Germany
    Country flag
    i've now installed Download Microsoft Build Tools 2015 from Official Microsoft Download Center Build Tools 2015 which provided the MSBUILD.exe v14 but now it fails with:
    Code:
    Projekt "C:\Users\admin\Desktop\Dev\MediaPortal-1\Build\RestorePackages.targets" auf Knoten "1" (Standardziele).
    CustomRestorePackages:
      Downloading 'https://dist.nuget.org/win-x86-commandline/latest/nuget.exe' ...
    C:\Users\admin\Desktop\Dev\MediaPortal-1\Build\RestorePackages.targets(17,5): error : Die Anfrage wurde abgebrochen: Es konnte kein geschützter SSL/TLS-Kanal
    erstellt werden..
    Die Erstellung des Projekts "C:\Users\admin\Desktop\Dev\MediaPortal-1\Build\RestorePackages.targets" ist abgeschlossen (Standardziele) -- FEHLER.
    
    
    Fehler beim Buildvorgang.
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,638
    5,271
    France - IDF
    France France
    Country flag
    Hello stefan
    How are you?
    About nuget it's a bug with msbuild 14
    We have branch with newest vs2019 tool.
    I'm very busy since month, look on mp release thread.

    Envoyé de mon LG-H870S en utilisant Tapatalk
     

    disaster123

    MP Donator
  • Premium Supporter
  • May 14, 2008
    3,555
    434
    Germany Germany
    Country flag
    Hello azzuro ;-) i'm fine thanks for asking hope you're ok as well. I solved everything and building now runs fine again. It's much easier today with VS2019 and nuget ;-) no wasm, yasm, directx sdk. That's very nice.

    I didn't need that vs2019 branch - what's the advantage? Which one is it? "mp release thread"
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,638
    5,271
    France - IDF
    France France
    Country flag
    Hello azzuro ;-) i'm fine thanks for asking hope you're ok as well. I solved everything and building now runs fine again. It's much easier today with VS2019 and nuget ;-) no wasm, yasm, directx sdk. That's very nice.
    you say than, it's great because you don't need to install Dx9 / yasm / ant, anymore ?
    if yes, we use nuget to provide all this part ( more easy to update ) also libbluray can be imported from nuget if you do'nt want build it ;)
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    ge2301 Images missing im Forum Online Facilities 2
    catalpa MP2 - V2.3 Optimfrog.dll missing Allgemeines Support- und Diskussionsforum 10
    E [solved] TV-Server Configuration Missing TV-Server 9
    O Steps to achieve AV sync - please tell me I'm missing something General 0
    P Missing channels after rebuild (all on one MUX ?) General 2
    SpudR Missing Page Numbers Website/Forum/Wiki Feedback 11
    g0rsq UK Freesat not tunning BBC HD channels, and lots of other freesat channels missing. Newcomers Forum 4
    D [solved] TVServer Plugin must be missing something. General Development (no feature request here!) 1
    HTPCSourcer Missing series posters/banners MediaPortal 2 11
    thepahakurki Trakt error: Invalid or missing file Trakt 8
    T How to add missing buttons IR Server Suite (IRSS) 0
    T Missing sound in online streaming service (SVTPlay) General Support 3
    D Tuner Suddenly Missing Channels TV-Cards 0
    S Missing plugin for MP2 Plugin Development 1
    L [solved] MP2 doesnt play anything - player missing? General 1
    L Tv series install problem missing file My TVSeries 7
    L [solved] Missing gentle.config file General 6
    CyberSimian TV Server import is missing some settings MediaPortal 1 0
    T Media Portal 2 EPG data missing General 16
    zunixnuz Missing #iswatched property to recorded TV Titan Skin Feedback 5

    Similar threads

    Top Bottom