No Video playback on Media Portal 2.2.3 (2 Viewers)

Octavius

Portal Member
September 15, 2020
7
1
Home Country
United Kingdom United Kingdom
Country flag
I have a new install of Windows 10 (2004), running Media Portal 2.2.3, on a machine that's set up to be a dedicated HTPC.

I can play music and view images from the media libraries I've set up, but I can't get any videos to play at all, including a local DVD. I've attached screenshots of the errors I get, but it doesn't tell me much.

Originally, I was testing Kodi on this HTPC, as part of that I installed VLC to give Kodi the ability to decode DVD and Blu-Ray disks. VLC is able to play both videos over the network and DVDs. Is there something I need to set up in Media Portal to have it use VLC to play/decode videos? Or is there somewhere with more information about why the videos wont' play so I can troubleshoot?

Many thanks
 

Attachments

  • DVD Error.png
    DVD Error.png
    730.1 KB · Views: 0
  • Video Error.png
    Video Error.png
    718.5 KB · Views: 0

Octavius

Portal Member
September 15, 2020
7
1
Home Country
United Kingdom United Kingdom
Country flag
I've found the error in the Client.log file:

[2020-10-16 00:50:23,548] [1194483] [136 ] [INFO ] - WorkflowManager: Trying to remove 1 workflow states from navigation stack...
[2020-10-16 00:50:23,550] [1194485] [136 ] [INFO ] - WorkflowManager: Trying to show screen 'BrowseMediaNavigation'...
[2020-10-16 00:50:23,551] [1194486] [136 ] [INFO ] - WorkflowManager: Screen 'BrowseMediaNavigation' successfully shown
[2020-10-16 00:50:24,117] [1195052] [136 ] [INFO ] - BassLibrary: Loading player add-ins from 'C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\BassLibraries\Plugins'
[2020-10-16 00:50:25,991] [1196926] [136 ] [INFO ] - BassLibrary: Loaded 16 audio decoders.
[2020-10-16 00:50:26,512] [1197447] [136 ] [WARN ] - MediaPortal.UI.Players.Video.VideoPlayer: Unable to play 'Resource '{03dd2da6-4da8-4d3e-9e55-80e3165729a3}://\\MyServer\Media\TV/TV Series/Rules of Engagement/Season 6/06x14 - Goodbye Dolly.mp4' at system '805a91c0-57a9-48e4-8f65-040de226a2b0'
System.Runtime.InteropServices.COMException (0x80040154): Retrieving the COM class factory for component with CLSID {FA10746C-9B63-4B6C-BC49-FC300EA5F256} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).
at MediaPortal.UI.Players.Video.VideoPlayer.AddEvr()
at MediaPortal.UI.Players.Video.VideoPlayer.AddPresenter()
at MediaPortal.UI.Players.Video.BaseDXPlayer.SetMediaItem(IResourceLocator locator, String mediaItemTitle, MediaItem mediaItem)
at MediaPortal.UI.Players.Video.VideoPlayerBuilder.GetPlayer(MediaItem mediaItem)
[2020-10-16 00:50:26,517] [1197452] [136 ] [ERROR] - Unable to create media player for media item '06x14 - Goodbye Dolly'
System.Runtime.InteropServices.COMException (0x80040154): Retrieving the COM class factory for component with CLSID {FA10746C-9B63-4B6C-BC49-FC300EA5F256} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).
at MediaPortal.UI.Players.Video.VideoPlayer.AddEvr()
at MediaPortal.UI.Players.Video.VideoPlayer.AddPresenter()
at MediaPortal.UI.Players.Video.BaseDXPlayer.SetMediaItem(IResourceLocator locator, String mediaItemTitle, MediaItem mediaItem)
at MediaPortal.UI.Players.Video.VideoPlayerBuilder.GetPlayer(MediaItem mediaItem)
at MediaPortal.UI.Services.Players.PlayerManager.BuildPlayer_NoLock(MediaItem mediaItem, ICollection`1& exceptions)
[2020-10-16 00:50:26,538] [1197473] [AMQ 'UPnPRendererPlugin'] [ERROR] - Player Error
[2020-10-16 00:50:26,541] [1197476] [Thread12 ] [INFO ] - WorkflowManager: Pushing workflow state 'VideoFullscreenContent' (id='882c1142-8028-4112-a67d-370e6e483a33') onto the navigation stack...
[2020-10-16 00:50:26,546] [1197481] [Thread12 ] [INFO ] - WorkflowManager: Screen was updated by workflow model


Any idea what this error means?
 

morpheus_xx

Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,752
    7,115
    Home Country
    Germany Germany
    Country flag
    Are you using a Windows "N" version or similar? Those versions are missing the Windows Media stuff, which need to be installed separately. The call which fails above is related to the Enhanced Video Renderer (EVR) which doesn't seem to find required filters
     

    Users who are viewing this thread

    Similar threads

    I've just tested by taking a copy of the file you mentioned above, than navigating to Settings -> Media Sources -> Network Credentials in the Media Portal Client. I tick the box to say "Use username and password..." (it is unticked every time I go into this setting), then enter the username and password and click OK. I went back to...
    I've just tested by taking a copy of the file you mentioned above, than navigating to Settings -> Media Sources -> Network...
    Hi All, I'm setting up Media Portal 2.2.3 on a new Windows 10 (2004) Build The first issue I've come across is that I can't...
    Replies
    7
    Views
    878
    OK. Two things. ajs is right. MP is not a player, but it must use a lot of overhead that Windows Media Player (default player, right?) needs to play H265 files. VLC does not have that overhead, but it doesn't have the nifty database and UI. Same goes for MPV player. Sebastiii suggests that I need to set up my LAV codec as he has. I...
    OK. Two things. ajs is right. MP is not a player, but it must use a lot of overhead that Windows Media Player (default player...
    For some unknown reason I can't play HEVC encoded video with MP1 on my system. I have tried every trick I know, but nothing works...
    Replies
    5
    Views
    152
    No compatibility settings at all please. MP2 runs on Windows 10 without further interaction.
    No compatibility settings at all please. MP2 runs on Windows 10 without further interaction.
    I am new to MediaPortal and just installed the newest 2.2.3 on a Windows 10. The first few days were fine, we recorded TV and...
    Replies
    31
    Views
    2K
    Hi, I have just updated my MediaPortal 1.22 HTPC from Windows 7 to Windows 10 Home, and now cannot play DVD or Blu Ray discs with the internal player. As soon as MediaPortal tries to read the DVD or Blu Ray it locks up. If I set MediaPortal to use an external player (VLC) it works fine within VLC. I am using EVR and LAV filters...
    Hi, I have just updated my MediaPortal 1.22 HTPC from Windows 7 to Windows 10 Home, and now cannot play DVD or Blu Ray discs with...
    Hi, I have just updated my MediaPortal 1.22 HTPC from Windows 7 to Windows 10 Home, and now cannot play DVD or Blu Ray discs with...
    Replies
    0
    Views
    653
    I am not sure that I understand what setup you are trying to achieve. Some suggestions: (1) Place the PC adjacent to the TV. Connect the video output from the PC to the video input on the TV. Most desktop PCs and laptops have HDMI output sockets these days, and most modern TVs have HDMI input sockets, so you simply need an...
    I am not sure that I understand what setup you are trying to achieve. Some suggestions: (1) Place the PC adjacent to the TV...
    I currently have Media Portal installed on just my PC as a library and viewing platform for my personal collection of videos and...
    Replies
    1
    Views
    1K
    Top Bottom