PC Crashes While Recording (1 Viewer)

macmr

Portal Pro
August 21, 2011
70
8
Country flag
Not sure if this is a bug with 1.14.0 pre release or not but this is the version I am running so I will post it here anyway.

Some history:

Was running 1.3.0 and added a PCI DVT quad tuner (TBS-6205) card in conjunction with my original twin usb tuner. When I set a number of programs to record concurrently it sometimes would crash the pc
I thought that this might be an issue with 1.3.0 so decided to upgrade to 1.14.0 but it still happens so I now think it might be a tuner issue.

This is what happened last night:
1. Set multiple concurrent programs to record - Sunday night normal selection each Sunday
2. Turned off tv at approx 9pm with recording running
3. Next morning found pc still running (which normally indicates a problem)
4. Tried a Ctrl+Alt+Del but no response
5. Hard reset by power button
6. Use Watchdog program to export available logs
7. Checked programs that were recording but didn't finish and it looks like they stopped around 9:10 pm. This is somewhat earlier a crash than normal as on Sunday nights it usually stops around 10 to 10:30 pm. Sometimes but not very often it has actually managed to record all the programs correctly

Hoping someone can analyse this issue

Thanks
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello again

    When I set a number of programs to record concurrently it sometimes would crash the pc
    I thought that this might be an issue with 1.3.0 so decided to upgrade to 1.14.0 but it still happens so I now think it might be a tuner issue.
    The plausibility of it being an issue with MediaPortal entirely depends on what you mean by "crash the pc".

    If MediaPortal or TV Server close/stop suddenly and without warning (ie. crash to desktop, often abbreviated as CTD) then it's possibly a MediaPortal issue.
    Most other things - blue screens of death (BSODs), Windows/PC lockups, PC automatic restarts etc. - are generally caused by hardware (eg. manufacturing defect), driver, or hardware/software compatibility issues.

    This is what happened last night...
    There's nothing in the log files to indicate that either MediaPortal or TV Server crashed or experienced any sort of problem. Therefore I'd tend to suspect a hardware, driver or compatibility issue with the new card that you've added.

    Hoping someone can analyse this issue
    What I've said above is pretty much all that I can say.
    In essence: it doesn't look like a MediaPortal problem.
    I suggest you:
    1. Ensure you're using the latest/best versions of tuner and motherboard chipset drivers.
    For the tuner it looks like you're using v1.0.0.3 but 1.0.0.4 is available etc.
    2. Check for motherboard BIOS/EFI updates.

    If the above advice doesn't help, contact TBS and/or Gigabyte for support.
     

    macmr

    Portal Pro
    August 21, 2011
    70
    8
    Country flag
    Thanks yes that is what I expected but just eliminating Mediaportal first as the issue
     

    macmr

    Portal Pro
    August 21, 2011
    70
    8
    Country flag
    Ok an update but not positive

    I have installed the latest tuner driver 1.0.0.4
    I ran DXDiag and it showed no errors
    I changed the TV codec audio renderer to DirectSound

    So this is probably still not an MP issue but this is what happened

    8-5-16
    TV off at 9:42 pm while shows were recording

    9-5-16 (logs attached)
    PC locked up so restart required
    Previous nights programs that recorded were:
    Good Bones - Started 9:26 pm and ran for approx 33:40 (not complete) so end time of 9:59:40
    Blacklist - Started 9:49 pm and ran for approx 10:45 (not complete) so end time of 9:59:45
    NCIS New Orleans - Started 10:08 pm and ran for approx 33:45 (not complete) so end time of 10:41:45

    As far as I can tell the logs stopped around 10:42 pm which I assume is when the pc crashed which is a similar time to when NCIS stopped recording
    I do not know why the other two recordings stopped together about 10pm which was well before the pc shutdown

    Hopefully the logs may be of assistance
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    PC locked up so restart required
    What time was this?
    How did you know the PC was locked up?

    TV off at 9:42 pm...
    As far as I can tell the logs stopped around 10:42 pm
    To me it's suspicious that the difference is so close to 60 minutes.

    ...which I assume is when the pc crashed which is a similar time to when NCIS stopped recording
    Yes, that's a given. Any active recordings are going to stop in the event of a crash.

    I do not know why the other two recordings stopped together about 10pm which was well before the pc shutdown
    The log files don't show TV Server intentionally stopping them. Further, there are indications in the TsWriter log that both Good Bones and The Blacklist were still recording at 22:37:30:
    [collapse]
    [2016-05-08 21:26:15,127] [bfd3480] [1340] - video pid: 83 type: H264
    [2016-05-08 21:26:15,127] [bfd3480] [1340] - audio pid: 213 language: eng type: MPEG1 - audio
    [2016-05-08 21:26:15,127] [bfd3480] [1340] - pmtgrabber: got new pmt version:2 ffffffff, service_id:790
    [2016-05-08 21:26:15,127] [bfd3480] [1340] - pmtgrabber: do callback pid 14b
    [2016-05-08 21:26:15,136] [bfd3480] [1e24] - analyzer: set video pid:83
    [2016-05-08 21:26:15,136] [bfd3480] [1e24] - analyzer: reset
    [2016-05-08 21:26:15,137] [bfd3480] [1e24] - analyzer: set audio pid:213
    [2016-05-08 21:26:15,137] [bfd3480] [1e24] - analyzer: reset
    [2016-05-08 21:26:15,168] [bfd3480] [1e24] - Recorder: RECORD set filename:F:\Recorded Tv\Good Bones - LIFE - 2016-05-08.ts
    ...
    [2016-05-08 21:49:11,514] [bfd3480] [13c8] - video pid: a8c type: MPEG2
    [2016-05-08 21:49:11,514] [bfd3480] [13c8] - audio pid: a8d language: eng type: MPEG2 - audio
    [2016-05-08 21:49:11,514] [bfd3480] [13c8] - pmtgrabber: got new pmt version:3 ffffffff, service_id:942
    [2016-05-08 21:49:11,514] [bfd3480] [13c8] - pmtgrabber: do callback pid 10e
    [2016-05-08 21:49:11,524] [bfd3480] [1e24] - analyzer: set video pid:a8c
    [2016-05-08 21:49:11,524] [bfd3480] [1e24] - analyzer: reset
    [2016-05-08 21:49:11,524] [bfd3480] [1e24] - analyzer: set audio pid:a8d
    [2016-05-08 21:49:11,524] [bfd3480] [1e24] - analyzer: reset
    [2016-05-08 21:49:11,564] [bfd3480] [1e24] - Recorder: RECORD set filename:F:\Recorded Tv\The Blacklist - PRIME7 Wollongong - 2016-05-08.ts
    ...
    [2016-05-08 22:37:30,368] [bfd3480] [1340] - Recorder:pid 83 Continuity error... a ( prev b ) - bad signal?
    [2016-05-08 22:37:30,368] [bfd3480] [1340] - Recorder:pid 213 Continuity error... c ( prev 6 ) - bad signal?
    [2016-05-08 22:37:30,368] [bfd3480] [1340] - Recorder:pid 83 Continuity error... a ( prev b ) - bad signal?
    [2016-05-08 22:37:30,368] [bfd3480] [1340] - Recorder:pid 213 Continuity error... c ( prev 0 ) - bad signal?
    [2016-05-08 22:37:30,438] [bfd3480] [13c8] - Recorder:pid a8c Continuity error... 5 ( prev 9 ) - bad signal?
    [2016-05-08 22:37:30,438] [bfd3480] [13c8] - Recorder:pid a8d Continuity error... e ( prev c ) - bad signal?
    ...
    [2016-05-08 22:37:30,438] [bfd3480] [13c8] - Recorder:pid a8c Continuity error... 5 ( prev 5 ) - bad signal?
    [2016-05-08 22:37:30,438] [bfd3480] [13c8] - Recorder:pid a8d Continuity error... e ( prev 0 ) - bad signal?
    [/collapse]

    (Note the matches between the video/audio PIDs at the start of the recordings, and the video/audio PIDs for the continuity errors.)

    Therefore to me it seems likely that the Good Bones and Blacklist recordings were also still running at the time of the crash. The truncated length could be due to corruption as a side effect of the crash.


    I can't add anything to what I said in my previous reply. It appears that your system is crashing. System crashes are most often caused by hardware, driver or compatibility issues. It seems likely that the issue has something to do with the new TBS-6205 tuner that you added, because the crashes only started after you added it. Therefore you ought to contact TBS and/or Gigabyte for support. There's nothing more that we can do to help you.
     

    macmr

    Portal Pro
    August 21, 2011
    70
    8
    Country flag
    Ok I appreciate your advice I will look further afield other than MP

    Thanks
     

    macmr

    Portal Pro
    August 21, 2011
    70
    8
    Country flag
    Changed a few settings in MP based on other users using TBS card (different model) but no success. I am now starting another thread in the Hardware/ TV Cards forum as well as on the TBS forum. Thanks.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    I am now starting another thread in the Hardware/ TV Cards forum
    Why don't we just move this thread? To me it makes no sense to fragment the info over multiple threads.
     

    macmr

    Portal Pro
    August 21, 2011
    70
    8
    Country flag
    I think it would be a cleaner thread just to quote the info on the tuner rather than mentioning all the info about MP. I'm sure the card is the problem for whatever reason. Thanks
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    badboyxx MP 1.22 final is crashing when jumping forward while playing DVD-Iso watch/edit Videos 26
    amatesi MP2.2pre Client crash while streaming Live TV from remote MP2.2pre Server (both offline) 2.2 Archive 8
    A MP2 - V2.1 MP2 suddenly stops working while playing audio / Crash inside FreeType Older releases 14
    L Service keeps crashing General 0
    U [solved] MediaPortal crashing on startup General Support 10
    RoChess Weird GPU crash -- possible cause: resizing media MediaPortal 1 Talk 8
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    D [solved] Changed username in Win10, now TV Server config crashes on fresh install Installation, configuration support 1
    ajs Trakt error when start with MP crash Trakt 1
    R TV server crash with WintTV quadHD General 0
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    atlantic [solved] MP1.24 Pre released crash in TV General Support 12
    RoChess Random GPU crash leads to MePo restart, but works fine afterwards MediaPortal 1 14
    R [fixed] [MP2-819] MP2 Server crashes on ATSC OTA channel scan Submit: Bug Reports 33
    doskabouter 1.23.0 Crash when skipping in a dvd Bugreports 3
    J [fixed] [MP2-833] 2.2.2 server crash during import Submit: Bug Reports 50
    P MP2 TV Server crashes when starting - throws error remoting exception General 2
    G MP Crashed during setting up recording. Newcomers Forum 1
    Rob Hexenmeister DVD Skip steps causing crash General Support 2
    Terra Crash when opening ACTORS list My TVSeries 3
    Terra Crash when searching movies, reproducable Moving Pictures 2
    KlausWirn Music crash Bass crash no change to play music Installation, configuration support 2
    cladinshadows85 [solved] Audio playing mutiple times over video and crashing General 8
    Similar threads

























    Top Bottom