[Plugin] DVDArt - All artwork for MovingPictures, MyFilms, TVSeries, Music & more!!! | Page 57

Discussion in 'MediaPortal 1 Plugins' started by m3rcury, September 29, 2012.

  1. m3rcury
    • Team MediaPortal

    m3rcury Development Group

    Joined:
    August 12, 2010
    Messages:
    954
    Likes Received:
    523
    Gender:
    Male
    Ratings:
    +621 / 4
    Home Country:
    Malta Malta
    Show System Specs
    DVDArt Plugin V1.0.3.2 is available for download from here. This version fixes issue reported by @conguero23.



    In order to download any missed actors, go to the plugin from the icon, choose Movies tab, choose Actors/Writers/Directors missing Picture tab, right-click on the list and select Rescan All.
     
    • Like Like x 1
    • Thank You! Thank You! x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. conguero23

    conguero23 Portal Member

    Joined:
    December 9, 2012
    Messages:
    48
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +8 / 0
    Home Country:
    United States of America United States of America
    Thanks it works, I have another question I was never able to make the program run automatically when a new movie is added. I always have to run it manually.
    One i Thing I see is that in the xml file no matter when I run it it says:

    <section name="Scheduler">
    <entry name="lastrun">24/01/2014 21:14:23</entry>
    </section>

    Even if delete it it defaults back to that date.
     
  4. m3rcury
    • Team MediaPortal

    m3rcury Development Group

    Joined:
    August 12, 2010
    Messages:
    954
    Likes Received:
    523
    Gender:
    Male
    Ratings:
    +621 / 4
    Home Country:
    Malta Malta
    Show System Specs

    @conguero23. The lastrun date is used for re-scanning of missing artwork. In order for plugin to run automatically you need to have the following setup:
    Untitled.jpg

    You also need to see what setup you have for CPU usage % and the periodicity as well.
     
  5. conguero23

    conguero23 Portal Member

    Joined:
    December 9, 2012
    Messages:
    48
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +8 / 0
    Home Country:
    United States of America United States of America
    I do have those settings but it never ran automatically.
     
  6. m3rcury
    • Team MediaPortal

    m3rcury Development Group

    Joined:
    August 12, 2010
    Messages:
    954
    Likes Received:
    523
    Gender:
    Male
    Ratings:
    +621 / 4
    Home Country:
    Malta Malta
    Show System Specs

    Can you upload your XML please.
     
  7. conguero23

    conguero23 Portal Member

    Joined:
    December 9, 2012
    Messages:
    48
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +8 / 0
    Home Country:
    United States of America United States of America
    Here is the xml. Thanks,
     

    Attached Files:

  8. m3rcury
    • Team MediaPortal

    m3rcury Development Group

    Joined:
    August 12, 2010
    Messages:
    954
    Likes Received:
    523
    Gender:
    Male
    Ratings:
    +621 / 4
    Home Country:
    Malta Malta
    Show System Specs
    XML looks fine. Can you please upload dvdart_plugin.log and mediaportal.log.
     
  9. conguero23

    conguero23 Portal Member

    Joined:
    December 9, 2012
    Messages:
    48
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +8 / 0
    Home Country:
    United States of America United States of America
    Please see logs below. Thanks,
     
  10. m3rcury
    • Team MediaPortal

    m3rcury Development Group

    Joined:
    August 12, 2010
    Messages:
    954
    Likes Received:
    523
    Gender:
    Male
    Ratings:
    +621 / 4
    Home Country:
    Malta Malta
    Show System Specs
    @conguero23. There is an error in MediaPortal.log. Let me see if I can re-create and have a look into it. Again, thanks for reporting (y)


    Edit: @conguero23. Error located and fixed. Will be uploading a new version soon.
     
    Last edited: April 26, 2015
    • Like Like x 1
  11. totopsgr
    • Premium Supporter

    totopsgr MP Donator

    Joined:
    August 15, 2011
    Messages:
    108
    Likes Received:
    7
    Gender:
    Male
    Occupation:
    Project Management Consultant
    Location:
    Abu Dhabi, UAE
    Ratings:
    +14 / 0
    Home Country:
    Greece Greece
    Hi all,

    I got a new HTPC, and was setting it up. Its a Zotac 760 plus, with windows 64bit 8.1 Pro. I installed the latest MP 1.11 and latest plugins for Avalance Skin, My Films, TV series etc. and of course DVDart. I have been struggling to make the DVDart display. At the moment whenever I start the config file I get the following error message detail (in blue):

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.ArgumentException: Argument 'Length' must be greater or equal to zero.
    at Microsoft.VisualBasic.Strings.Right(String str, Int32 Length)
    at DVDArt_Plugin.DVDArt_Common.Initialize(String database, String thumbs, String Movies, String Series, String Music, String Person)
    at DVDArt_Plugin.DVDArt_GUI.DVDArt_Load(Object sender, EventArgs e)
    at System.Windows.Forms.Form.OnLoad(EventArgs e)
    at System.Windows.Forms.Form.OnCreateControl()
    at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
    at System.Windows.Forms.Control.CreateControl()
    at System.Windows.Forms.Control.WmShowWindow(Message& m)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
    at System.Windows.Forms.ContainerControl.WndProc(Message& m)
    at System.Windows.Forms.Form.WmShowWindow(Message& m)
    at System.Windows.Forms.Form.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


    ************** Loaded Assemblies **************
    mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.34014 built by: FX45W81RTMGDR
    CodeBase:
    file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
    ----------------------------------------
    DVDArt_PluginLauncher
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase:
    file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/DVDArt_PluginLauncher.exe
    ----------------------------------------
    System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase:
    file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase:
    file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.34003 built by: FX45W81RTMGDR
    CodeBase:
    file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    Utils
    Assembly Version: 1.11.0.0
    Win32 Version: 1.11.0.0
    CodeBase:
    file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/Utils.DLL
    ----------------------------------------
    Core
    Assembly Version: 1.11.0.0
    Win32 Version: 1.11.0.0
    CodeBase:
    file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/Core.DLL
    ----------------------------------------
    System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase:
    file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
    ----------------------------------------
    DVDArt_Plugin
    Assembly Version: 1.0.3.2
    Win32 Version: 1.0.3.2
    CodeBase:
    file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/Plugins/process/dvdart_plugin.dll
    ----------------------------------------
    Common.Utils
    Assembly Version: 1.11.0.0
    Win32 Version: 1.11.0.0
    CodeBase:
    file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/Common.Utils.DLL
    ----------------------------------------
    Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 12.0.20806.33440 built by: FX45W81RTMREL
    CodeBase:
    file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
    ----------------------------------------
    System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase:
    file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
    ----------------------------------------
    MyFilms
    Assembly Version: 6.1.1.3139
    Win32 Version: 6.1.1.3139
    CodeBase:
    file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/Plugins/windows/MyFilms.dll
    ----------------------------------------

    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.

    For example:

    <configuration>
    <system.windows.forms jitDebugging="true" />
    </configuration>

    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.


    I can continue after this message and I end up in the config setup. But although I set the paths to artwork and the importer seems to pick them up, they don't appear in the movie list. So I guess the software may not be running properly after the error message.

    Any ideas what to do?

    Regards

    AT
     
Loading...

Users Viewing Thread (Users: 0, Guests: 1)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!