Problem running Live TV and network content

TonyR63

Portal Pro
December 1, 2015
60
6
56
Country flag
Hello


I installed Windows 10 Pro N clean on my media server to replace MythTv which broke on upgrade and hoped to use Media Portal in conjunction with Kodi on client machines to recover the mythtv functionality. Unfortunately nothing works in Media Portal 2 even though it appears to have installed correctly. First it only see one of my tuner cards the Fusion HDTV Plus and does not see the ASUS My Cinema U3100 at all which was working fine in Ubuntu and MythTv. I was able to scan for channels on the Fusion however it did not detect any SBS channels even though all other PVR in this location and TVs can see SBS with no problems. As I watch SBS a lot this is a show stopper – single tuner and no SBS, not a good solution. Next I tried to add media sources from the network and it could see the Astone media player and browse its folder structure but on configuration cannot see any of the content getting the message “no content”? Next I connected to another Win10 machine and it could not see any of its shares.


Reading the Wiki I learned you have to set network credentials and reconfigure all your media sources fresh even though I was logged in to both windows 10 machines as the same Microsoft user and the media server in Explorer could see all the shares that the Media Portal 2 could not and VLC could play. Several loops of setting network credentials and full restarts occurred until FINALLY I was able to see the share on my Window 10 machine shared content folders. I set all the sources and found that although in Media Portal I can see the content it can play back NOTHING no matter what format it is. It can’t play WMA, ts, m2ts, avi, vob, mkv, or mp4. I get the message do not recognise the file format!

Live TV show all channels except SBS but plays NOTHING. No matter what channel you chose in Media Portal 2 you get the same message “There is no player registered to play the media item filename.ts buffer”. I configured Kodi on another network client PC to connect to the media server using the Media Portal PVR client and again NOTHING – Connect lost message is all I get. The only content I can access from Media Portal 2 is audio MP# and standard CD.


In the Media Portal server configuration I can run “Test” for every found channel found (except SBS) and see perfect live tv so what is the problem with the Media Portal 2 client and the cryptic “There is no player registered to play the media item filename.ts buffer”. Because others have got this solution working well I am looking for something I might have done wrong in my attempted clean installation as I cannot easily see what else I can check. Are there special considerations for Win10?
 

HTPCSourcer

MP2 Product Manager
  • Team MediaPortal
  • Administrator
  • May 16, 2008
    11,286
    113
    Country flag
    As I've read in another thread you need MP1 TV Server not MP2.
    Maybe some more words of explanation: Kodi will not work in combination with the MP2 installation, but does with the MP1 TV Server setup. In other words: uninstall MP2, install MP1 and Kodi will work.
     

    TonyR63

    Portal Pro
    December 1, 2015
    60
    6
    56
    Country flag
    Hello


    Thanks for the suggestion. I will try and report back how I go.

    Many Thanks


    Anthoy
     

    TonyR63

    Portal Pro
    December 1, 2015
    60
    6
    56
    Country flag
    Hello

    I downloaded MP 1 but I cannot install as it requires windows media player 11 for XP. Even though the link in the installer took me to nowhere offer any download after much searching I found the file and downloaded. Why is media player now hidden from easy access to download? However I cannot install this version on Win10 as it reports Package Manager has been depreciated and setup exits? How do I install MP1 on Windows 10?

    In addition I reported much more than Kodi not working. Are you saying that MP2 will not detect SBS but all other channels and that MP2 will not playback any video format? Will all this be fixed if I can down grade to MP1? Sounds unlikely.
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • Administrator
  • May 16, 2008
    11,286
    113
    Country flag
    I downloaded MP 1 but I cannot install as it requires windows media player 11 for XP.
    That is not correct. MP1 requires a MediaPlayer to be installed - nothing to do with XP. Use the version that corresponds to your Windows, be it 7, 8 or 10.

    Why is media player now hidden from easy access to download?
    Chosing the correct MediaPlayer version to download is within the user's responsibility. In your case you should look for the "Media Featur Pack" that complements your Windows 10 N Pro version. A quick internet search will give you the correct Microsoft URL to download and install.

    How do I install MP1 on Windows 10?
    As explained in the Wki you need to activate the .Net 3.5 features in "Program Features" to be compatible with the MP1 installer.

    In addition I reported much more than Kodi not working.
    As I did say before: Kodi as front-end will not work in combination with a MP2 back-end. If you want to use Kodi as front-end you should stick to MP1.
     

    TonyR63

    Portal Pro
    December 1, 2015
    60
    6
    56
    Country flag
    Hello

    The MP1 installation program directs users to manually install wmp11-windowsxp-x86-ENU.exe and provides a link to download Windows Media player that takes you to a page where no download is available. This page provides users with a link titled "Download the Player : - http://windows.microsoft.com/en-us/windows/windows-media-player however you are taken to a page where you cannot download Media player for Windows 10 : - http://windows.microsoft.com/en-us/windows/download-windows-media-player. In addition nothing in the page references the "Feature Pack" and thousands of Microsoft users have reported this exact difficulty restoring WMP functionality on Windows 10. Anyone would expect a link "Download the player for windows 10 " to do just that and not lead users on a merry-go-round of frustration.

    When I encountered this problem I remembered that 5 months previously I had similar problems installing Media Player for Win 10 on my main computer so I looked in my downloads folder and found several downloads and after some time worked out it was a Feature Pack installation that got my main machine working with Media player. I run this feature pack installation on my Media Server PC which is the target machine for MP1 and it run successfully and restarted. I reran the MP1 setup and I still encountered the same problem. It sounds like you are suggesting that I need to activate .Net 3.5 features which I was unaware of so how do I do that?

    In the course of troubleshooting this I note that on my main PC, which has media player installed derived from the feature pack installation, I cannot see Media Player in my program group. In addition it does not appear in the Add Programs or Features app list and I found no way of starting media player in its own right. I can right click a MP3 file and choose "Play with media player" where it will launch and play the file but in its interface it provides no Help, About where you can review what version is loaded. I wasted a lot of time trying in vain to establish what version of Media Player is actually installed. All in all this is very sloppy by Microsoft for the follow reasons.

    1. You cannot easily go straight to a download link for media player and chose your windows version, download and install.
    2. The information about needing a specific feature pack is notably missing from all the pages you would expect to find it and takes a lot of effort to discover what you need to do. There is no mention what so ever of Feature Pack" in the two pages references I provided above a remarkable oversight I would say and in fact it implies that Media Player is already part of Win 10 which it was not on any of my Win 10 installations.
    3. Once you download and install the feature pack and media player is installed it does not setup the proper shortcut and program groups and you so not know what version you have installed and cannot be easily managed via Programs and Features. Combine this with the WMP info web page making it look like it should already be installed except there is no easy way to check if it is installed on a Win 10 system a perfect recipe for confusion.

    I suggesrt this is not a streagjht forward as suggested in response to my query and you should consider revising you installation program to explicitly reference the feature pack if that is what is required.

    For installation programs to be effective they have to be designed to work with those who are unfamiliar and new to a program and not just those who already know the working and requirements of MP.
     

    Vasilich

    Test Group
  • Team MediaPortal
  • August 30, 2009
    3,392
    113
    Germany, Mayence
    Country flag
    it implies that Media Player is already part of Win 10 which it was not on any of my Win 10 installations
    only Windows 7/8/10 N or KN do not have WMP preinstalled.
    Windows 10 N and KN editions, available for customers who live in countries that are part of the European Economic Area, Croatia, and Switzerland, have been designed to give you most of the features of Windows 10—with the addition of choice.
    The N and KN editions of Windows 10 include the same functionality as Windows 10, except for media-related technologies (Windows Media Player) and certain preinstalled media apps (Music, Video, Voice Recorder, and Skype). You must install other software from Microsoft or another company for this communication functionality and to play or create audio CDs, media files, and video DVDs, to stream music, and to take and store pictures. New features such as Cortana, Windows Hello, and PDF viewing in the new Edge browser rely on Windows Media files that are not present in these editions.
    the link for Media Feature Pack including WMP for w10 is there https://www.microsoft.com/en-us/download/details.aspx?id=49919
    P.S. edited after comment from mm.
     
    Last edited:

    TonyR63

    Portal Pro
    December 1, 2015
    60
    6
    56
    Country flag
    MythTv 10.04 worked fine for 5 years but on "forced" upgrade everything broke. After 14 weeks of troubleshooting and numerous re-installations I gave up as a lost cause and figured I would look at a windows platform. So here I am learning MP from scratch.
     
    Top Bottom