Problem with sortby for 'Star Trek'

Discussion in 'IMDb+' started by wolferl99, April 15, 2017.

  1. wolferl99
    • Premium Supporter

    wolferl99 MP Donator

    Joined:
    January 21, 2007
    Messages:
    14
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    Hi,

    I have the problem that movie series are not sorted correctly. The problem seems to be that the 'Sort By' field isn't filled correctly. As an example see Star Trek: Insurrection which should be Star Trek 9:

    [​IMG]


    It is listed correctly in the scraper script:

    [​IMG]




    Here the imdb+ version plus the chosen options:

    [​IMG]

    It must be something specific to this install, because it works fine (updates to: Star Trek 09) on another PC.

    Any hint appreciated, log attached if needed.
     

    Attached Files:

  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. SpudR
    • Team MediaPortal

    SpudR Documentation Group

    Joined:
    July 27, 2007
    Messages:
    2,612
    Likes Received:
    451
    Occupation:
    CTO, MD
    Location:
    Yorkshire, UK
    Ratings:
    +683 / 2
    Home Country:
    England England
    Show System Specs
    Looks like a glitch in the matrix - use the buttons at the top right to send back to the importer...
     
  4. RoChess
    • Premium Supporter

    RoChess Extension Developer

    Joined:
    March 10, 2006
    Messages:
    4,238
    Likes Received:
    1,334
    Ratings:
    +1,743 / 2
    Yeah, looks like the forced `sortby` value was not used.

    Probably one of those random race-conditions anomalies that I'll never be able to reproduce. As @SpudR mentioned a refresh should fix it.
     
  5. wolferl99
    • Premium Supporter

    wolferl99 MP Donator

    Joined:
    January 21, 2007
    Messages:
    14
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    It gets weirder. I tried re-importing multiple times without success. And not just did that not fix it for this movie, when I tried the reimport on one of the other ones ('Star Trek V' I think), it replaced it's sortby value 'Star Trek 05' with 'star trek v the final frontier'!

    Should I try de- and re-installing the imdb+ plugin?

    Edit: the logfile in the first post is from one of those unsuccessful re-import trials, created following the description on the wiki. I should have clarified that in the OP
     
    Last edited: April 17, 2017
  6. RoChess
    • Premium Supporter

    RoChess Extension Developer

    Joined:
    March 10, 2006
    Messages:
    4,238
    Likes Received:
    1,334
    Ratings:
    +1,743 / 2
    @wolferl99 the only way I can have a serious look at it, is if you follow the IMDb+ debug steps as outlined on the wiki @ Issues Debugging · RoChess/IMDbPlus Wiki · GitHub

    The key is capturing the failure in a clean log file without any asynchrone log entries mixed in.

    I'll be happy to take a look then.
     
  7. wolferl99
    • Premium Supporter

    wolferl99 MP Donator

    Joined:
    January 21, 2007
    Messages:
    14
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    Actually the log in the 1st post was captured that way: set log level to debug in both MP and scripts, start movingpictures config, wait for log file to not grow anymore and delete it, run import.
     
  8. RoChess
    • Premium Supporter

    RoChess Extension Developer

    Joined:
    March 10, 2006
    Messages:
    4,238
    Likes Received:
    1,334
    Ratings:
    +1,743 / 2
    @wolferl99, my bad, I'm so used to bad logs that I misjudged yours.

    Try v4.9.71 and it should work again.
     
    • Thank You! Thank You! x 1
  9. wolferl99
    • Premium Supporter

    wolferl99 MP Donator

    Joined:
    January 21, 2007
    Messages:
    14
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    No worries, having been on the receiving end of bad logs way too many time myself, I fully understand your sentiment! :)

    And I'm happy to report that 4.9.71 fixed the problem, allowing both 'refresh' and 'reimport' to update the sortby field correctly.

    Thanks for all your work and support.
     
  10. RoChess
    • Premium Supporter

    RoChess Extension Developer

    Joined:
    March 10, 2006
    Messages:
    4,238
    Likes Received:
    1,334
    Ratings:
    +1,743 / 2
    You're welcome.

    There is a special IMDb+ plugin entry to quickly fix your entire database with the correct SortBy entries, and that is to use the "Refresh Movies" option, and then select "Update replacements only".

    This will refresh all your movies that you have in your collection with a matching entry in the default/custom rename XML files. That way the proper "Sort By" values will be used.

    NOTE: Moving-Pictures only updates the movie list when it starts for the first time, so you would have to restart MediaPortal to see the new results correct.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!