[no Bug] Recorded TV Playback stops without user intervention (1 Viewer)

gonzo90017

Portal Pro
September 3, 2012
238
26
21
United States of America United States of America
When I playback any show from my Recorded TV. Playback stops without user intervention. It's as if I pressed the stop button. I tried this with multiple recordings and had the same issue.

TV> Recorded TV> Choose Recording> Start Playback.
 

Holzi

Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,930
    2,234
    Ba-Wü
    Germany Germany
    Country flag
    When I playback any show from my Recorded TV. Playback stops without user intervention. It's as if I pressed the stop button. I tried this with multiple recordings and had the same issue.

    TV> Recorded TV> Choose Recording> Start Playback.

    Can you try with LAV Video and Audio Codec for TV playback?
    Please also try DefaultDirectSound Device as Audio Renderer.
     
    Last edited:

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello gonzo90017

    When I playback any show from my Recorded TV. Playback stops without user intervention. It's as if I pressed the stop button. I tried this with multiple recordings and had the same issue.
    Can you absolutely confirm it happens with all recordings?

    I can see that you might think it is happening with "The Life of Muhammad"... but actually, to me it looks like that recording is playing out in full. It is just a really short recording for some reason. The fact that the name of the file is "The Life of Muhammad _ - 50 Pbs - 2013-08-20_2.ts" suggests the recording has multiple parts for some reason.

    I don't see it happening with "NFL Football - 5 CW - 2013-08-23.ts" which you played earlier.

    More specific information needed please... :)
     

    gonzo90017

    Portal Pro
    September 3, 2012
    238
    26
    21
    United States of America United States of America
    Can you absolutely confirm it happens with all recordings?
    Change that to most recordings.
    "The Life of Muhammad _ - 50 Pbs - 2013-08-20_2.ts"
    The 2 is because it was a 3 part series. The recording was 1 hour long.

    If you can find the recording "Cachito del Cielo" in the logs you would see that playback stopped multiple times without user intervention.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    If you can find the recording "Cachito del Cielo" in the logs you would see that playback stopped multiple times without user intervention.
    I can see "Cachito de Cielo" - I assume that is the program you mean.
    There are two recordings that you play. One from 22/08 and the other from 21/08. Which one should I be looking at?
     

    gonzo90017

    Portal Pro
    September 3, 2012
    238
    26
    21
    United States of America United States of America
    Yes that's the one. The thing is that the wife was the one watching the show so i'm not sure which one it is. :oops:
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Right, no worries - think I can guess what is going on regardless...
    Each time the recording is stopped I see MP has detected that the audio renderer is lost. So:
    [collapse][2013-08-24 11:12:01,008] [Log ] [MPMain ] [DEBUG] - Main: WM_DEVICECHANGE (Event: DBT_DEVICEREMOVECOMPLETE)
    [2013-08-24 11:12:01,009] [Log ] [MPMain ] [DEBUG] - Main: Device type is DBT_DEVTYP_DEVICEINTERFACE - Name: Bluetooth Stereo Audio
    [2013-08-24 11:12:01,026] [Log ] [MPMain ] [DEBUG] - Main: WM_DEVICECHANGE (Event: DBT_DEVICEREMOVECOMPLETE)
    [2013-08-24 11:12:01,026] [Log ] [MPMain ] [DEBUG] - Main: Device type is DBT_DEVTYP_DEVICEINTERFACE - Name: Bluetooth Stereo Audio
    [2013-08-24 11:12:01,026] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer Bluetooth Stereo Audio removed
    [2013-08-24 11:12:01,028] [Log ] [MPMain ] [DEBUG] - g_Player.doStop() keepTimeShifting = False keepExclusiveModeOn = False
    [2013-08-24 11:12:01,028] [Log ] [MPMain ] [INFO ] - g_Player.OnStopped()
    [2013-08-24 11:12:01,032] [Log ] [MPMain ] [INFO ] - RadioRecorded:OnPlayRecordingBackStopped Recording D:\TV Recordings MP\34 Univision\Cachito de cielo\Cachito de cielo - 2013-08-22.ts
    [2013-08-24 11:12:01,032] [Log ] [MPMain ] [INFO ] - TvRecorded:OnPlayRecordingBackStopped Recording D:\TV Recordings MP\34 Univision\Cachito de cielo\Cachito de cielo - 2013-08-22.ts[/collapse]

    MP detects that the audio renderer returns shortly afterwards:
    [collapse][2013-08-24 11:12:02,263] [Log ] [MPMain ] [DEBUG] - Main: WM_DEVICECHANGE (Event: DBT_DEVICEARRIVAL)
    [2013-08-24 11:12:02,263] [Log ] [MPMain ] [DEBUG] - Main: Device type is DBT_DEVTYP_DEVICEINTERFACE - Name: Bluetooth Stereo Audio
    [2013-08-24 11:12:02,275] [Log ] [MPMain ] [DEBUG] - Main: WM_DEVICECHANGE (Event: DBT_DEVICEARRIVAL)
    [2013-08-24 11:12:02,275] [Log ] [MPMain ] [DEBUG] - Main: Device type is DBT_DEVTYP_DEVICEINTERFACE - Name: Bluetooth Stereo Audio
    [2013-08-24 11:12:02,275] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer Bluetooth Stereo Audio connected
    [2013-08-24 11:12:02,321] [Log ] [MPMain ] [DEBUG] - Main: WM_DEVICECHANGE (Event: DBT_DEVICEREMOVECOMPLETE)
    [2013-08-24 11:12:02,322] [Log ] [MPMain ] [DEBUG] - Main: Device type is DBT_DEVTYP_DEVICEINTERFACE - Name: Bluetooth Hands-free Audio Device
    [2013-08-24 11:12:02,338] [Log ] [MPMain ] [DEBUG] - Main: WM_DEVICECHANGE (Event: DBT_DEVICEREMOVECOMPLETE)
    [2013-08-24 11:12:02,338] [Log ] [MPMain ] [DEBUG] - Main: Device type is DBT_DEVTYP_DEVICEINTERFACE - Name: Bluetooth Hands-free Audio Device
    [2013-08-24 11:12:02,354] [Log ] [MPMain ] [DEBUG] - Main: WM_DEVICECHANGE (Event: DBT_DEVICEREMOVECOMPLETE)
    [2013-08-24 11:12:02,355] [Log ] [MPMain ] [DEBUG] - Main: Device type is DBT_DEVTYP_DEVICEINTERFACE - Name: Bluetooth Hands-free Audio Device
    [2013-08-24 11:12:02,355] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer Bluetooth Hands-free Audio Device removed
    [2013-08-24 11:12:02,404] [Log ] [MPMain ] [DEBUG] - Main: WM_DEVICECHANGE (Event: DBT_DEVICEARRIVAL)
    [2013-08-24 11:12:02,405] [Log ] [MPMain ] [DEBUG] - Main: Device type is DBT_DEVTYP_DEVICEINTERFACE - Name: Bluetooth Hands-free Audio Device
    [2013-08-24 11:12:02,421] [Log ] [MPMain ] [DEBUG] - Main: WM_DEVICECHANGE (Event: DBT_DEVICEARRIVAL)
    [2013-08-24 11:12:02,421] [Log ] [MPMain ] [DEBUG] - Main: Device type is DBT_DEVTYP_DEVICEINTERFACE - Name: Bluetooth Hands-free Audio Device
    [2013-08-24 11:12:02,438] [Log ] [MPMain ] [DEBUG] - Main: WM_DEVICECHANGE (Event: DBT_DEVICEARRIVAL)
    [2013-08-24 11:12:02,438] [Log ] [MPMain ] [DEBUG] - Main: Device type is DBT_DEVTYP_DEVICEINTERFACE - Name: Bluetooth Hands-free Audio Device
    [2013-08-24 11:12:02,439] [Log ] [MPMain ] [INFO ] - Main: Audio Renderer Bluetooth Hands-free Audio Device connected[/collapse]

    In other words, the reason that playback is stopping is because MP thinks the audio renderer is going away. If there is no renderer to play audio then continuing to attempt to play the recording may cause a crash. So, MP is stopping playback to avoid a crash.

    The way to solve this would be to stop the connection with the bluetooth audio device from dropping out.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    I note...
    There is a setting in MP configuration that relates:
    http://wiki.team-mediaportal.com/1_...guration/11_General/5_Startup_Resume_Settings

    "stop playback on removal of an audio renderer"

    If you untick that, playback will continue. However as previously mentioned, if that is the device that MP is using to play audio then unticking could cause MP to crash.

    Hope that helps. :)
     

    gonzo90017

    Portal Pro
    September 3, 2012
    238
    26
    21
    United States of America United States of America
    Forgot about the bluetooth adapter. I was trying to get bluetooth headphones working for night time listening. :cool:

    The thing is that this never happened with MP 1.4. It just started happening yesterday when I upgraded to 1.5.
    This also (at least until now) has not affected live tv.

    I'll untick the device for now. :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    bta489 [solved] Stuttering playback of edited recordings watch/edit Videos 2
    H MP2 database won't keep in synch with recordings General 1
    toricred Only Show Actual Recordings General 1
    ajs How recreate Recording thumbs TV-Server 4
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    CyberSimian [Proposal] Tool to display time of next recording MediaPortal 1 0
    Golf4 TV-Records werden als Audio-Files importiert ? Allgemeines Support- und Diskussionsforum 0
    R [solved] Unable to delete single recording General 2
    R Correct setting for recordings on shared folder General 0
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    S Shortcuts MP1 My Recorded & TV Guide General 10
    F How to reset tv recordings database General 5
    P Recordings not showing up unless re-imported and not possible to delete General 0
    X Recording import hängt Allgemeines Support- und Diskussionsforum 0
    F Recording starts at second time only MediaPortal 1 Talk 6
    T TV Recording Schedule General 2
    T Unwanted recording Newcomers Forum 18
    bta489 [solved] DVB-T2 Recordings: Sometimes no Audio after muxing with mkvmerge Tools and other software 2
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2
    G Occasional Black screen on Live TV and Recorded TV Watch / Listen Media 5
    B MP 1.23 First time click TV or Recorded TV fails, 2nd ... it will work General Support 5
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    R [solved] MP will not delete recordings that are on NAS Television (MyTV frontend and TV-Server) 23
    U [solved] Beginner needs help recording live TV General 19
    Similar threads

























    Top Bottom