Rework Graphbuilding TV Side (Fix Close Caption / adding correct filter in graph) (1 Viewer)

Status
Not open for further replies.

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,434
    10,256
    France
    France France
    Country flag
    • Thread starter
    • Moderator
    • #1
    Hi,

    I would like to release a public thread in dev section to try to have more feedback on this rework.
    My proposal was to fix somes issues :

    1- Fix connecting filter after mediatype change (i.e switch AC3 to AAC audio).
    2- Fix Closed Caption Subtitle (need CoreCC Parser set in TV Post Process Filter).
    3- Fix Closed Caption Subtitle selection in context Menu (actually stay to off in some condition)
    4- Fix FFDShow Post Processing option (in context menu) after mediatype change.
    5- Rework connection of Post Processing Filter when mediatype change.
    6- Enable Possibility to switch ON/OFF Analog Closed Caption when using FFDShow Decoder.
    7- Possibility to set subtitle OFF by default when starting TV or RecordedTV (Thanks Smeuf).
    8- Possibility to disable Closed Caption Subtitle if not needed (usefull for Europe)

    Related thread :
    Mantis : 0003724: Graphbuilding TV Side (Post Process Fix / Close Caption / adding correct filter in graph) - MediaPortal Bugtracker
    CC : https://forum.team-mediaportal.com/improvement-suggestions-46/north-american-closed-captions-89487/
    Subtitle ON : https://forum.team-mediaportal.com/mediaportal-1-2-0-beta-540/dvb-subtitles-default-97955/

    Binaries attached was for MP 1.2.1 Final :)
    Thanks for feedback :)
     

    Attachments

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,434
    10,256
    France
    France France
    Country flag
    • Thread starter
    • Moderator
    • #2
    Version 46

    • Seems PlayerFactory issue is gone
    • Rework the List of post Processing Filter

    Version 47

    • Add SupportCC for MyVideo
     

    xvffx

    Portal Pro
    August 15, 2007
    313
    53
    Canada Canada
    Thanks,
    will be testing shortly (just doing a clean install)

    if I remember correctly, I have a recorded TV with CC in my video database and to get the cc to work I must first turn on CC via the remote in Live TV channel.

    there's never an option to turn on CC in a TV recorded (TS file) from myvideo

    Vff
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,434
    10,256
    France
    France France
    Country flag
    • Thread starter
    • Moderator
    • #6
    Hi,

    Yep will try to see how to make it work under myvideo, because when opening .ts file, it use tsreaderplayer (like TV) so i think it will possible :)
    Thanks.
     
    Status
    Not open for further replies.

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom