SchedulesDirect plugin downloads only 24 hr of data for most channels (1 Viewer)

2BitSculptor

Super Moderator
  • Team MediaPortal
  • January 23, 2008
    1,906
    449
    South Central Wisconsin
    Home Country
    United States of America United States of America
    @geoffstewart

    I've been using Schedules direct for several years now and have not run into this before.

    About a week ago I moved to Win7 64bit from XP MCE 32bit. Installed MP 1.3 beta and rescanned all my channels. I then installed the SchedulesDirect plugin, forced Guide population, and all 13 days were downloaded on all channels. 2 Days ago I installed MP 1.3 Final, and still had all channels in Guide without rescanning. Then, to test the Channel labeled as 10000 issue, I cleared and rescanned all my channels again. Now, after forcing Guide population, I get only 24 hours of data, except for 3 channels that get 13 days. I've forced Guide population several times, at different times of the day, and each time I still get only 24 hours of data (from the time I force population), again, except for the 3 channels where I get full 13 day data.

    Weird.

    When the wife is off the TV tonight, I will uninstall SchedulesDirect and rescan my channels, then reinstall to see if the last scan somehow messed up the config data file(?) for Guide population.
     

    2BitSculptor

    Super Moderator
  • Team MediaPortal
  • January 23, 2008
    1,906
    449
    South Central Wisconsin
    Home Country
    United States of America United States of America
    • Thread starter
    • Moderator
    • #2
    okay... finally resolved.

    After several attempts at clearing and re scanning my channels, then forcing guide update ... with varying results (not all channels were scanned in correctly - varied by tuner scan), On last try, after I had finally got all my channels scanned correctly (but Guide was incomplete as before) I deactivated the plugin, exported my channels, exited config, and removed the plugin from the TV plugins folder. Then restarted TV config. Imported my Channels (no new scan), saved config. I then added the plugin back in to the TV plugins folder. I restarted TV Config, activated SchedulesDirect and forced the Guide download (it still remembered all my criteria).

    Started MP, waited 10 minutes, and all my channels in the Guide were downloaded correctly.

    Still, not getting all the Guide data has me stumped, but I'm happy it is working now.
     

    Sigpi007

    Portal Pro
    November 14, 2012
    104
    38
    Chicago, IL
    Home Country
    United States of America United States of America
    Hey 2Bit... not sure that you're checking this thread anymore... but just reiterating that I had the same issue just a few days ago. Been modifying the data directly in the database to correct. Definitely seems like something is wrong with the recent version(s) of the SD plugin.
     

    2BitSculptor

    Super Moderator
  • Team MediaPortal
  • January 23, 2008
    1,906
    449
    South Central Wisconsin
    Home Country
    United States of America United States of America
    • Thread starter
    • Moderator
    • #5
    I'm not sure I have the "most recent" version. I've not experienced any issue with the SD plugin or SD since resolving the issue in my previous posts. Still getting 13 days of data. I'm running MP 1.3 final. My SD plugin is set up as it has always been.
     
    Last edited:

    Users who are viewing this thread

    Top Bottom