Shutdown Issues (1 Viewer)

macmr

Portal Pro
August 21, 2011
70
8
Country flag
Hi I upgraded from 1.3.0 to 1.14.0 Pre Release recently and have had a few issues. One I have a log for (attached) is as follows:

PowerScheduler shutdowns the computer at night with tv off and no HDMI signal
Startup next morning finds Mediaportal at reduced screen size and unresponsive
Ctrl+Alt+Del finds Mediaportal as "Not Responding"
Close via Ctrl+Alt+Del and let Mediaportal Watchdog produce file

Hope this is enough info to track down the problem

Thanks
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Thanks for the report - perfect. (y)

    I'll look at the log files and get back to you in the next hour or two. Just having [late] dinner at the moment [here in New Zealand]...
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Okay, so unfortunately the cause of the problem isn't 100% clear because the MediaPortal log level is information rather than debug.

    From the TV Server log I can assemble the power sequence/timing:
    [2016-04-14 06:15:45,422] [Log ] [PowerEventThread] [DEBUG] - OnPowerEvent: PowerStatus: Suspend
    [2016-04-14 15:07:26,676] [Log ] [PowerEventThread] [DEBUG] - OnPowerEvent: PowerStatus: ResumeAutomatic
    [2016-04-14 15:07:39,033] [Log ] [PowerEventThread] [DEBUG] - OnPowerEvent: PowerStatus: ResumeSuspend
    [2016-04-15 00:33:00,427] [Log ] [PowerEventThread] [DEBUG] - OnPowerEvent: PowerStatus: Suspend
    [2016-04-15 00:34:24,338] [Log ] [PowerEventThread] [DEBUG] - OnPowerEvent: PowerStatus: ResumeAutomatic
    [2016-04-15 00:36:13,500] [Log ] [PowerEventThread] [DEBUG] - OnPowerEvent: PowerStatus: Suspend
    [2016-04-15 07:12:04,812] [Log ] [PowerEventThread] [DEBUG] - OnPowerEvent: PowerStatus: ResumeAutomatic
    [2016-04-15 07:12:09,085] [Log ] [PowerEventThread] [DEBUG] - OnPowerEvent: PowerStatus: ResumeSuspend

    When I compare the MediaPortal log:
    [2016-04-14 06:15:46,152] [Log ] [MPMain ] [INFO ] - Main: WM_POWERBROADCAST (PBT_APMSUSPEND)
    [2016-04-14 15:07:26,838] [Log ] [MPMain ] [INFO ] - Main: WM_POWERBROADCAST (PBT_APMRESUMEAUTOMATIC)
    [2016-04-14 15:07:36,850] [Log ] [MPMain ] [INFO ] - Main: WM_POWERBROADCAST (PBT_APMRESUMESUSPEND)
    [2016-04-15 00:33:01,130] [Log ] [MPMain ] [INFO ] - Main: WM_POWERBROADCAST (PBT_APMSUSPEND)
    [2016-04-15 00:34:24,358] [Log ] [MPMain ] [INFO ] - Main: WM_POWERBROADCAST (PBT_APMRESUMEAUTOMATIC)

    ...and so we can see that although MediaPortal hangs/crashes at 07:12:04, the problem actually seems to occur when MediaPortal resumes or suspends on 15 April at either 00:34 or 00:36.

    Due to the log verbosity I can't say much more than this about the problem itself. However I can speculate a little. I'm aware that there is at least one bug in MP 1.14 PR that may cause problems like this. That problem didn't exist in MP 1.13 final and has been fixed for MP 1.14 final. Therefore this problem may correct itself if you switch versions. I could give a more definitive diagnosis and resolution if you could provide new debug-level log files.
     

    macmr

    Portal Pro
    August 21, 2011
    70
    8
    Country flag
    Thanks I have now set the log verbosity to "debug" and the process priority to "normal". If it happens again I will resubmit
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    HTPCSourcer [Finished] [MP2-793] 'Restart MP2' as additional option in shutdown menu Archive 6
    H Shutdown of PC not work IR Server Suite (IRSS) 0
    Rob Hexenmeister Shutdown options General Support 0
    olli14 Power scheduler settings for no shutdown as long as kodi client is online TV-Server 1
    R MP2 GUI Issues General 7
    morpheus_xx [WiP] WIP 2.3 Fanart issues? MediaPortal 2 13
    morpheus_xx [Help Me!] Build issues on TeamCity MediaPortal 2 1
    W Not finding/matching new series - thetvdb issue? My TVSeries 3
    J [fixed] Import issue with alternate movie title matching the name of another movie Submit: Bug Reports 7
    1gkar Latest Intel HD4600 Drivers Issue General Support 1
    J Odd issues with Freesat EPG - MP2 General 18
    DHosein Mediaportal & Antimalware Service High CPU issue General Support 2
    J MediaPortal TV Server and Kodi media source issues General 9
    S Movie navigation issues in MP2 General 8
    cbr954rr Issue BOOTSUWRNQ with online videos? Plugin Development 1
    2BitSculptor MP1.23 release mediainfo issue? MediaPortal 1 Talk 4
    A TV Channel Combination - case issue Television (MyTV frontend and TV-Server) 0
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    G Amazon Prime (Online Videos) Issue Plugin Development 6
    joecrow 1.22.0 MPE Manager issues. 1.22 5
    M [solved] MP2 v 2.2.1 Issue - Registry Key not created General 5
    D [solved] Multiple issues with new MP2.2.1 install 2.2 Archive 7
    S [solved] Live TV subtitle issue if not using 100% font General 31
    T FF or Rewind video issue watch/edit Videos 0
    K server issue OffTopic 0
    Top Bottom