[Solved] I need help for RTMP site (1 Viewer)

laf

Portal Member
August 30, 2013
13
0
Home Country
Canada Canada
I have a problem with a RTMP site configuration. It's working with RTMPDUMP but in MediaPortal, I have a "NoDataAvailable" message. Same message with util="GenericSite" or util="Rtmp" configuration (see logs below).

Any idea of the configuration error or the problem?

***Site configuration***

<Site name="Télé-Québec" util="GenericSite" agecheck="false" enabled="true" lang="fr" lastUpdated="2013-09-01T12:10:54.5565722-04:00">
<Description>Télévision nationale publique du Québec offrant un contenu éducatif et culturel. La section vidéo permet notamment de voir en version intégrale des émissions, documentaires et des vidéos conçues pour le web.</Description>
<Configuration>
<item key="dynamicCategoriesRegEx"><![CDATA[<li><a\shref="(?<url>[^"]*)"\sonclick="return\schangeCategorie\(\s'[^"]*'\s\);">(?<title>[^<]*)</a></li>]]></item>
<item key="videoListRegEx"><![CDATA[<td><div\sclass="listThumb"><a\sclass="listThumbLink"\shref="(?<VideoUrl>[^"]*)"\sonclick="return\ssetVideo\([^\)]*\);"\sonmouseover="showTooltipBox\(event,\sthis,\s[^\)]*\);"\sonmouseout="hideTooltipBox\(event,\sthis\);"\sonmousemove="setTooltipBoxLocation\(event\);"><img\ssrc="(?<ImageUrl>[^"]*)"\salt=""\swidth="160"\sheight="90"><img\sclass="listThumbPlay"\ssrc="/Content/images/gui/play\.png"\swidth="48"\sheight="48"\salt="Lire"></a></div></td>\s*<td><span\sclass="listVideoTitle"><a\shref="[^"]*"\sonclick="return\ssetVideo\([^\)]*\);">(?<Title>[^<]*)</a></span><br>(?<Duration>[^<]*)<br>(?<Airdate>[^<]*)]]></item>
<item key="fileUrlRegEx"><![CDATA[<media\slocation='(?<m0>[^']*)'\sisAd='false'/>]]></item>
<item key="fileUrlFormatString"><![CDATA[{0}&swfurl=http://video.telequebec.tv/video/content/flash/lecteur_av_stq.swf]]></item>
<item key="baseUrl"><![CDATA[http://video.telequebec.tv/]]></item>
</Configuration>

***RTMPDUMP log***

C:\Users\R\Desktop\rtmpdump-1.9>rtmpdump -r rtmp://207.162.84.52/vod1/_defins
t_/14968.flv -s http://video.telequebec.tv/video/content/flash/lecteur_av_stq.sw
f -o out.flv
RTMPDump v1.9
(c) 2009 Andrej Stepanchuk, Howard Chu, The Flvstreamer Team; license: GPL
Connecting ...
Starting download at: 0.000 kB
Metadata:
audiocodecid 2
audiodatarate 96.23
canseektoend FALSE
creationdate Wed Apr 10 10:20:17 2013
duration 783.70
framerate 29.97
height 288
lastkeyframetimestamp 779913
lasttimestamp 783673
metadatacreator On2 Flix SDK for Dshow_2.6.8.0
rating none
title 029
videocodecid 4
videodatarate 705.29
width 512
59849.042 kB / 781.98 sec (99.8%)
Download complete


***OnlineVideos.log***

[09-01 12:17:31,574] [OVInit ] [INFO ] Using language 'fr'
[09-01 12:17:32,050] [OVInit ] [INFO ] Thumbnails will be stored in C:\ProgramData\Team MediaPortal\MediaPortal\Thumbs\OnlineVideos\ with a maximum age of 100 days.
[09-01 12:17:33,539] [OVInit ] [INFO ] Loaded 133 sites from OnlineVideoSites.xml
[09-01 12:17:34,016] [OVInit ] [INFO ] Looking for SiteUtils and Hosters in OnlineVideos (Version: 1.6.1.2835, Compiled: 2013-05-01 14:03:47)
[09-01 12:17:34,088] [OVInit ] [INFO ] Looking for SiteUtils and Hosters in OnlineVideos.Sites.apondman (Version: 2.0.4986.29201, Compiled: 2013-08-26 11:13:22)
[09-01 12:17:34,099] [OVInit ] [INFO ] Looking for SiteUtils and Hosters in OnlineVideos.Sites.brownard (Version: 1.0.0.0, Compiled: 2013-05-08 11:06:20)
[09-01 12:17:34,106] [OVInit ] [INFO ] Looking for SiteUtils and Hosters in OnlineVideos.Sites.corporategadfly (Version: 1.0.2.2835, Compiled: 2013-05-01 14:03:49)
[09-01 12:17:34,110] [OVInit ] [INFO ] Looking for SiteUtils and Hosters in OnlineVideos.Sites.diebagger (Version: 1.0.0.0, Compiled: 2013-08-01 06:47:03)
[09-01 12:17:34,213] [OVInit ] [INFO ] Looking for SiteUtils and Hosters in OnlineVideos.Sites.Dj_Moren (Version: 1.0.0.1, Compiled: 2013-05-01 14:03:49)
[09-01 12:17:34,215] [OVInit ] [INFO ] Looking for SiteUtils and Hosters in OnlineVideos.Sites.doskabouter (Version: 1.0.0.2966, Compiled: 2013-08-29 15:09:48)
[09-01 12:17:34,383] [OVInit ] [INFO ] Looking for SiteUtils and Hosters in OnlineVideos.Sites.hioctane (Version: 1.0.0.0, Compiled: 2013-08-03 13:34:59)
[09-01 12:17:34,385] [OVInit ] [INFO ] Looking for SiteUtils and Hosters in OnlineVideos.Sites.ministerk (Version: 1.0.0.2973, Compiled: 2013-08-31 10:01:22)
[09-01 12:17:34,426] [OVInit ] [INFO ] Looking for SiteUtils and Hosters in OnlineVideos.Sites.offbyone (Version: 1.0.0.2968, Compiled: 2013-08-30 08:48:20)
[09-01 12:17:34,592] [OVInit ] [INFO ] Looking for SiteUtils and Hosters in OnlineVideos.Sites.pilehave (Version: 1.0.0.0, Compiled: 2013-05-16 03:59:34)
[09-01 12:17:34,593] [OVInit ] [INFO ] Looking for SiteUtils and Hosters in OnlineVideos.Sites.rick164 (Version: 1.0.0.0, Compiled: 2013-08-25 14:42:48)
[09-01 12:17:34,595] [OVInit ] [INFO ] Looking for SiteUtils and Hosters in OnlineVideos.Sites.SilentException (Version: 1.0.0.0, Compiled: 2013-05-01 14:03:51)
[09-01 12:17:34,597] [OVInit ] [INFO ] Looking for SiteUtils and Hosters in OnlineVideos.Sites.SK_CZ (Version: 1.5.0.2835, Compiled: 2013-05-01 14:03:48)
[09-01 12:17:34,602] [OVInit ] [INFO ] Looking for SiteUtils and Hosters in OnlineVideos.Sites.titof (Version: 1.0.0.0, Compiled: 2013-05-01 14:03:49)
[09-01 12:17:34,605] [OVInit ] [INFO ] Found 162 SiteUtils and 56 Hosters in 15 assemblies
[09-01 12:17:34,929] [OVInit ] [WARN ] SiteUtil with name: YahooMusicVideos not found!
[09-01 12:17:35,530] [OVInit ] [INFO ] Created 132 SiteUtils
[09-01 12:17:36,428] [OVLatest ] [INFO ] LatestVideosManager getting new data from SiteUtils.
[09-01 12:17:37,819] [OVLatest ] [INFO ] LatestVideosManager found 3 videos from 1 SiteUtils.
[09-01 12:18:01,822] [MPMain ] [INFO ] DoPageLoad with CurrentState 'groups', PreviousWindowId '0'

***For GenericSite configuration***

[09-01 12:18:08,825] [OnlineVideos] [INFO ] Looking for dynamic categories for site 'Télé-Québec'
[09-01 12:18:09,388] [OnlineVideos] [INFO ] Found 87 dynamic categories for site 'Télé-Québec'
[09-01 12:18:22,143] [MPMain ] [INFO ] Preparing graph for playback of

'rtmp://207.162.84.52/vod1/_definst_/14968.flv&swfurl=http://video.telequebec.tv/video/content/flash/lecteur_av_stq.swf'
[09-01 12:18:23,609] [OnlineVideos] [INFO ] Start prebuffering ...
[09-01 12:18:44,239] [OnlineVideos] [WARN ] System.Runtime.InteropServices.COMException (0xFFFFFFEC): Exception de HRESULT : 0xFFFFFFEC
à System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
à OnlineVideos.MediaPortal1.Player.OnlineVideosPlayer.BufferFile()
[09-01 12:18:44,242] [OnlineVideos] [INFO ] Buffering was aborted.
[09-01 12:18:45,121] [OnlineVideos] [WARN ] OnlineVideos.OnlineVideosException: NoDataAvailable
à OnlineVideos.MediaPortal1.Player.OnlineVideosPlayer.BufferFile()
à OnlineVideos.MediaPortal1.GUIOnlineVideos.<>c__DisplayClass80.<Play_Step4>b__7c()
à OnlineVideos.MediaPortal1.Gui2UtilConnector.<>c__DisplayClass5.<ExecuteInBackgroundAndCallback>b__2()

***For Rtmp configuration***

[09-01 12:18:52,396] [OnlineVideos] [INFO ] Looking for dynamic categories for site 'telequebec.tv'
[09-01 12:18:52,406] [OnlineVideos] [INFO ] Found 87 dynamic categories for site 'telequebec.tv'
[09-01 12:18:59,195] [MPMain ] [INFO ] Preparing graph for playback of 'rtmp://207.162.84.52####Url=rtmp%3a%2f%2f207.162.84.52%2fvod1%2f_definst_%2f14968.flv%26swfurl%3dhttp%3a%2f

%2fvideo.telequebec.tv%2fvideo%2fcontent%2fflash%2flecteur_av_stq.swf&'
[09-01 12:19:00,263] [OnlineVideos] [INFO ] Start prebuffering ...
[09-01 12:19:20,896] [OnlineVideos] [WARN ] System.Runtime.InteropServices.COMException (0xFFFFFFEC): Exception de HRESULT : 0xFFFFFFEC
à System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
à OnlineVideos.MediaPortal1.Player.OnlineVideosPlayer.BufferFile()
[09-01 12:19:20,899] [OnlineVideos] [INFO ] Buffering was aborted.
[09-01 12:19:21,680] [OnlineVideos] [WARN ] OnlineVideos.OnlineVideosException: NoDataAvailable
à OnlineVideos.MediaPortal1.Player.OnlineVideosPlayer.BufferFile()
à OnlineVideos.MediaPortal1.GUIOnlineVideos.<>c__DisplayClass80.<Play_Step4>b__7c()
à OnlineVideos.MediaPortal1.Gui2UtilConnector.<>c__DisplayClass5.<ExecuteInBackgroundAndCallback>b__2()
 
Last edited:

offbyone

Development Group
  • Team MediaPortal
  • April 26, 2008
    3,989
    3,711
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    We need MpUrlSourceSplitter.log to know what the connection problem is.
    I am guessing you must specify the swf url in Configuration for SWF Verification to work.
     

    laf

    Portal Member
    August 30, 2013
    13
    0
    Home Country
    Canada Canada
    We need MpUrlSourceSplitter.log to know what the connection problem is.
    I am guessing you must specify the swf url in Configuration for SWF Verification to work.


    Here's the MpUrlSourceSplitter.log for those events.
     

    laf

    Portal Member
    August 30, 2013
    13
    0
    Home Country
    Canada Canada
    In the log you'll find that the connection is already rejected.
    I would say do not add the "&swfurl=http://video.telequebec.tv/video/content/flash/lecteur_av_stq.swf" to the actual Url but set it as parameter in the configuration values (and use the rtmputil).

    With the rtmputil, I change:
    <item key="fileUrlRegEx"><![CDATA[<media\slocation='(?<m0>[^']*)'\sisAd='false'/>]]></item>
    <item key="fileUrlFormatString"><![CDATA[{0}&swfurl=http://video.telequebec.tv/video/content/flash/lecteur_av_stq.swf]]></item>
    <item key="baseUrl"><![CDATA[http://video.telequebec.tv/]]></item>

    for:
    <item key="fileUrlRegEx"><![CDATA[<media\slocation='(?<m0>[^']*)'\sisAd='false'/>]]></item>
    <item key="fileUrlFormatString"><![CDATA[{0}]]></item>
    <item key="swfUrl"><![CDATA[http://video.telequebec.tv/video/content/flash/lecteur_av_stq.swf]]></item>
    <item key="baseUrl"><![CDATA[http://video.telequebec.tv/]]></item>

    Same result...

    In the MpUrlSourceSplitter.log, I dont see any reference to the swfUrl parameter.
     

    chesstu

    New Member
    September 18, 2013
    2
    0
    42
    Home Country
    Canada Canada
    Hi laf :)
    I was looking to rtmpdump telequebec as well. When I try your rtmp terminal line, it does indeed work.

    So my question is how did you get the swf file and the rtmp://207... adress ? How can I retreive theses info from the bowser ??

    Thank you very much :)

    example from your fist post:

    ***For GenericSite configuration***

    [09-01 12:18:08,825] [OnlineVideos] [INFO ] Looking for dynamic categories for site 'Télé-Québec'
    [09-01 12:18:09,388] [OnlineVideos] [INFO ] Found 87 dynamic categories for site 'Télé-Québec'
    [09-01 12:18:22,143] [MPMain ] [INFO ] Preparing graph for playback of

    'rtmp://207.162.84.52/vod1/_definst_/14968.flv&swfurl=http://video.telequebec.tv/video/content/flash/lecteur_av_stq.swf'
    [09-01 12:18:23,609] [OnlineVideos] [INFO ] Start prebuffering ...
    [09-01 12:18:44,239] [OnlineVideos] [WARN ] System.Runtime.InteropServices.COMException (0xFFFFFFEC): Exception de HRESULT : 0xFFFFFFEC
    à System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
    à OnlineVideos.MediaPortal1.Player.OnlineVideosPlayer.BufferFile()
    [09-01 12:18:44,242] [OnlineVideos] [INFO ] Buffering was aborted.
    [09-01 12:18:45,121] [OnlineVideos] [WARN ] OnlineVideos.OnlineVideosException: NoDataAvailable
    à OnlineVideos.MediaPortal1.Player.OnlineVideosPlayer.BufferFile()
    à OnlineVideos.MediaPortal1.GUIOnlineVideos.<>c__DisplayClass80.<Play_Step4>b__7c()
    à OnlineVideos.MediaPortal1.Gui2UtilConnector.<>c__DisplayClass5.<ExecuteInBackgroundAndCallback>b__2()

    ***For Rtmp configuration***

    [09-01 12:18:52,396] [OnlineVideos] [INFO ] Looking for dynamic categories for site 'telequebec.tv'
    [09-01 12:18:52,406] [OnlineVideos] [INFO ] Found 87 dynamic categories for site 'telequebec.tv'
    [09-01 12:18:59,195] [MPMain ] [INFO ] Preparing graph for playback of 'rtmp://207.162.84.52####Url=rtmp%3a%2f%2f207.162.84.52%2fvod1%2f_definst_%2f14968.flv%26swfurl%3dhttp%3a%2f

    %2fvideo.telequebec.tv%2fvideo%2fcontent%2fflash%2flecteur_av_stq.swf&'
    [09-01 12:19:00,263] [OnlineVideos] [INFO ] Start prebuffering ...
    [09-01 12:19:20,896] [OnlineVideos] [WARN ] System.Runtime.InteropServices.COMException (0xFFFFFFEC): Exception de HRESULT : 0xFFFFFFEC
    à System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
    à OnlineVideos.MediaPortal1.Player.OnlineVideosPlayer.BufferFile()
    [09-01 12:19:20,899] [OnlineVideos] [INFO ] Buffering was aborted.
    [09-01 12:19:21,680] [OnlineVideos] [WARN ] OnlineVideos.OnlineVideosException: NoDataAvailable
    à OnlineVideos.MediaPortal1.Player.OnlineVideosPlayer.BufferFile()
    à OnlineVideos.MediaPortal1.GUIOnlineVideos.<>c__DisplayClass80.<Play_Step4>b__7c()
    à OnlineVideos.MediaPortal1.Gui2UtilConnector.<>c__DisplayClass5.<ExecuteInBackgroundAndCallback>b__2()[/quote]
     

    laf

    Portal Member
    August 30, 2013
    13
    0
    Home Country
    Canada Canada
    Hi laf :)
    I was looking to rtmpdump telequebec as well. When I try your rtmp terminal line, it does indeed work.

    So my question is how did you get the swf file and the rtmp://207... adress ? How can I retreive theses info from the bowser ??

    Thank you very much :)

    The website Télé-Québec was totally changed on September 9 and they also changed the media server. The new RTMP server is located at the following address: "rtmpe://s2.csl.delvenetworks.com:1935/a4820/l1/". But the problem now is that I am not able to find a way to identify in the web pages the name of MP4 file. Big problem...
     

    chesstu

    New Member
    September 18, 2013
    2
    0
    42
    Home Country
    Canada Canada
    So the RTMPDumpHelper isn't of any use anymore with the new site or it will help me find the links for rtmpdump still ??
    Hope the XBMC teams comes up with something !!!
     

    Users who are viewing this thread

    Similar threads

    this seems to be related to the Ares skin. It can be somewhat fixed by replacing the mytvrecordedtv.xml with the one found in the DefaultWide skin. It really messes up the overlays though.
    this seems to be related to the Ares skin. It can be somewhat fixed by replacing the mytvrecordedtv.xml with the one found in the...
    For the past year or so I have not been able to get into my TV recordings menu. MediaPortal wont crash, but it just hangs and...
    Replies
    1
    Views
    695
    This issue seems have been rectified as all the previously unavailable videos are now watchable.
    This issue seems have been rectified as all the previously unavailable videos are now watchable.
    Hi all If this has been covered elsewhere, sorry I searched, please point me to the right place :) I saw a lot of posts about...
    Replies
    6
    Views
    2K
    Site is fixed, still a few hosters to be fine tuned, Vodlocker seems to be the best after tests. Please remember links get deleted fast for popular movies. Thank you[
    Site is fixed, still a few hosters to be fine tuned, Vodlocker seems to be the best after tests. Please remember links get deleted...
    Hi there, Just want to report that Movie25 site in Online Videos is broken again. It seems that the site content has changed...
    Replies
    2
    Views
    2K
    Ah ok. Its not such a big deal. The videos from 3sat are also in the zdf mediathek and as mentioned before it is possible to play the videos with an external player (vlc).
    Ah ok. Its not such a big deal. The videos from 3sat are also in the zdf mediathek and as mentioned before it is possible to play...
    I have this problem with Demuxer Not Created All Data Received and it just started on Online Videos The Log file says this: 02-08...
    Replies
    3
    Views
    1K
    Are you running the latest version of OV? From your logs looks like you are using an old version so you might be right about it not searching for PS3 streams. Try updating the plugin/site.
    Are you running the latest version of OV? From your logs looks like you are using an old version so you might be right about it not...
    Maybe it's just me but I've not been able to play any videos from 4oD recently, other sites work fine and the log suggests that LAV...
    Replies
    3
    Views
    1K
    Top Bottom