Codecs Subtitles using ... well, anything (1 Viewer)

vomov

Portal Member
April 4, 2010
13
0
Netherlands Netherlands
I've been using an intel desktop board DM2800MT as a low-power HTPC. Due to the Intel GMA nonsense, it is an incredible pain to work with, but I've got something that performs pretty well.
After some initial 'hiccups', which resulted in usage of the term 'impact electronics', as well as some foul language, I've got it playing practically everything.

The main use, however, is HD (720p and 1080p) video using H264. I've got it playing using several methods:
  1. Using FFDshow, no DXVA. Quite a bit of stutter in fast detail-heavy scenes, but works better than I expected. Not really fun to watch The Matrix like that, though.
  2. Using FFDshow, DXVA. No problems, and an energy usage a bit south of 6W during play. Which is awesome.
  3. Using LAV, same behaviour as FFDshow with DXVA.
  4. Using a borrowed Broadcom Crystal HD BCM970015. No problems, same energy usage. I need to return this soon, though.
The problem, however, are the subtitles. Mediaportal supports several methods, with varying degrees of succes.
  • DirectVobSub simply crashes. I've not explored this avenue further, since I've had better succes with the other methods.
  • The built-in MPC-HC subtitle thingy does work with method 2 (but not with 3 or 4), but does not always show the correct line. For example; I'm simply watching a movie, and it shows several lines of subtitle without a problem, and then suddenly shows a line that's supposed to appear half a minute later or earlier, and it seems to 'clip' the line based on the expected line length of the line it's supposed to show. For example, if I'm watching The Matrix, and the line I'm expecting is "It's Cold." (from when Neo is sitting in the chair and has just touched the mirror), I get part of a different line, like "he blue pill". When starting a movie somewhere in the middle (resuming etc.) it also has a tendency to show a random line from the movie. If I could fix this, I'd be blissfully happy, since that's the only problem I have.
  • The FFDshow subtitle overlay works perfectly with the normal FFDshow (1, no DXVA), but gives artifacts when used with the DXVA version (2) and the LAV one (3), but doesn't work with the Crystal HD thingy (4). The artifacts I'm talking about are detailed in bug 186 here, with an example of the artifacts.
Ideally, I'd like to get rid of the artifacts in the FFDshow subtitle overlay, since this has more options. However, it's plausible that the MPC-HC subtitle thingy is easier to fix.

Can anyone offer any insight into where these problems originate from, or perchance even how to fix them?
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
S [solved] Live TV subtitle issue if not using 100% font General 31
mickb Subtitles My TVSeries 4
M.Hulot Blu-ray: Es werden nicht nur Forced Subtitles angezeigt Allgemeines Supportforum 1
J How to change y position of subtitles General 2
R [will not fix] [MP2-832] MP2.2.2 subtitles not shown for WTV files Submit: Bug Reports 7
S Remote button to change audio and subtitle on / off General 10
P [solved] ATSC subtitles not fixed yet? General 2
E Swedish subtitles problem General 2
ratata Someone stole my subtitles... General Support 0
Dark Eyes Display subtitles on a separate display or device MediaPortal 1 Plugins 0
R [solved] Command / Shortcut for changing subtitles or audio Archive 5
K Multichannel audio and subtitles for TV not properly supported General Support 4
S Display non english folder name, subtitle, etc. General 23
S [solved] Movie SRT subtitle didn't display on client 2.2 Archive 18
D [solved] How to configure subtitle color in MP 2.2.1? General 5
S [fixed] [MP2-611] Teletext subtitles language selection 2.2 Archive 20
G [fixed] [MP2-611] Having problems with subtitles (ATSC) 2.2 Archive 14
S Australia live TV teletext subtitle General 4
toricred Using TMM, How to Stop Importer From Going to The Movie Database for Data General 1
morpheus_xx [WiP] OnlineVideos: New browser based playback support using WebDriver, new Amazon siteutil MediaPortal 2 6
toricred [solved] Configuring TV Server to use NAS General 1
vvulture Using Windows 10 MediaPortal 1 Talk 8
atlantic How to use Spotify inside Mediaportal? Listen Music 18
Megane Too much RAM used (over 2 GB). General Support 18
doskabouter 1.23.0 MatroskaTagInfo uses the wrong casing for tags Bugreports 27
Similar threads

























Top Bottom