Trailers Plugin v1.2.2 (Play/Stream/DL for MovingPictures, My Films, My Videos..) [2015-04-11] | Page 14

Discussion in 'MediaPortal 1 Plugins' started by ltfearme, November 4, 2013.

  1. D3ltoroxp
    • Premium Supporter

    D3ltoroxp MP Donator

    Joined:
    June 1, 2008
    Messages:
    3,308
    Likes Received:
    133
    Gender:
    Male
    Ratings:
    +207 / 9
    Home Country:
    Germany Germany
    Show System Specs
    Did you make Skinfiles for Titan ? I will try it at my on way. So what xml i need for adding the ID ? For now i play the Trailers in detail view so i need this one ?? This one ShowTimesGUI.details.xml ??


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. D3ltoroxp
    • Premium Supporter

    D3ltoroxp MP Donator

    Joined:
    June 1, 2008
    Messages:
    3,308
    Likes Received:
    133
    Gender:
    Male
    Ratings:
    +207 / 9
    Home Country:
    Germany Germany
    Show System Specs
    Is there a way that you can use this filmstarts.de for german trailer source ?
     
  4. ltfearme
    • Premium Supporter

    ltfearme Community Plugin Dev

    Joined:
    June 10, 2007
    Messages:
    6,447
    Likes Received:
    4,227
    Gender:
    Male
    Occupation:
    Software Test Engineer
    Location:
    Sydney
    Ratings:
    +5,365 / 0
    Home Country:
    Australia Australia
    I will only consider adding a site which has an API that contains a url to the video.
     
    • Like Like x 1
  5. D3ltoroxp
    • Premium Supporter

    D3ltoroxp MP Donator

    Joined:
    June 1, 2008
    Messages:
    3,308
    Likes Received:
    133
    Gender:
    Male
    Ratings:
    +207 / 9
    Home Country:
    Germany Germany
    Show System Specs
    hm k, so i think because this answer there is no api. I don't know how it works in onlinevideos, but there is the site active...

    Another think, alternative, can i preferd a youtube channel for trailer search ? Or search the plugin the complet youtube network for the trailer ?
     
  6. D3ltoroxp
    • Premium Supporter

    D3ltoroxp MP Donator

    Joined:
    June 1, 2008
    Messages:
    3,308
    Likes Received:
    133
    Gender:
    Male
    Ratings:
    +207 / 9
    Home Country:
    Germany Germany
    Show System Specs
    Hello lt, its me again, i have add the trailers button to showtimes but when i do this, there are no data showen in the main gui window from showtimes, where normaly the covers from the actual movies is. Did i something wrong ?

    Code (XML):
    1. <!-- Trailers Button (Plugin) -->
    2. <control>
    3. <description>Play Button</description>
    4. <type>button</type>
    5. <id>11899</id>
    6. <label>#Trailers.Translation.Trailers.Label</label>
    7. <onleft>11899</onleft>
    8. <onright>11899</onright>
    9. <onup>43</onup>
    10. <ondown>40</ondown>
    11. <textureFocus>myvideos_play_focus.png</textureFocus>
    12. <textureNoFocus>myvideos_play_nofocus.png</textureNoFocus>
    13. <textcolor>FF000000</textcolor>
    14. <textcolorNoFocus>ffffffff</textcolorNoFocus>
    15. <visible>plugin.isenabled(Trailers)</visible>
    16. </control>
    17. <!-- Traliers Button (Plugin) -->
     
  7. ltfearme
    • Premium Supporter

    ltfearme Community Plugin Dev

    Joined:
    June 10, 2007
    Messages:
    6,447
    Likes Received:
    4,227
    Gender:
    Male
    Occupation:
    Software Test Engineer
    Location:
    Sydney
    Ratings:
    +5,365 / 0
    Home Country:
    Australia Australia
    Yes, you probably did something wrong. Im not sure how I can help you with only that information.

    Check if there is already a trailers button with ID:11899 defined in the main GUI. If you are trying to add the button to the Detail window, remember that ShowTimes does not use a seperate window so you need to ensure the Trailer button is unique otherwise the navigation will become screwed if placing two buttons in the same window. For Plugins which like to use the same WindowID like ShowTimes I have provided multiple IDs that can be used for the trailer button. You can quickly test by replacing 11899 with 11900 in the above code:
    Code (Text):
    1.  
    2. <id>11900</id>
    3. <label>#Trailers.Translation.Trailers.Label</label>
    4. <onleft>11900</onleft>
    5. <onright>11900</onright>
    6.  
    If you want more help, remember in future to post log files and all the skin files for the relevant window. You can use 11899 in the main gui view and 11900 in the details view.
     
    • Thank You! Thank You! x 1
  8. D3ltoroxp
    • Premium Supporter

    D3ltoroxp MP Donator

    Joined:
    June 1, 2008
    Messages:
    3,308
    Likes Received:
    133
    Gender:
    Male
    Ratings:
    +207 / 9
    Home Country:
    Germany Germany
    Show System Specs
    Sorry for the missing infos and files here they are. I used it with other id's but the same. One thing is strange, when i run mepo and change the detail.xml than i have the button and it seems to be working fine, it comes the window with the found trailers. But when i close MP and start it again its broken now covers showen...
     

    Attached Files:

  9. ltfearme
    • Premium Supporter

    ltfearme Community Plugin Dev

    Joined:
    June 10, 2007
    Messages:
    6,447
    Likes Received:
    4,227
    Gender:
    Male
    Occupation:
    Software Test Engineer
    Location:
    Sydney
    Ratings:
    +5,365 / 0
    Home Country:
    Australia Australia
    @D3ltxoroxp,

    You have removed a mandatory control required by ShowTimes:
    Code (Text):
    1.  
    2. [2015-07-10 12:25:51,516] [Log  ] [MPMain  ] [WARN ] - GUIWindow:OnWindowLoaded: 'C:\ProgramData\Team MediaPortal\MediaPortal\Skin\TITANIUS\ShowTimesGUI.xml' is missing control id 41 (window property: btnPlayTrailer)
    3. [2015-07-10 12:25:51,565] [Log  ] [MPMain  ] [DEBUG] - Window: MediaPortal.GUI.ShowTimesGUI.ShowTimesGUI init
    4. [2015-07-10 12:25:51,566] [Error  ] [MPMain  ] [ERROR] - OnMessage exception:System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
    5.   bei MediaPortal.GUI.ShowTimesGUI.ShowTimesGUI.HideMovieControls(Boolean hideposter)
    6.   bei MediaPortal.GUI.ShowTimesGUI.ShowTimesGUI.OnPageLoad()
    7.   bei MediaPortal.GUI.Library.GUIWindow.OnMessage(GUIMessage message)
    8.  
    Showtimes has a Trailer button as well with ID 41, you can make it conditionally visible if the Trailers plugin is not installed.

    I am also surprised you have not picked up on the fact that MediaPortal is not shutting down correctly!!! You should take a look at why this occurs:
    Code (Text):
    1.  
    2. [2015-07-10 12:26:10,179] [Log  ] [MPMain  ] [ERROR] - Exception: System.UnauthorizedAccessException: Der Zugriff auf den Pfad "C:\Program Files (x86)\Team MediaPortal\MediaPortal\MediaPortal.xml" wurde verweigert.
    3.   bei System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    4.   bei System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
    5.   bei System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
    6.   bei System.IO.StreamWriter.CreateFile(String path, Boolean append, Boolean checkHost)
    7.   bei System.IO.StreamWriter..ctor(String path, Boolean append, Encoding encoding, Int32 bufferSize, Boolean checkHost)
    8.   bei System.IO.StreamWriter..ctor(String path, Boolean append)
    9.   bei MediaPortal.Profile.XmlSettingsProvider.Save()
    10.   bei MediaPortal.Profile.CacheSettingsProvider.Save()
    11.   bei MediaPortal.Profile.Settings.SaveCache()
    12.   bei MediaPortalApp.Main(String[] args)  Message: Der Zugriff auf den Pfad "C:\Program Files (x86)\Team MediaPortal\MediaPortal\MediaPortal.xml" wurde verweigert.  Site  : Void WinIOError(Int32, System.String)  Source : mscorlib  Stack Trace:  bei System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    13.   bei System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
    14.   bei System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
    15.   bei System.IO.StreamWriter.CreateFile(String path, Boolean append, Boolean checkHost)
    16.   bei System.IO.StreamWriter..ctor(String path, Boolean append, Encoding encoding, Int32 bufferSize, Boolean checkHost)
    17.   bei System.IO.StreamWriter..ctor(String path, Boolean append)
    18.   bei MediaPortal.Profile.XmlSettingsProvider.Save()
    19.   bei MediaPortal.Profile.CacheSettingsProvider.Save()
    20.   bei MediaPortal.Profile.Settings.SaveCache()
    21.   bei MediaPortalApp.Main(String[] args)
    22.  
    You should ensure that the user that invokes MediaPortal has write access to MediaPortal.xml. For some reason it looks like the directory is C:\Program Files (x86)\Team MediaPortal\MediaPortal. The default directory is C:\ProgramData\Team MediaPortal\MediaPortal.\
     
    Last edited: July 11, 2015
    • Thank You! Thank You! x 1
  10. D3ltoroxp
    • Premium Supporter

    D3ltoroxp MP Donator

    Joined:
    June 1, 2008
    Messages:
    3,308
    Likes Received:
    133
    Gender:
    Male
    Ratings:
    +207 / 9
    Home Country:
    Germany Germany
    Show System Specs
    Yes i delet the id 41 and put there your id ? So this is wrong ? How can i use then your button, when the other is still there ?

    Can ou give me the visible line ?

    So i understand it right, i must create 2 buttons, and when your plugin is installed, the other button is hidden by the visible line ?

    Hm normaly my user has admin rights on this system, and the xml is on program data.

    EDIT :: This one for the trailers button ?

    Code (XML):
    1. <visible>plugin.isenabled(Trailers)</visible>
    and then i need one for the showtimes button to hide, if trailers are activate ?

    Something like this ::

    Code (XML):
    1. <control>
    2. <description>Play Button</description>
    3. <type>button</type>
    4. <id>41</id>
    5. <label>-</label>
    6. <onleft>41</onleft>
    7. <onright>41</onright>
    8. <onup>43</onup>
    9. <ondown>40</ondown>
    10. <textureFocus>myvideos_play_focus.png</textureFocus>
    11. <textureNoFocus>myvideos_play_nofocus.png</textureNoFocus>
    12. <textcolor>FF000000</textcolor>
    13. <textcolorNoFocus>ffffffff</textcolorNoFocus>
    14. <visible allowhiddenfocus="true">control.isvisible(11901)</visible>
    15. </control>
    16. <!-- Trailers Button, wird gezeigt wenn das Plugin installiert ist ansonsten wird der Standard genutzt. -->
    17. <control>
    18. <description>Play Button</description>
    19. <type>button</type>
    20. <id>11901</id>
    21. <label>#Trailers.Translation.Trailers.Label</label>
    22. <onleft>11901</onleft>
    23. <onright>11901</onright>
    24. <onup>43</onup>
    25. <ondown>40</ondown>
    26. <textureFocus>myvideos_play_focus.png</textureFocus>
    27. <textureNoFocus>myvideos_play_nofocus.png</textureNoFocus>
    28. <textcolor>FF000000</textcolor>
    29. <textcolorNoFocus>ffffffff</textcolorNoFocus>
    30. <visible>plugin.isenabled(Trailers)</visible>
    31. </control>
     
    Last edited: July 11, 2015
  11. kiwijunglist
    • Team MediaPortal

    kiwijunglist Super Moderator

    Joined:
    June 10, 2008
    Messages:
    6,741
    Likes Received:
    1,416
    Occupation:
    Doctor
    Location:
    New Zealand
    Ratings:
    +1,845 / 9
    Home Country:
    New Zealand New Zealand
    Show System Specs
    Feature Request / Bug Report:

    Sometimes i get incomplete trailers. I suspect this is because of either an internet connection timeout error or perhaps exiting or alt+f4'ing mediaportal while a trailer is downloading. Is there a way that trailers could check that the trailer has downloaded correctly? I'm guessing the frequency of this happening might be about 1in20 to 1in40.

    An example trailer that didn't download properly is Aloha (2015) - http://www.imdb.com/title/tt1243974/

    Logs attached:

    Questions:

    1. If I delete an incomplete trailer video file will trailers plugin attempt to re-download the file?

    2. If I am reformatting my HDD is it enough to just backup the trailer folder and then trailers plugin will automatically pick up what is already downloaded or do I need to backup the database files as well?
     
    Last edited: August 15, 2015
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!