WebEPG - Problem mapping Channel id FSN+ (special character) to siteId FSDPLUS

Discussion in 'TV-Server Plugins' started by Ann Smedes, June 27, 2016.

  1. Ann Smedes

    Ann Smedes New Member

    Joined:
    June 27, 2016
    Messages:
    3
    Likes Received:
    0
    Gender:
    Female
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    It seems that WebEPG has an issue with the "+" symbol and will not grab the channels from my imdb xml file. Any ideas on how to fix this? I tried entering the Channel id as FSNPLUS - this didn't work.
    I read about the issue with the "&" symbol and how to fix, but I need a solution for the "+" symbol.
    Thank you,
    Ann


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,518
    Likes Received:
    4,729
    Ratings:
    +8,195 / 17
    Home Country:
    New Zealand New Zealand
    Welcome Ann :)

    Try replacing the + with %2B.
    If that also doesn't work, try %252B.
     
  4. Ann Smedes

    Ann Smedes New Member

    Joined:
    June 27, 2016
    Messages:
    3
    Likes Received:
    0
    Gender:
    Female
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    neither of these worked :(
     
  5. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,518
    Likes Received:
    4,729
    Ratings:
    +8,195 / 17
    Home Country:
    New Zealand New Zealand
    Okay, what's your zipcode please?
    (I need to know so that I can try to reproduce the problem and find a solution.)
     
  6. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,518
    Likes Received:
    4,729
    Ratings:
    +8,195 / 17
    Home Country:
    New Zealand New Zealand
    Based on the info here:
    http://www.foxsports.com/north/story/fox-sports-north-plus-channel-information-011214

    ...I selected a random MN zip code (55404), then looked up the Comcast listings for that area:
    http://www.imdb.com/tvgrid/2016-06-...N22623&start_date=2016-06-29&start_time=2000#

    According to the first link, FSN Plus is channel 254. I found it as "FSNO1P":
    http://www.imdb.com/tvgrid/2016-06-29/FSNO1P/

    As you can see, the siteId for that channel would be FSNO1P. Therefore I don't understand why you'd need a plus symbol. :confused:
     
  7. Ann Smedes

    Ann Smedes New Member

    Joined:
    June 27, 2016
    Messages:
    3
    Likes Received:
    0
    Gender:
    Female
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    my zip is 48082 I have Wow Cable the Channel id=FSN+ and the siteId=FSDPLUS
    --- Post updated ---
    FSN+ is the channel that my tuner cards find, WebEPG doesn't seem to understand it or can't translate it to FSDPLUS, because it won't grab listings.
    --- Post updated ---
    it's similar to the H&I channel, but I believe that I have found the solution..is to change it to H&ampI for the Channel id in the xml file, tho I haven't tested that yet.
     
  8. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,518
    Likes Received:
    4,729
    Ratings:
    +8,195 / 17
    Home Country:
    New Zealand New Zealand
    Okay, thanks.

    I set up WebEPG with a couple of test channels - including FSN+ - on my TV Server, but I'm not able to reproduce the problem. Guide data grabbed no problem:
    upload_2016-7-1_23-55-56.png


    Therefore I think you've made some mistakes when configuring WebEPG.

    No, it's actually nothing like that. Ampersand (&) is a special character in XML, whereas plus (+) is not.


    I suggest you double-check that you've followed the instructions in the setup guide properly:
    http://wiki.team-mediaportal.com/1_...ides/2_TV_Setup/4_TV_Guide_Setup_(EPG)/WebEPG

    Important points:
    1. Make sure you restarted the TV service after enabling the WebEPG plugin.
    2. Your www_imdb_com.xml file should contain lines like this:
    <Channel id="FSN+" siteId="FSDPLUS" />
    <Channel id="FXHD" siteId="FXHD" />

    Those lines should be between the <Channels> and </Channels> lines.
    Also, you should have entered your zip code. The line:
    <Site url="http://www.imdb.com/tvgrid/[YYYY]-[MM]-[DD]/[ID]&amp;start_date=[YYYY]-[MM]-[DD]/?zip=ZIPCODE" post="" external="false" encoding="" />

    ...changes to:
    <Site url="http://www.imdb.com/tvgrid/[YYYY]-[MM]-[DD]/[ID]&amp;start_date=[YYYY]-[MM]-[DD]/?zip=48082" post="" external="false" encoding="" />

    3. TV Server Config -> plugins -> WebEPG -> General tab -> Auto Mapping section -> Country setting should be set to "United States".
    4. TV Server Config -> plugins -> WebEPG -> TV Mappings tab...
    Select your channel group (eg. "All Channels") up the top and click "import". This should populate the list of channels below.
    If you correctly set the "id" field in the www_imdb_com.xml file to exactly match your channel names then you should just be able to click "auto map" to link the guide channels to TV Server's channels:
    upload_2016-7-2_0-1-11.png

    Even if that doesn't work (eg. you made a typing error), you can still manually fix the mappings using the "mapping details" section down the bottom (select the channel you want to fix in the top list, in the "mapping details" section on the "single" tab click "...", expand "web sites", expand "United States", expand "www.imdb.com", select the guide channel, click "select").

    5. Very VERY IMPORTANT: TV Server Config -> plugins -> WebEPG -> General tab: CLICK SAVE (down the bottom).
    6. Now you should be able to click "grab now!", and it should just work.


    If it still doesn't work and you're stuck, please attach:
    1. Your WebEPG config (www_imdb_com.xml file).
    2. Screenshots of the WebEPG plugin General and TV Mappings tabs.
    3. Your TV Server log files. (You can find them by clicking "open log directory" in the top left corner of TV Server Config. Please zip all the files in that folder, then attach the zip file.)
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!