[solved] When playing music Fanart does not shuffle (1 Viewer)

horned_reaper

Test Group
  • Team MediaPortal
  • January 7, 2011
    1,153
    411
    Munich
    Germany Germany
    Country flag
    FH runs excellent now!
    Just a minor issue I found with multi-artists tracks:
    1. A multi-artist track is played, for both artists Fanarts already exist in the database.
    2. The Fanarts of the first artist are displayed.
    3. FH starts to download pictures for the second artist.
    4. The new Fanarts of the second artist are shown successively.
    5. The Fanarts of the first artist are shown successively.
    6. The new Fanarts of the second artist are shown successively.
    7. ... and so on.
    The expected result would be that the Fanarts of both artists are displayed randomly.
    If I stop and restart the track it works this way.
     

    ajs

    Development Group
  • Team MediaPortal
  • February 29, 2008
    13,714
    8,260
    Kyiv
    Ukraine Ukraine
    Country flag
    The expected result would be that the Fanarts of both artists are displayed randomly.
    If I stop and restart the track it works this way.
    Yes, it is, the plugin receives all the Fanarts for all artists at a single moment and then caches and mixes them. And in the list of Fanarts there is no sign to which artist he belongs. This is just a set of pictures that the database returned.
     

    ajs

    Development Group
  • Team MediaPortal
  • February 29, 2008
    13,714
    8,260
    Kyiv
    Ukraine Ukraine
    Country flag
    The algorithm is something like this:
    • Got a list of artists
    • Selected pictures for this list
    • Mixed up
    • Shows in a circle as the list of artists or album does not change
    :)
     

    horned_reaper

    Test Group
  • Team MediaPortal
  • January 7, 2011
    1,153
    411
    Munich
    Germany Germany
    Country flag
    Does this mean that the Fanarts of both artists should be mixed after the update?
    In my case only the Fanarts of the first artist are displayed in sequence then only the Fanarts of the second artist but not mixed.
     

    horned_reaper

    Test Group
  • Team MediaPortal
  • January 7, 2011
    1,153
    411
    Munich
    Germany Germany
    Country flag
    This was not the case. It was like this:
    first Fanart of artist 1, second Fanart of artist 1, third Fanart of artist 1, first Fanart of artist 2, second Fanart of artist 2, third Fanart of artist 2
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    H Cannot play music after full MP reinstall from scratch General Support 3
    2BitSculptor MP 1.23.. music stops playing General Support 9
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    G [fixed] [MP2-786] Party Music Player can only play playlists with less than 1000 items 2.2 Archive 7
    KlausWirn Music crash Bass crash no change to play music Installation, configuration support 2
    bta489 Sometimes no image rendered when playing video watch/edit Videos 49
    R 1.27.0 Random "Unable to play" errors after server hardware upgrade. Television (MyTV frontend and TV-Server) 8
    M MP Sometimes Unresponsive When Playing Playlist General Support 0
    squizeer Sound only when playing 4k UHD (HEVC 265) Codecs, External Players 0
    T Madvr with GeForce 30xx - can't play SDR content after playing HDR General Support 26
    P 1.26.0 Can't play blu-ray disc Bugreports 1
    doskabouter 1.26.0 Codec question (unable to play video, lv50 codec) Codecs, External Players 24
    W 1.25.0 Blu-ray disks that used to play are no longer playing Watch / Listen Media 2
    joecrow [solved] DVD won't play properly. General Support 11
    M.Hulot MP plays in Internal Blu-ray-Player-mode always first audio stream not the one I chosen in settings General Support 1
    BrownGhost Mepo/MediaInfo takes 59 secunds to open library and start play :o( General Support 30
    I 1.25.0 Videos in HEVC UHD 2160p don't play good watch/edit Videos 8
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 2
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    horned_reaper [solved] No Fanart when playing Fanart Handler 115
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31

    Similar threads

    Top Bottom