[Question] Why no standby ? (1 Viewer)

Holzi

Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,930
    2,234
    Ba-Wü
    Germany Germany
    Country flag
    I had to restart the computer so these settings were used.
    Known issue I think: https://issues.team-mediaportal.com/browse/MP1-4177 - If you activate PS for the first time you have to restart TVService.exe that the changes will take effect (or reboot your PC).


    After wakeup, the windows taskbar was visible (but-non functional - rather like an image). It was not visible before Hibernation - I had "Hide taskbar in fullscreen mode" active all the time. Alt-tab switching did not help to get rid of it, the only thing that worked was restarting MP.
    Could be releated to: https://issues.team-mediaportal.com/browse/MP1-1546 - which we try to fix for MP 1.5.0 Final.
     

    c 4

    Portal Pro
    March 4, 2008
    83
    2
    Known issue I think: https://issues.team-mediaportal.com/browse/MP1-4177 - If you activate PS for the first time you have to restart TVService.exe that the changes will take effect (or reboot your PC).
    I had already S3 working well and encountered that issue on the way - so I have already restarted TVServer some days before I switched from Plug&Play to Expert and changed to S4.

    *edit*
    simple experiment: htpc just went to hibernation, so that works.
    I woke it up and checked "apply recommended windows power settings for selected profile automatically", closed "TV Server Configuration" and then I waited which sleep mode it would enter (expected = S3).
    It was S4 ("Resume from Hibernation") - windows setting for hibernation was "never". Did a TVServer Restart - still S4. Switched back to Plug&Play - ...

    So it seems as if after any (major?) change to PowerScheduler settings there is a TVServer restart required.
    Irritatingly PowerScheduler 'General' page currently displays "Put the computer to sleep after 0 minutes"
    */edit*

    Could be releated to: https://issues.team-mediaportal.com/browse/MP1-1546 - which we try to fix for MP 1.5.0 Final.
    I am not sure if this is the same problem. It sounds as if the taskbar would be usable in that case. In my case it was visible but non-functional - felt more like an after-image 'burnt' in the MP UI (it looked completely normal, though).
     
    Last edited:

    michael_t

    Portal Pro
    November 30, 2008
    1,258
    813
    Germany Germany
    ...I woke it up and checked "apply recommended windows power settings for selected profile automatically", closed "TV Server Configuration" and then I waited which sleep mode it would enter (expected = S3).
    It was S4 ("Resume from Hibernation") - windows setting for hibernation was "never". Did a TVServer Restart - still S4. Switched back to Plug&Play - ...
    There seems to be a bug that "apply recommended windows power settings for selected profile automatically" is not activated (but only stored as setting) on leaving TVServer Configuration. And then it takes effect only on the next change to "Plug&Play" or a TVServer restart. I will fix this. Thank you for reporting!

    Michael
     

    c 4

    Portal Pro
    March 4, 2008
    83
    2
    I did some more tests to check if a TVService restart is enough when changing PS settings:

    I configured it in Expert Mode to use S4 (5min waiting time), but it was using S3 (which I set earlier) so I changed the Hibernation waiting time to 1 min and clicked OK. After a manual TVService restart it took roughly 10 min then the HTPC entered S3.

    Next try: switched to Plug&Play then back to Expert, changed the settings again (would be nice if they would not be forgotten + a 'reset to defaults' button) - the settings in "Configure Manually" were still like before. So I clicked Apply ,then OK, then did a manual TVService restart. It took 5 min and then it entered - you guessed it - S3 mode.

    Checked my settings: Standby after 0 min, Hibernate after 1 min.

    Changed Hibernate to 5min, back to Plug&Play, then to Expert again, redid my settings, checked "Configure Manually" and it was still the same - regardless I changed it to 4min to 'force-trigger' an update just in case, Apply, OK, TVService restart, waiting ... and after 4-5 min it entered S3 again

    In two of the above tests, the HTPC woke up (1x immediately, 1x after ~3min) after going to sleep although there is no recording scheduled for the next few hours and it is not set to wake up for EPG grabbing.
    So I restarted the PC. Now the HTPC was using S4 like I wanted but it woke up immediately after it went to S4 (displayed 'Resume from Hibernation'). I suspected that this happened because I left the HDMI-connected TVScreen on, but after I switched that off, the HTPC went to S4 and again, it woke up immediately. I guess it is tired of my tests.

    Total logs are now well beyond 15 MB, so if you could tell me which logfile you need, I would not have to spend the whole afternoon watching the upload progress bar.
     

    michael_t

    Portal Pro
    November 30, 2008
    1,258
    813
    Germany Germany
    I configured it in Expert Mode to use S4 (5min waiting time), but it was using S3 (which I set earlier) so I changed the Hibernation waiting time to 1 min and clicked OK. After a manual TVService restart it took roughly 10 min then the HTPC entered S3.
    What value did you set for "Standby after"? This must be set to "0" (never) if you want to use S4 and "Hybrid skleep" must be disabled.
    Next try: switched to Plug&Play then back to Expert, changed the settings again (would be nice if they would not be forgotten + a 'reset to defaults' button) - the settings in "Configure Manually" were still like before.
    This is the purpose of the Plug&Play mode - to reset all settings to a default. If you do not want them to be changed you should not press the Plug&Play button. The settings in "Configure manually" reflect the system settings and these are not changed until you apply your settings with the "Apply" button or by leaving the TV Server Configuration with "OK" (not with "Cancel").
    In two of the above tests, the HTPC woke up (1x immediately, 1x after ~3min) after going to sleep although there is no recording scheduled for the next few hours and it is not set to wake up for EPG grabbing.
    Use "powercfg /lastwake" or have a look in the System event log to see what made your PC resume.

    Michael
     

    c 4

    Portal Pro
    March 4, 2008
    83
    2
    What value did you set for "Standby after"? This must be set to "0" (never) if you want to use S4 and "Hybrid skleep" must be disabled.
    Hybrid sleep is deactivated, Standby after 0 minutes, Hibernate after 4 minutes - and it went to S4 but only after a complete PC restart, clicking Apply and OK and restarting the TVService was insufficient to make the PC use the setting. Before the restart it ignored the settings and used S3.

    Use "powercfg /lastwake" or have a look in the System event log to see what made your PC resume.
    Will have a look, thanks.
     
    Last edited:

    doveman

    Portal Pro
    February 12, 2008
    2,326
    178
    United Kingdom United Kingdom
    Country flag
    Like I wrote earlier I switched tp 'desktop' profile and back to 'htpc' profile so I could click 'apply' to definitely activate PowerScheduler Standby prevented by srvnet is a new message, I did not get this before.
    I found I have to use

    powercfg /requestsoverride driver srvnet system

    to stop srvnet blocking standby. For some reason

    powercfg /requestsoverride driver \FileSystem\srvnet system

    doesn't work. Hope that helps someone save some time/hair ;)
     

    c 4

    Portal Pro
    March 4, 2008
    83
    2
    The reason for the mysterious wakeups after S4 seems to be windows HomeGroup - in contrast to the past, the HTPC goes to sleep but wakes up if another PC from the same Windows HomeGroup is active (and has a folder from the HTPC open?)
    Wakeup event: "Power-Troubleshooter Reactivation Source: unknown" (which is said to indicate a wakeup from S4)

    - TV Server Configuration - Power Scheduler - Network "Do not put the computer to sleep while the network is active" is set to 7 KB/s.
    - I did not set anything in Shares.
    These two should roughly be the same settings like in 1.4.0 and there I did not have this problem. In my eyes, either the computer goes to sleep because there is nothing blocking or there is something preventing hibernation - not both at the same time.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom