WinCVS 2.0 - authorization failed for user anonymous (1 Viewer)


New Member
November 24, 2005
I'm really a novice of mediaportal project (but i have some good ideas) and the first problem seems to be source download with WinCVS 2.0

I have insert the parameters in "Checkout module" but i was unable to download anything.
In the log windows i see:

cvs -d ":pserver;username=anonymous ;;hostname=cvs.sourcef..." checkout -P -- "mediaportal " (in directory C:\mediaportal)
cvs [checkout aborted]: authorization failed: server rejected access to /cvsroot/mediaportal for user anonymous

What's the problem?


P.S. Sorry for the poor english.


Portal Member
January 21, 2005
Sydney, Australia
I'm getting much the same problems with v2.0.2.4 of WinCVS - I've followed the original instructions but the new version of WinCVS is different so I'm not sure what I need to do to get the latest project.

In the Remote menu I selected Checkout Module then entered a checkout loaction ("e:\projects\mediaportal") then ticked "CVSROOT" and the "..." button. Once on the CVSROOT dialog I entered the following:

Protocol: pserver
Repository Path: /cvsroot/mediaportal/
Username - anonymous
Password - <my email address>
hostname -

I didn't enter anything for any of the Port or Proxy fields.

My CVSROOT string then looks like this:


When I close that dialog and click OK again I get this in the log window:

cvs -d :pserver;username=anonymous;password=<my email>;hostname=cvs.sourceforge.n... checkout -P -- mediaportal (in directory E:\Projects\MediaPortal)
cvs [checkout aborted]: Error reading from server 0

When I tried this the other day with the same parameters it told me I wasn't authorised (the same error Danielle got) but now it gives me this error - if anyone can help me out here I'd really appreciate it.




Retired Team Member
  • Premium Supporter
  • February 23, 2005
    Tulsa, OK
    Home Country
    United States of America United States of America
    I've been able to checkout the CVS of MP for quite sometime, today however it seems there maybe a problem with the sourceforge server. I recieved the following error:

    cvs [checkout aborted]: Error reading from server 0

    I've been using WinCvs (Build 4) for several months with no issues.


    Users who are viewing this thread

    Top Bottom