1.15.0 XML TV Import:Exception :System.FormatException: System.Number.StringToNumber (1 Viewer)

Aquarius

MP Donator
  • Premium Supporter
  • November 23, 2004
    347
    7
    NRW
    Home Country
    Germany Germany
    Country flag
    Hi all,
    with upgrading to 1.15 my XML TV importer throws this exception.

    2017-01-22 12:13:24,327] [Log ] [XmlTvImporter] [ERROR] - plugin:xmltv import failed
    [2017-01-22 12:13:24,452] [Log ] [XmlTvImporter] [ERROR] - Exception System.FormatException: Die Eingabezeichenfolge hat das falsche Format.
    bei System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
    bei System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
    bei System.Int32.Parse(String s)
    bei TvEngine.XMLTVImport.Import(String fileName, Boolean deleteBeforeImport, Boolean showProgress)
    bei TvEngine.XmlTvImporter.ThreadFunctionImportTVGuide(Object aparam)

    I would be very grateful if someone could point me to some direction what might be wrong here.

    I've attached logs & the bad tvguide.xml.

    Thanks
    Gerry
     

    Aquarius

    MP Donator
  • Premium Supporter
  • November 23, 2004
    347
    7
    NRW
    Home Country
    Germany Germany
    Country flag
    Thank you very much for this quick reply. That was indeed the problem !

    Now I'll can go on with fixing the contents problems of tvguide.xml.

    Have a nice rest weekend !
    Gerry
     

    Users who are viewing this thread

    Similar threads

    Hi doskabouter I only use the line jump for the description. I modify the XmlTV file from EPG-Buddy with WebGrabPlus (rex) only in the description with \n. My new description is: Genre, year of production \n Original description \n Actors
    Hi doskabouter I only use the line jump for the description. I modify the XmlTV file from EPG-Buddy with WebGrabPlus (rex) only...
    Just installed 1.28, and the new XML EPG importer refuses to import the xml spit out by EPG-Buddy. Older versions of MP1 ingest it...
    Replies
    23
    Views
    2K
    MP1 MP2 XMLTV import stucks DE
    Thank you. I thought I did this before. Now I had all reinstalled and it works again.
    Thank you. I thought I did this before. Now I had all reinstalled and it works again.
    A few days ago MP2 stops to import EPG data from xmlTV Log file says [2016-05-11 14:18:21,723] [14978 ] [SetupTv ] [DEBUG] -...
    Replies
    14
    Views
    3K
    you nailed it, it was that hours and minutes setting... the option was deselected but only seconds was set to 0. The latest import seems to have worked fine. Muchas gracias!
    you nailed it, it was that hours and minutes setting... the option was deselected but only seconds was set to 0. The latest import...
    Hey, spent a few hours scratching head and trawling the forums here, and none of the suggestions so far have helped. I've already...
    Replies
    4
    Views
    5K
    Hi. Sorry, but I don't have any clue about this. It's something a dev must answer. And the Multishortcut dev is gone a long time now.
    Hi. Sorry, but I don't have any clue about this. It's something a dev must answer. And the Multishortcut dev is gone a long time now.
    Hi! Unfortunately i've noticed some error messages in MediaPortal-error.log with MultiShortcut -> [2014-05-18 14:43:10,576] [Log...
    Replies
    2
    Views
    5K
    The update to the donator version worked like a charm for me. Thanks!
    The update to the donator version worked like a charm for me. Thanks!
    Windows 10, MP 1.12. Using donation version of mc2xml from microsoft to create tvguide.xml Once I switched to the donated version...
    Replies
    5
    Views
    3K
    Top Bottom