5.1 AAC not working using FFDShow under Windows 7 (1 Viewer)

vaelyn

Portal Member
July 27, 2009
8
0
MediaPortal Version: 1.02 and 1.10alpha
Windows Version: windows 7 x64 build 7600

I have the following problem and hope that some of you might help me fix it:
In those mp4 or mkv HD movies where the 5.1 sound in encoded with AAC I am unable to pass it correctly to my speakers (logitech z-5500 using Digital Coax Input). This only occurs in Windows 7.

When I use FFDShow Audio Decoder as MediaPortal's AAC Decoder:
http://bayimg.com/image/hacciaaco.jpg
I get this error:
http://bayimg.com/image/haccdaaco.jpg

It plays fine when using either:
MPC - MPA Decoder Filter
or
Microsoft DTV-DVD Audio Decoder
However when I do that, it doesn't pass through the full 6 channels and my speakers get only stereo input.

When I play the same file in MPC-HC it works fine, as can be seen in GraphEdit, it uses ffdshow and dxva (same as what I want in MP) and the speakers detect input as Dolby Digital, rather than stereo sound.
http://bayimg.com/image/iaccdaaco.jpg

-----------


Edit: Managed to fix it by uninstalling absolutely every codec I had (including the ones integrated in Windows 7) and installing K-Lite 5.00 Mega followed by 5.02 update only. I'm now using DXVA with MPC Video Decoder and FFDShow Audio for both AC3 and DTS throughput.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
bta489 [solved] DVB-T2 Recordings: Sometimes no Audio after muxing with mkvmerge Tools and other software 2
A AAC 2.0 going out of sync Codecs, External Players 2
Rob Hexenmeister ITV Player still not working for me OnlineVideos 2
V Do you have to have a smart tv for it to work? Newcomers Forum 4
M WTV Files does not play on client, MPEG files works well General 0
D Does Schedules Direct work with mp 1.24? General Support 3
J [solved] Blu-ray disc playback does not work. Bugreports 13
P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
ratata [solved] Can't get two virtual IPTV cards to work side by side... General Support 6
S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
T [solved] Green Button start MP not working....but box ticked in config. General Support 1
mickb [solved] Mediaportal Stops working General Support 5
C Importer works super slow My TVSeries 5
D [solved] Movie artwork download stopped working Submit: Bug Reports 9
A 1.24.0 CD art grabber not working in Shares view 1.24 Pre Release 17
RoChess Random GPU crash leads to MePo restart, but works fine afterwards MediaPortal 1 14
Dark Eyes Updated to Windows 10, now TVServer won't work Installation, configuration support 1
D [solved] EPG Buddy for MP2 - Does it work? General 5
D Please help with getting Schedules Direct to work Newcomers Forum 10
B MP 1.23 First time click TV or Recorded TV fails, 2nd ... it will work General Support 5
M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
rsbrux IR has stopped working Remotes 4
thepahakurki TVDB import not working My TVSeries 3
Rob Hexenmeister Work arounds for an alternative home screen General Support 3
A Working server, no video playback on client General 5
Similar threads

























Top Bottom