A beginner has a lot of questions (1 Viewer)

thoath

Portal Pro
June 8, 2012
69
3
17
Home Country
Germany Germany
1.) When I start mediaportal, it is not possible to navigate with the arrow Keys of Keyboard or remote. If i click by mouse on an item, after this is it possible to navigate with remote or keyboard.

2.) How I can adjust the font size larger than 18pt.

3.) How can I set the menu width? The Changing of list-width has no influence.

4.) I've made in the Basic Home Editor some structural changes.
The Menu-Folder "Sonstiges" contains the following entries:
Sonstiges
- Weather (yrWeather)
- HTPC info
- settings
- Tetris
- Sudoku

If I start MediaPortal and navigate to the menu "Sonstiges" and click Ok then the original content menu appears before the change. The menu is also displayed in the "home layout" and not in "Basic Home layout".

5.) how can i disable the info-item (TV-Series) on the lower edge

Please help me?5050550
 

Attachments

  • Editor-Sonstiges.png
    Editor-Sonstiges.png
    30.6 KB
  • Sonstiges.png
    Sonstiges.png
    393 KB

Dadeo

Docs Group Manager
  • Premium Supporter
  • November 26, 2006
    5,340
    3,321
    Himalayas, India
    Home Country
    Canada Canada
    @thoath I will try to help but some of those are tricky questions!

    1.) When I start mediaportal, it is not possible to navigate with the arrow Keys of Keyboard or remote. If i click by mouse on an item, after this is it possible to navigate with remote or keyboard.
    I would need more info - does this occur only on Basic Home or Classic My Home also? Does it occur with other skins or only aMPed? If it is Basic Home in aMPed, which layout do you use - revaMPed, Vintage, or your own custom mod? If it is custom mod, does the same issue apply when you use the built in layouts?

    2.) How I can adjust the font size larger than 18pt.
    See MP wiki - Changing font sizes - in aMPed you can just increase the height - however it is quite possible many things won't 'fit' nicely.

    3.) How can I set the menu width? The Changing of list-width has no influence.
    Not easy in MP 1.2.x - in MP 1.3.0 I can implement new methods to support that. If you really want I can tell you how, but it is many changes in XML files! See MP Skin architecture in Wiki for all the different types of buttons!

    4.) I've made in the Basic Home Editor some structural changes.
    The Menu-Folder "Sonstiges" contains the following entries:
    Sonstiges
    - Weather (yrWeather)
    - HTPC info
    - settings
    - Tetris
    - Sudoku

    If I start MediaPortal and navigate to the menu "Sonstiges" and click Ok then the original content menu appears before the change. The menu is also displayed in the "home layout" and not in "Basic Home layout".
    Yes, just press the right arrow key when you highlight Sonstiges and you will access your custom sub menu

    5.) how can i disable the info-item (TV-Series) on the lower edge
    Disable TV-Series plugin

    Hope that helps a bit?
     
    Last edited:

    thoath

    Portal Pro
    June 8, 2012
    69
    3
    17
    Home Country
    Germany Germany
    Thanks Dadeo for yout fast answer!

    to 1.) Now i can reproduce the Problem.
    To get the Problem, I make following steps.
    - I make a change of structure in MPed-Config/Layouts Button "Edit" on my own layout based on revaMPed.
    _ I save the changes with a new name
    - I start MP and get the problem, it is not possible to navigate with remote or Keyboard.
    - After this a change in Media-portal-Configuration/GUI from aMPed to DefaultWide
    - I start MP, and i have no problems.
    - After this a change again to aMPed and after starting MP it works fine.
    - It's my workaround.

    to 2. and 3) This is a pity. Because I don't want to make tricky changes, i will wait for the 1.3. Version.

    to 4.) Sorry, that is not this what I want. If I click on Sonstiges, I get a Menu, what I never built. How I could config this window to get my own items? Is it possible? Is it possible to generate Menu-Windows which I get if I click on an Menu-item. In my opinion is it the normaly way to navigate between windows -> select an item -> get an new window with the subfolder-navigation --> click to item (for instance yrWeather) and get the content. If it is not possible to navigate so, can I disable the false window "Sonstiges" to get nothing if i click on Sonstiges.

    to 5.) I cannot find a TV-Series Plugin in Media-Portal-Configuration --> Plugins. Where I can find this?

    Best thanks and best regards
    Thomas
     

    Dadeo

    Docs Group Manager
  • Premium Supporter
  • November 26, 2006
    5,340
    3,321
    Himalayas, India
    Home Country
    Canada Canada
    Hi Thomas !

    1. If you try the built-in revaMPed layout (not your mod) - does it work? If so, then if you post your BasicHome.xml (your mod) - I can take a look and see if I can spot what is going wrong. Did you try Deda's suggestion? - enable 'Keep MediaPortal always on top?"

    2. and 3. - Yes it might be better to wait until you have everything working well, and get a bit more experience with MediaPortal. I don't think I will be able to offer more than 18pt font in aMPed however, because it is already VERY difficult to fit everything on screen, especially on 4x3 screen sizes, but you should be able to increase font size a bit on 16x9 without many issues.

    4. In MP, 'Plugins' is a built in window that displays ALL the plugins you have installed that do not display on the Classic My Home window. Those two windows work together. So when you press that option on revaMPed Basic Home, it will open that window. You can configure the Plugins window in MediaPortal using the 'Home' plugin in Configuration (see Wiki: Home Plugin for details). However, I don't think that is exactly what you want.

    revaMPed layout does not use separate windows for sub menus - everything is in 'layers' in one window - so to access the sub menus you create in Editor you press the right arrow key. You need to read about Using revaMPed in the Wiki for more info. You CAN change the Plugins menu item to open to whatever window you wish (and even rename it on the main menu).

    5. TV-Series is actually listed in Plugins under MP-TV Series (official name). However, I think I misunderstood your issue! Did you install MP-TV Series? Did you install the Latest Media Handler Plugin? (it's under process plugins at the bottom in Config>Plugins.) Those 'tickers' at the bottom of Basic Home display the latest media you have added in different plugins. However, they should ONLY display if you have Latest Media Handler AND those plugins installed and enabled. So I will check into that and see if I can spot a bug and get back to you.
     
    Last edited:

    thoath

    Portal Pro
    June 8, 2012
    69
    3
    17
    Home Country
    Germany Germany
    Hi Dadeo,

    1. ) Enable 'Keep MediaPortal always on top was not a solution. As attachment you find my basicHome.xml.

    2+3.) That's OK!

    4.) My Solution is now: I define the yrWeather Windows instead "Sonstiges". If I click this Item, i get a good window with weather content. if i want to use the sub-items a have to use the right arrow.

    5.) Yes, I find the MP-TV-Series Plugin, I disabled this plugin. But the Text is to see, yet. Is it possible to completely disable the lower Infotext. I don't need it.

    Thomas
     

    Attachments

    • BasicHome.xml
      95.4 KB
    • BasicHomeInfoRecentlyAdded.xml
      6.4 KB

    Dadeo

    Docs Group Manager
  • Premium Supporter
  • November 26, 2006
    5,340
    3,321
    Himalayas, India
    Home Country
    Canada Canada
    OK your Basic Home mod looks fine - and it works here both with remote and keyboard :confused:
    If I press left arrow key I get the first screenshot, If I press right arrow on Videos, I get the second. Weird!

    Did you create the mod in a previous version of aMPed and then modify it in 3.4? If so, could you try recreating it based on revaMPed in 3.4.0 and see if that fixes the issue? I assume you are using aMPed 3.4.0 on MP 1.2.x?

    If not, I'll keep trying to figure out what is causing your issue!

    Is it possible to completely disable the lower Infotext. I don't need it.
    Yes, the easiest way is to just remove the line: <import>BasicHomeInfoRecentlyAdded.xml</import> from the bottom of your BasicHome.xml mod. Don't forget to copy it to skin\aMPed\Layouts\BasicHome\[modname] folder or it will come back when you reselect or edit you mod.
     

    Attachments

    • thoath_aMPed_BH.jpg
      thoath_aMPed_BH.jpg
      121.6 KB
    • thoath_aMPed_BH_Videos_Submenu.jpg
      thoath_aMPed_BH_Videos_Submenu.jpg
      103.7 KB
    Last edited:

    thoath

    Portal Pro
    June 8, 2012
    69
    3
    17
    Home Country
    Germany Germany
    Hi Dadeo,
    I created the mod in a the newest version of aMPed.

    I removed the line <import>BasicHomeInfoRecentlyAdded.xml</import> from C:\ProgramData\Team MediaPortal\skin\aMPed\Layouts\BasicHome\revaMPed-20121118f but nothing changed. The info line is always to see.
    Thomas
     

    Dadeo

    Docs Group Manager
  • Premium Supporter
  • November 26, 2006
    5,340
    3,321
    Himalayas, India
    Home Country
    Canada Canada
    Re your Basic Home Mod:
    I'm stumped Thomas - no matter what I try, I cannot reproduce your issue with your Basic Home mod - it works fine here. :confused:

    So next step, we can try the following:
    1. Check if you have any error.log in ProgramData\Team MediaPortal\MediaPortal\log folder? If so, please post it
    2. Set your log verbosity to 'Debug' on the General Tab in MP Config settings, and post your MediaPortal.log (same folder as above)
    Your logs are probably in German so I won't be able to tell much, but maybe I can spot something ;)

    Re Recently Added Info (ticker on Basic Home)
    Can you confirm if you have Latest Media Handler (LMH) installed and enabled? (See attached screenshot)
    If so, try disabling it and see if that removes the ticker for you (it should remove it on all Home screens).
    If you don't have it installed or enabled, then there is a deeper issue because it does not display if disabled.

    Let's see if any of that helps, then we can go from there ok? It might provide more info to help me identify the source of your issues.

    BTW do you have any other skins installed besides Default and aMPed?

    Thanks for your patience!
     

    Attachments

    • LMHPlugin.jpg
      LMHPlugin.jpg
      112.8 KB

    thoath

    Portal Pro
    June 8, 2012
    69
    3
    17
    Home Country
    Germany Germany
    Hi Dadeo,
    Basic Home Mod:
    I have not an error.log file. That's why I send you all log-Files as zip-File.
    Edit: I added the MediaPortal.log File. But it is curious. After the recent changes, the problem no longer existed!

    Recently Added Info (ticker on Basic Home)
    The "disabled"-task for LMH was the solution. The ticker is gone. Thank you.

    Thomas
     
    Last edited:

    Users who are viewing this thread

    Top Bottom