Adding MPC-HC decoder to MediaPortal H.264 Video decoder

Discussion in 'Codecs, External Players' started by VashStampede, October 31, 2009.

  1. VashStampede

    VashStampede Portal Member

    Joined:
    August 16, 2008
    Messages:
    44
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Netherlands Netherlands
    Hello there!

    I want to use the MPC-HC video decoder in MP for H.264 decoding. I already registered the MPCVideoDec.ax file in the OS\SysWow64 folder (regsrv32.exe MPCVideoDec.ax).



    But I cannot choose it in MediaPortal? Is there something else I can do, as I have a better quality in MPC with their codec then in MP with CoreAVC.

    Thanks!



    MediaPortal Version: 1.1.0 BETA
    MediaPortal Skin: 1080p Black & White
    Windows Version: Seven Ultimate
    CPU Type: Intel E8400 3.0Ghz
    HDD: Hitachi 2x250GB (Raid1), Seagate 500GB
    Memory: 4GB DDR2 PC6400
    Motherboard: Gigabyte EP45-DS3R
    Video Card: Asus HD4850
    Video Card Driver: 9.10
    Sound Card:
    Sound Card AC3:
    Sound Card Driver:
    1. TV Card: Hauppage PVR 150
    1. TV Card Type: Analog
    1. TV Card Driver: 2.0.48.24227
    2. TV Card:
    2. TV Card Type:
    2. TV Card Driver:
    3. TV Card:
    3. TV Card Type:
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec:
    MPEG2 Audio Codec:
    h.264 Video Codec:
    Satelite/CableTV Provider: Ziggo
    HTPC Case: None (main PC used)
    Cooling: Enough :)
    Power Supply: Asus 450Watt
    Remote: Microsoft MCE Remote
    TV: BenQ 20" Wide TFT
    TV - HTPC Connection: DVI
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. roosterx

    roosterx Portal Pro

    Joined:
    April 24, 2006
    Messages:
    137
    Likes Received:
    1
    Occupation:
    MCSE, Watchmaker
    Location:
    Högsäter, Sweden
    Ratings:
    +1 / 0
    Home Country:
    Norway Norway
    Try using x86 version of the codec, that should work.

    Don't forget to unregister with '/u' the old one, and also don't forget Haali mediasplitter if you need it.
     
    • Like Like x 1
  4. kiwijunglist
    • Team MediaPortal

    kiwijunglist Super Moderator

    Joined:
    June 10, 2008
    Messages:
    6,746
    Likes Received:
    1,420
    Occupation:
    Doctor
    Location:
    New Zealand
    Ratings:
    +1,849 / 9
    Home Country:
    New Zealand New Zealand
    Show System Specs
    What you have done should work, it works for me. As what above has posted, make sure you use te 32bit version. After you register a codec sometimes you have to relogin to windows to see it.
     
  5. VashStampede

    VashStampede Portal Member

    Joined:
    August 16, 2008
    Messages:
    44
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Netherlands Netherlands
    Thanks. Using the 32-bit version worked!
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!