AirPlayer - AirPlay target for MediaPortal (1 Viewer)

FreakyJ

Retired Team Member
  • Premium Supporter
  • July 25, 2010
    4,024
    1,420
    Home Country
    Germany Germany
    Thanks
     

    Brownard

    Development Group
  • Team MediaPortal
  • March 21, 2007
    2,286
    1,867
    Home Country
    United Kingdom United Kingdom
    • Thread starter
    • Moderator
    • #22
    The sound of Windows mutes when I disconnect my phone from the "external speakers".

    Audio Setup: PC -> via HDMI -> AV Receiver -> 5.1 Sound System
    MP Config: Control: Master Volume; Scale: Windows Vista/ Win 7

    System: Windows 7 64bit; MP 1.7pre

    The Mediaportal.1.log is quite big, I tried it around 8 till 8:10 pm (20:00 - 20:10)

    Thanks, are you saying that you don't even have to play a song - just connecting then disconnecting causes the volume to mute? Is the volume properly muted or is the volume just turned right down?

    Does it make a difference if you disable allowing client to control volume in the config?

    Did you actually connect during the above logs - there's no connections showing? :confused:
     

    fischy667

    Super User
  • Team MediaPortal
  • Super User
  • May 5, 2010
    958
    283
    41
    Rostock
    Home Country
    Germany Germany
    I don't know if that that is a good or bad news, I cannot reproduce the problem.

    The sound was muted, and I was playing a youtube video on my device.
    Did the same as yesterday and everything is fine now. Strange???

    Nevertheless here are some logs, I hope there is also everything as it should now.
     

    Attachments

    • log1.rar
      37.6 KB
    • log2.rar
      25 KB
    • log3.rar
      33.5 KB

    sunfire7

    Portal Pro
    March 24, 2011
    193
    47
    35
    Home Country
    Mexico Mexico
    Great plug-in, I've been using it and it's great. One question, is it possible to use the MePo Bass Engine to be able to use visualization??
     

    Brownard

    Development Group
  • Team MediaPortal
  • March 21, 2007
    2,286
    1,867
    Home Country
    United Kingdom United Kingdom
    • Thread starter
    • Moderator
    • #25
    I couldn't figure out how to pass the audio stream onto Bass.

    If anybody knows how I can pipe a System.IO.Stream / byte buffer through then please let me know!
     

    sunfire7

    Portal Pro
    March 24, 2011
    193
    47
    35
    Home Country
    Mexico Mexico
    Other things:

    *In spotify, when a track ends it stops and you have to select the airplay source again and hit play, this don't happen with native music app
    *Sometimes stream is lost for unknown reasons, maybe my network, but with my AVR is rock solid
     

    Brownard

    Development Group
  • Team MediaPortal
  • March 21, 2007
    2,286
    1,867
    Home Country
    United Kingdom United Kingdom
    • Thread starter
    • Moderator
    • #27
    Thanks, I'm gunna need logs from when you get the dropouts. Does Spotify keep playing on the AVR?
     

    wilcken

    MP Donator
  • Premium Supporter
  • April 21, 2011
    11
    0
    Gothenburg
    Home Country
    Sweden Sweden
    Hi i got this error. it seems to connect but when it should start playing something happens.

    Logg:

    03-12 18:17:29,436] [MPMain ] [INFO ] Server starting: MAC address 00248C23F99F, port 5000
    [03-12 18:17:29,438] [MPMain ] [DEBUG] Starting bonjour service
    [03-12 18:17:29,449] [MPMain ] [DEBUG] Starting TCP Listener
    [03-12 18:17:37,292] [26 ] [DEBUG] TCP Listener: New connection
    [03-12 18:17:37,298] [26 ] [DEBUG] RtspServer: Listening for new RTSP packets
    [03-12 18:17:37,314] [16 ] [DEBUG] RAOPSession: Received Apple-Challenge: W5lIqioZPdCVJNSz10o9aw==
    [03-12 18:17:37,453] [16 ] [DEBUG] RAOPSession: Created Apple-Response: iCS7zUxxZBxBAAiHueWdTFQgnuOyCgWCtShNuxjyvhNVsxTjNFYXqcc+3EZ9KiGSJOsbLizs7bUiM6p8btWcgNlXhmt8XO4lhCgKBepY7l5HxhOdqMJ9sVOBJqkeEjDaWIglPUTOJqTmfLHLAQ0GrYTBuiik9Z6O78iZJ/EihC8Eq2QTRq0y0Gbhk2fbH+amqBNEzvZ+a9ihXrR6g74dkLmuFfNRgPp+/Xv4mHxXEc0gdvkyxzkvoZkJfSHvCUFO3M6w7Nz2jRf9Z1tljiOCryC/ng1mK5Dyo9DtCyBYwBP+RrempWohyaXA7Y5fGZJ8Sdysc60ZZLDt1d31nmwdlg
    [03-12 18:17:37,472] [26 ] [DEBUG] RAOPSession: Received remote info - DacpId : '9D3D7A3BF99EAB97', ActiveRemote : '1221036125'
    [03-12 18:17:37,476] [26 ] [DEBUG] RAOPSession: Received audio info - '96 352 0 16 40 10 14 2 255 0 0 44100
    '
    [03-12 18:17:37,541] [26 ] [DEBUG] RAOPSession: Received AES Key - 'W3I+Cw8CcLIantkQQ91RD34SKhnlgA08Wsa3hG6rR6/Q4WZ7sJAKqFJ/uX2l9XsokgPZdpsRtfaubn8oY0n/F7CN8M4X90jHfIkCh+NgGrpJ+2hMeyoouaX+QHdnN5AjiW7M/048GJNJNMNSxHqA7CwUWaO/EVUK3CAY9/97hosz48mQWout4Q5TWEMjQQH36SWAlCykhljgM6xQZVFokDzfT26JzSouzsfsZMPNDZVmRlTCfvZwatjhphyc9EcENJIsyXHPzJ7SzCBqY0g6YOxRQZyGG80FAze/mxcS3TT3BuQWJKo+HBSQlUJ3Z40fWvBB2L33+WeY+1WalDcIlQ==
    '
    [03-12 18:17:37,544] [26 ] [DEBUG] RAOPSession: Received AES IV - '1fqOGc5HwNPCGKbRjzT8OA==
    '
    [03-12 18:17:37,552] [26 ] [DEBUG] RAOPSession: Set client control port to 54898
    [03-12 18:17:37,556] [26 ] [DEBUG] RAOPSession: Set client timing port to 53248
    [03-12 18:17:37,560] [26 ] [DEBUG] Audio Buffer: Buffer size: 1024 frames (8,2s)
    [03-12 18:17:37,568] [26 ] [DEBUG] Audio Server: Using ports 6000 - 6002
    [03-12 18:17:37,571] [26 ] [DEBUG] RAOPSession: Started new Audio Server
    [03-12 18:17:37,584] [26 ] [ERROR] RtspServer: Error receiving RTSP packets - Indatasträngen hade ett felaktigt format.
    vid System.Number.ParseDouble(String value, NumberStyles options, NumberFormatInfo numfmt)
    vid ShairportSharp.RaopSession.handleParameterString(String parameterString)
    vid ShairportSharp.RaopSession.HandleRequest(RtspRequest request)
    vid ShairportSharp.Rtsp.RtspServer.onInputReadComplete(IAsyncResult result)

    [03-12 18:17:37,588] [26 ] [DEBUG] RtspServer: Closed socket
    [03-12 18:17:37,592] [26 ] [DEBUG] Audio Buffer: Stopped
    [03-12 18:17:37,595] [26 ] [DEBUG] RAOPSession: Stopped audio server
    [03-12 18:17:38,160] [28 ] [DEBUG] RemoteHandler: Found service - iTunes_Ctrl_9D3D7A3BF99EAB97
    [03-12 18:17:39,156] [5 ] [DEBUG] RemoteHandler: Resolved service - iTunes_Ctrl_9D3D7A3BF99EAB97, fredrikwilckens-iPhone-2.local.:56479
    [03-12 18:17:40,915] [16 ] [DEBUG] RemoteHandler: Removed service - iTunes_Ctrl_9D3D7A3BF99EAB97
    [03-12 18:17:49,549] [26 ] [DEBUG] TCP Listener: New connection

    /Fredrik
     

    Brownard

    Development Group
  • Team MediaPortal
  • March 21, 2007
    2,286
    1,867
    Home Country
    United Kingdom United Kingdom
    • Thread starter
    • Moderator
    • #29
    Hi i got this error. it seems to connect but when it should start playing something happens.

    I've updated the first post with a new version which should fix your problem.

    Thanks.
     

    Users who are viewing this thread

    Top Bottom