[WiP] Audio delay when using LAV Audio codec (1 Viewer)

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    • Thread starter
    • Moderator
    • #1
    Description of Change

    This branch will permit to have enabled audio delay (based for FFDShow Engine) but this time for LAV Audio.
    This branch is based on 1.20 final.
    Set the value of the step (there will be -10 to 10 so 20 step) from MP GUI selection

    upload_2018-9-30_15-31-45.png


    upload_2018-9-30_15-33-54.png


    Jira Link : [MP1-4928] Add audio delay with LAVAudio - Jira
    Branch Link: MediaPortal/MediaPortal-1
    Review : MP1CR-862 MP1-4928 : Delay Audio with LAV - Under Review
    Wiki docs: To do.

    Steps to install and test
    Installation (latest version on the bottom on the below list)
     

    Attachments

    Last edited:

    daWooky

    MP Donator
  • Premium Supporter
  • April 3, 2012
    779
    868
    Germany Germany
    Country flag
    Bye bye last needed ffdshow function:LOL: tested it a bit and so far its working great.(y)(y)(y)
    there's only one thing i noticed, it would be nice if the delay would go back to zero ms or to the default/set value of the codec after playback. i don't remember if it was the same with ffd-show, but i think it would be handy.:p
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    • Thread starter
    • Moderator
    • #4
    Hey :)

    It was my idea at first to reset it on start but i didn't do it, i didn't remember if this settings was kept for ffdshow, but it should be possible to do the trick :p
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    R Delay in audio output over HDMI OffTopic 11
    Golf4 TV-Records werden als Audio-Files importiert ? Allgemeines Support- und Diskussionsforum 0
    W [solved] Incorrect audio being reported Moving Pictures 4
    404 [solved] Live TV...video and audio freeze General Support 20
    ninja 12 Audio dropouts with Dolby / DTS watch/edit Videos 12
    bta489 [solved] DVB-T2 Recordings: Sometimes no Audio after muxing with mkvmerge Tools and other software 2
    T [solved] MP2 Switch off visualisation when listening to audio....PLEASE!!! General 23
    azzuro [fixed] [WIP MP2.3] - Audio files not imported to MP MediaPortal 2 18
    S Remote button to change audio and subtitle on / off General 10
    F Audio render and font error in my logs General Support 2
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    Glith Audio out of sync after pause. Rewind 15sec gets it into sync again. MediaPortal 1 Talk 0
    C ARC Audio Renderer Changer: wo kann man es konfigurieren? Video & DVD 15
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    C Ability to browse videos and audio by folder General 2
    Lichloathe Offline audio content General 9
    G How best to get cover art for tracks to show up on the Audio Menu (Latest Added, Unplayed)? General 9
    Ralph Holmes Wrong audio source in TV General 1
    CyberSimian [Proposal] Audio description MediaPortal 1 10
    ge2301 [fixed] [MP2-807] Problem when switching player in PiP mode with audio files MediaPortal 2 32
    cladinshadows85 [solved] Audio playing mutiple times over video and crashing General 8
    H Live TV info OSD not displaying number of audio channels General Support 3
    T Moving Pictures...seem to have 'lost' ability to display Movie info. (eg Resolution/Audio) Moving Pictures 2
    N [fixed] [MP2-786] Cannot play audio playlist with >=1000 entries 2.2 Archive 36
    Similar threads

























    Top Bottom