[solved] Beginner needs help recording live TV (1 Viewer)

Ufiti

New Member
December 23, 2019
9
0
42
Home Country
United States of America United States of America
Country flag
I've installed and setup Mediaportal 2, so I am now receiving OTA TV. But I cannot, for the life of me, figure out how to record live TV. There is no RECORD button anywhere. What am I missing? I've tried searching the documentation and forums and Google. All I can find is info about MediaPortal1. Can someone please point me in the right direction? All I want to use this for is watching live TV and hitting record whenever something comes on that I want to record. Scheduling recordings is not something I'm interested in. Thanks!
 

HTPCSourcer

Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Home Country
    Germany Germany
    Country flag
    I've tried searching the documentation
    On the homepage is an entry "Documentation" that links the Wiki: MediaPortal 2
    how to record live TV
    • Mouse: move the mouse on the screen and you'll see a red "record" button. Its location depends on which skin/theme you are using
    • Remote: pres the standard record button
    • Keyboard: press the "Windows" key to bring up the info menu and navigate to the red "record" menu entry with the cursor keys
    However, without an EPG you can only do manual recordings. If you are using something like SchedulesDirect, you can import the information into MediaPortal. There should be plenty of threads about EPG in the US.
     

    Ufiti

    New Member
    December 23, 2019
    9
    0
    42
    Home Country
    United States of America United States of America
    Country flag
    Thanks for the reply, but this still isn't helping. There is no red record button when I mouse over, see the attached screenshot. I'm using the default theme. I installed the main client and server and nothing else. Is there any reason the record button would not be here? I do not have a remote and hitting the "Windows" key does nothing but open the START menu.

    If I mouse over and hit the right mouse button I get the "Player Configuration" menu, but that also has no options for recording. Only "Zoom mode", "Effect", "Subtitle", "Choose audio stream", "Mute", and "Close".

    And as I said, I'm not interested in scheduled recording, only manual. I can use my TIVO for scheduled.
     

    Attachments

    • Annotation 2019-12-23 181336.png
      Annotation 2019-12-23 181336.png
      612 KB · Views: 20
    Last edited:

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Home Country
    Germany Germany
    Country flag
    I'm using the default theme.
    Is the behavior the same in other themes, e. g. Win10?

    Did you enter network credentials in the settings? Logs would be helpful if the problem persists.

    as I said, I'm not interested in scheduled recording, only manual.,
    That won't work well without epg data. In that case you can either record until you stop the recording process manually or the recording will run forever.
     

    Ufiti

    New Member
    December 23, 2019
    9
    0
    42
    Home Country
    United States of America United States of America
    Country flag
    Here are the logs. Win10 is my operating system. I'll have to figure out how to find/change themes.
     

    Attachments

    • MediaPortal2-Logs-2019-12-24-00.24.11.zip
      457.3 KB · Views: 4

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Home Country
    Germany Germany
    Country flag
    Dokan didn't get installed - or is not working.

    Uninstall MP2, your data remain untouched. Then reinstall the software. If you have used IE or Edge for the download, make sure to tick the "allow access" in the file properties of the zip before unpacking or launching the setup from within the zip.
     

    Ufiti

    New Member
    December 23, 2019
    9
    0
    42
    Home Country
    United States of America United States of America
    Country flag
    Okay, uninstalled, restarted, downloaded the newest version, reinstalled. While installing I saw it said it was installing Dokan. Scanned for channels, TV works... but still no RECORD button anywhere. New log attached.
     

    Attachments

    • MediaPortal2-Logs-2019-12-24-01.43.22.zip
      485.2 KB · Views: 4

    Ufiti

    New Member
    December 23, 2019
    9
    0
    42
    Home Country
    United States of America United States of America
    Country flag
    Sorry, just figured out how to do that. So I switched to the "Win10" theme. There is now a button with a red circle in the top bar (Screencaps attached). However, when I hit it the windows darkens and a white box comes up that says "Recording Actions". When I click it disappears. Going into my recordings folder there is nothing there. What am I missing now?
     

    Attachments

    • Annotation 2019-12-24 021105.png
      Annotation 2019-12-24 021105.png
      351 KB · Views: 18
    • Annotation 2019-12-24 021126.png
      Annotation 2019-12-24 021126.png
      538.6 KB · Views: 19

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Home Country
    Germany Germany
    Country flag
    No more errors in the logs. I believe that you need EPG data for the recording to be functional. The menu would normally offer you to record the current show or record until stopped manually
     
    Last edited:

    Users who are viewing this thread

    Similar threads

    "TV Server" can produce logs with various levels of detail. The level that has the most detail is DEBUG level, but this is not the default. So the first thing that you need to do is start "TV Server Config" and change the log level to DEBUG; see this page in the Wiki. Actually, I run my HTPC with the log level set to DEBUG all of the...
    "TV Server" can produce logs with various levels of detail. The level that has the most detail is DEBUG level, but this is not the...
    Hi Folks, Are there any TV recording logs available in MP2, and if so could someone let me know where to look? I have a weird...
    Replies
    1
    Views
    333
    Settings -> Players -> Video Player -> Subtitles -> Select ATSC Closed Captions. There does seem to be a bug with enabling/disabling ATSC subtitles from within the submenu. Also haven't been able to setup a function shortcut to enable/disable ATSC subtitles.
    Settings -> Players -> Video Player -> Subtitles -> Select ATSC Closed Captions. There does seem to be a bug with...
    I am using MP 2.3.2 64bit on Win10. For OTA TV here in the US, I can not figure out how to enable Closed Captioning/Subtitles. The...
    Replies
    1
    Views
    280
    Could be that a sudden powercut corrupts the database, or give all your pcs a new ipadres, or several more things that can break up a running mediaportal setup. Without the logs however, I don't have a clue on what exactly is wrong...
    Could be that a sudden powercut corrupts the database, or give all your pcs a new ipadres, or several more things that can break up...
    Hi there, I'm a happy long time user and am currently using MP 1.25. Up until now I had no issues with my setup. Yesterday...
    Replies
    1
    Views
    412
    Ok, the importer also remembers the queue of items that are still needed to be processed in settings file. If there is something stuck, it will try again on next server start and probably stuck again. But removing the media source also removes the associated queue. The server's TV plugin automatically creates the media sources for...
    Ok, the importer also remembers the queue of items that are still needed to be processed in settings file. If there is something...
    Hi, I’ve been struggling with MP 2 now for several weeks. Initially all was fine. Then in the client, the listings of recorded TV...
    Replies
    8
    Views
    812
    Thank you for performing this test, and confirming @joecrow 's suspicion as to the cause of the problem. In principle the same problem exists with other EPG sources, such as the broadcast EPG that I use with DVB-T/T2. When a programme first appears in the EPG (7 days ahead of its broadcast time), some programmes have a generic...
    Thank you for performing this test, and confirming @joecrow 's suspicion as to the cause of the problem. In principle the same...
    TV Server 1.25. Windows 10. This has been an issue for many years, if not since inception, and I hoped it would be resolved...
    Replies
    10
    Views
    1K
    Top Bottom